at-spi.spec revision 15311
10139N/A#
10139N/A# spec file for package at-spi
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
11311N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: liyuan
10139N/A#
17185N/A%define pythonver 2.4
10139N/A
10139N/AName: at-spi
10139N/ALicense: LGPL v2
10139N/AGroup: System/Libraries
10139N/AVersion: 1.24.0
19093N/ARelease: 1
18688N/ADistribution: Java Desktop System
18688N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Assistive Technology Service Provider Interface
19013N/ASource: http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
12745N/A%endif
10139N/AURL: http://developer.gnome.org/projects/gap/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19142N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
16401N/APrereq: /sbin/ldconfig
10139N/A
20829N/A%define gtk2_version 2.4.0
10139N/A%define libbonobo_version 2.6.0
10139N/A%define atk_version 1.7.2
12533N/A%define gail_version 1.6.3
10139N/A
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
20829N/ABuildRequires: gail-devel >= %{gail_version}
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gail >= %{gail_version}
10139N/A
10139N/A%description
10139N/Aat-spi allows assistive technologies to access GTK-based
10139N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
13645N/Ascripting interfaces can query and interact with GUI controls.
15759N/A
16837N/A%package devel
10139N/ASummary: Assistive Technology Service Provider Developer Interface
10139N/AGroup: Development/Libraries/GNOME
16401N/ARequires: %{name} = %{version}
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/ARequires: atk-devel >= %{atk_version}
10139N/A
10139N/A%description devel
10139N/Aat-spi allows assistive technologies to access GTK-based
10139N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
10139N/Ascripting interfaces can query and interact with GUI controls.
12533N/A
10139N/A%prep
10139N/A%setup -q
13645N/A
15759N/A%build
16837N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
18138N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18397N/A%endif
18850N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18850N/A CPUS=1
18850N/Afi
18850N/A
19789N/Aintltoolize --force --copy --automake
19789N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Alibtoolize -f
19142N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="%optflags"
10139N/ALDFLAGS="%{_ldflags}"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A %{gtk_doc_option}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
17974N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
17974N/A
10139N/A# Move to vendor-packages
10139N/A#if [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10139N/A#mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
16837N/A# $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/A#fi
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/libspi*.so.*
10139N/A%{_libdir}/libcspi*.so.*
10139N/A%{_libdir}/libloginhelper*.so.*
10139N/A%{_libdir}/gtk-2.0/modules/*.so
10139N/A%{_libdir}/bonobo/servers/*.server
10139N/A%{_libdir}/orbit-2.0/*.so
10139N/A%{_libexecdir}/at-spi-registryd
14341N/A%{_datadir}/locale/*
14341N/A
14341N/A%files devel
14341N/A%defattr(-, root, root)
14341N/A%{_includedir}/at-spi-1.0/cspi/*.h
10139N/A%{_includedir}/at-spi-1.0/libspi/*.h
10139N/A%{_includedir}/at-spi-1.0/login-helper/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/gtk-doc/html
10139N/A%{_datadir}/idl
17866N/A%{_libdir}/libspi*.so
17866N/A%{_libdir}/libcspi*.so
10139N/A%{_libdir}/libloginhelper*.so
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
17866N/A* Wed Nov 05 2008 - li.yuan@sun.com
17866N/A- Change copyright information.
17866N/A* Mon Sep 29 2008 - christian.kelly@sun.com
10139N/A- Take out mv site-packages to vendor-packages.
10139N/A* Sun Sep 28 2008 - patrick.ale@gmail.com
10139N/A- Correct download URL
10139N/A* Sat Sep 27 2008 - christian.kelly@sun.com
10139N/A- Bump to 1.24.0.
10139N/A* Thu Sep 11 2008 - christian.kelly@sun.com
10139N/A- Bump to 1.23.92, add libtoolize -f to fix build issue.
10139N/A* Tue Sep 02 2008 - christian.kelly@sun.com
10139N/A- Bump to 1.23.91.
10139N/A* Tue Aug 05 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.23.6.
10139N/A* Mon Jul 21 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.23.5. Remove upstream patch 01-uninstalled.
10139N/A* Wed Jul 09 2008 - damien.carbery@sun.com
10139N/A- Add patch 01-uninstalled to fix bugzilla #542217.
10139N/A* Mon Jul 07 2008 - li.yuan@sun.com
10139N/A- Fix 6697334. Add 64 bit libraries support.
10139N/A* Tue Jun 03 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.23.3.
10139N/A* Mon Mar 10 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.22.0.
19784N/A* Mon Feb 25 2008 - damien.carbery@sun.com
19784N/A- Bump to 1.21.92.
18850N/A* Mon Jan 14 2008 - damien.carbery@sun.com
18850N/A- Bump to 1.21.5.
18397N/A* Thu Jan 10 2008 - li.yuan@sun.com
18397N/A- change owner to liyuan.
18098N/A* Tue Dec 04 2007 - damien.carbery@sun.com
18098N/A- Bump to 1.21.3.
17986N/A* Tue Oct 30 2007 - damien.carbery@sun.com
17986N/A- Bump to 1.21.1.
17912N/A* Fri Oct 19 2007 - damien.carbery@sun.com
17912N/A- Bump to 1.20.1.
17286N/A* Wed Oct 10 2007 - damien.carbery@sun.com
17286N/A- Move files from site-packages to vendor-packages. Fixes 6615442.
16837N/A* Tue Sep 18 2007 - damien.carbery@sun.com
16837N/A- Bump to 1.20.0.
16837N/A* Wed Aug 29 2007 - damien.carbery@sun.com
15759N/A- Add intltoolize call to update intltool scripts.
15759N/A* Wed Jul 11 2007 - damien.carbery@sun.com
14341N/A- Bump to 1.19.5.
14341N/A* Wed Jun 06 2007 - damien.carbery@sun.com
13645N/A- Bump to 1.19.3.
13645N/A* Thu May 10 2007 - damien.carbery@sun.com
12745N/A- Bump to 1.19.1.
12745N/A* Thu Apr 12 2007 - damien.carbery@sun.com
12084N/A- Bump to 1.18.1.
12084N/A* Mon Mar 12 2007 - damien.carbery@sun.com
12084N/A- Bump to 1.18.0.
12084N/A* Mon Mar 05 2007 - damien.carbery@sun.com
11859N/A- Bump to 1.17.2.
11859N/A* Wed Feb 28 2007 - li.yuan@sun.com
11311N/A- Remove upstream patch, at-spi-01-get-attributes-crash.diff
11311N/A* Tue Feb 13 2007 - damien.carbery@sun.com
11311N/A- Bump to 1.17.0.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.7.16.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.7.15.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.14. Remove upstream patch, at-spi-01-fix-leak.diff.
10139N/A* Fri Dec 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.13.
10139N/A* Fri Nov 10 2006 - padraig.obriain@sun.com
10139N/A- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
10139N/A 01-fix-leak.diff
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Wed Oct 11 2006 - padraig.obriain@sun.com
10139N/A- Add patch 02-fix-leak to fix bug 6457388
10139N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.12.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.11.
10139N/A* Tue Jul 25 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.10.
10139N/A* Wed Jul 19 2006 - dermot.mccluskey@sun.com
10139N/A- Bump to 1.7.9
10139N/A* Mon Apr 01 2006 - padraig.obriain@sun.com
10139N/A- Add patch 01-define-symbols so that gok builds.
10139N/A* Fri Mar 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.7.
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.6.
10139N/A* Thu Feb 23 2006 - damien.carbery@sun.com
10139N/A- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
10139N/A* Tue Feb 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.5.
10139N/A* Thu Feb 16 2006 - brian.cameron@sun.com
10139N/A- Add "make clean" hack to ensure that the bonobo
10139N/A registry server file is built with the right
10139N/A sysconfdir.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.4.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.3.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.2.
10139N/A* Thu Sep 08 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.6.6.
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.6.5.
10139N/A* Tue Aug 23 2005 - damien.carbery@sun.com
10139N/A- Move CFLAGS setting as it was useless in original location.
10139N/A* Tue Jun 14 2005 - brian.cameron@sun.com
10139N/A- Added aclocal/automake/autoconf, needed for Solaris build.
10139N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
10139N/A- Bump to 1.6.4
10139N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
10139N/A- Bump to 1.6.3
10139N/A* Tue Apr 5 2005 - bill.haneman@sun.com
10139N/A- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
10139N/A* Thu Dec 9 2004 - bill.haneman@sun.com
10139N/A- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
10139N/A* Wed Sep 1 2004 - bill.haneman@sun.com
10139N/A- Bumped to version 1.5.4, to include fixes for
10139N/A- activation issues with DISPLAY env, and gnopernicus
10139N/A- dependencies.
10139N/A* Tue Aug 31 2004 - bill.haneman@sun.com
10139N/A- Removed patch since #5088625 has been fixed, and
10139N/A- the patch is incompatible with the fix.
10139N/A* Wed Aug 18 2004 - bill.haneman@sun.com
10139N/A- added patch from Padraig to work around P1/S2 bug #5088625.
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri Jun 11 2004 - dermot.mccluskey@sun.com
10139N/A- add login-helper headers and lib to %files
10139N/A* Wed Jun 02 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.5.2
10139N/A* Fri Apr 30 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.5.1
10139N/A* Tue Mar 23 2004 - <brian.cameron@sun.com>
10139N/A- Remove "patch -p1" from the %prep section since
10139N/A the patch was removed, and this is causing an
10139N/A error on Solaris build.
10139N/A* Tue Mar 23 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.4.0, remove reference to
10139N/A at-spi-01-uninstalled-idldir.diff
10139N/A* Mon Mar 22 2004 - <laca@sun.com>
10139N/A- backport idldir fix in uninstalled.pc files from HEAD
10139N/A* Tue Mar 16 2004 - <glynn.foster@sun.com>
10139N/A- Remove the uninstalled-pc patch as it's
10139N/A upstream now.
10139N/A* Thu Mar 11 2004 - <damien.carbery@sun.com>
10139N/A- Reset release to 1.
10139N/A* Wed Mar 10 2004 - <damien.carbery@sun.com>
10139N/A- Bump to 1.3.15
10139N/A* Mon Feb 23 2004 - damien.carbery@sun.com
10139N/A- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
10139N/A* Wed Feb 18 2004 - matt.keenan@sun.com
10139N/A- tarball upgrade to 1.3.12, add manpages, update %files
16401N/A* Wed Dec 16 2003 - glynn.foster@sun.com
19189N/A- tarball upgrade to 1.3.9
19506N/A* Fri Oct 10 2003 - Laszlo.Kovacs@sun.com
- tarball upgrade
* Thu Aug 14 2003 - <laca@sun.com>
- move *.so to -devel, remove *.a and *.al
* Thu May 08 2003 - ghee.teo@Sun.COM
- Created new spec file for at-spi