at-spi.spec revision 14542
0N/A#
431N/A# spec file for package at-spi
0N/A#
0N/A# Copyright (c) 2008 Sun Microsystems, Inc.
0N/A# This file and all modifications and additions to the pristine
0N/A# package are under the same license as the package itself.
0N/A#
0N/A# Owner: liyuan
0N/A#
0N/A%define pythonver 2.4
0N/A
0N/AName: at-spi
0N/ALicense: LGPL
0N/AGroup: System/Libraries
0N/AVersion: 1.24.0
0N/ARelease: 1
0N/ADistribution: Java Desktop System
0N/AVendor: Sun Microsystems, Inc.
0N/ASummary: Assistive Technology Service Provider Interface
0N/ASource: http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.23/%{name}-%{version}.tar.bz2
0N/A%if %build_l10n
0N/ASource1: l10n-configure.sh
0N/A%endif
0N/AURL: http://developer.gnome.org/projects/gap/
0N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
0N/ADocdir: %{_defaultdocdir}/%{name}
0N/AAutoreqprov: on
0N/APrereq: /sbin/ldconfig
0N/A
0N/A%define gtk2_version 2.4.0
0N/A%define libbonobo_version 2.6.0
0N/A%define atk_version 1.7.2
0N/A%define gail_version 1.6.3
0N/A
0N/ABuildRequires: gtk2-devel >= %{gtk2_version}
0N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
0N/ABuildRequires: gail-devel >= %{gail_version}
0N/ARequires: gtk2 >= %{gtk2_version}
0N/ARequires: libbonobo >= %{libbonobo_version}
0N/ARequires: gail >= %{gail_version}
0N/A
0N/A%description
0N/Aat-spi allows assistive technologies to access GTK-based
0N/Aapplications. Essentially it exposes the internals of applications for
0N/Aautomation, so tools such as screen readers, magnifiers, or even
0N/Ascripting interfaces can query and interact with GUI controls.
0N/A
0N/A%package devel
0N/ASummary: Assistive Technology Service Provider Developer Interface
0N/AGroup: Development/Libraries/GNOME
0N/ARequires: %{name} = %{version}
0N/ARequires: libbonobo-devel >= %{libbonobo_version}
0N/ARequires: atk-devel >= %{atk_version}
0N/A
0N/A%description devel
0N/Aat-spi allows assistive technologies to access GTK-based
0N/Aapplications. Essentially it exposes the internals of applications for
0N/Aautomation, so tools such as screen readers, magnifiers, or even
0N/Ascripting interfaces can query and interact with GUI controls.
0N/A
0N/A%prep
0N/A%setup -q
0N/A
0N/A%build
0N/A%ifos linux
0N/Aif [ -x /usr/bin/getconf ]; then
0N/A CPUS=`getconf _NPROCESSORS_ONLN`
0N/Afi
0N/A%else
0N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
0N/A%endif
0N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
0N/A CPUS=1
0N/Afi
0N/A
0N/Aintltoolize --force --copy --automake
0N/A
0N/A%if %build_l10n
0N/Abash -x %SOURCE1 --enable-copyright
0N/A%endif
0N/A
0N/Alibtoolize -f
0N/Aaclocal $ACLOCAL_FLAGS
0N/Aautomake -a -c -f
0N/Aautoconf
0N/ACFLAGS="%optflags"
398N/ALDFLAGS="%{_ldflags}"
398N/A./configure --prefix=%{_prefix} \
398N/A --libdir=%{_libdir} \
398N/A --bindir=%{_bindir} \
398N/A --sysconfdir=%{_sysconfdir} \
398N/A --mandir=%{_mandir} \
398N/A --libexecdir=%{_libexecdir} \
398N/A %{gtk_doc_option}
430N/Amake -j $CPUS
0N/A
0N/A%install
0N/Amake DESTDIR=$RPM_BUILD_ROOT install
0N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
0N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
0N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
0N/A
0N/A# Move to vendor-packages
0N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
0N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
0N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
0N/Afi
0N/A
117N/A%clean
535N/Arm -rf $RPM_BUILD_ROOT
117N/A
0N/A%post
0N/A/sbin/ldconfig
0N/A
0N/A%postun
0N/A/sbin/ldconfig
0N/A
0N/A%files
0N/A%defattr(-,root,root)
0N/A%{_libdir}/libspi*.so.*
0N/A%{_libdir}/libcspi*.so.*
0N/A%{_libdir}/libloginhelper*.so.*
0N/A%{_libdir}/gtk-2.0/modules/*.so
0N/A%{_libdir}/bonobo/servers/*.server
0N/A%{_libdir}/orbit-2.0/*.so
0N/A%{_libexecdir}/at-spi-registryd
0N/A%{_datadir}/locale/*
0N/A
0N/A%files devel
0N/A%defattr(-, root, root)
0N/A%{_includedir}/at-spi-1.0/cspi/*.h
0N/A%{_includedir}/at-spi-1.0/libspi/*.h
0N/A%{_includedir}/at-spi-1.0/login-helper/*.h
0N/A%{_libdir}/pkgconfig/*.pc
0N/A%{_datadir}/gtk-doc/html
0N/A%{_datadir}/idl
0N/A%{_libdir}/libspi*.so
0N/A%{_libdir}/libcspi*.so
0N/A%{_libdir}/libloginhelper*.so
0N/A%{_mandir}/man3/*
0N/A
0N/A%changelog
0N/A* Sat Sep 27 2008 - christian.kelly@sun.com
0N/A- Bump to 1.24.0.
0N/A* Thu Sep 11 2008 - christian.kelly@sun.com
0N/A- Bump to 1.23.92, add libtoolize -f to fix build issue.
0N/A* Tue Sep 02 2008 - christian.kelly@sun.com
0N/A- Bump to 1.23.91.
0N/A* Tue Aug 05 2008 - damien.carbery@sun.com
0N/A- Bump to 1.23.6.
0N/A* Mon Jul 21 2008 - damien.carbery@sun.com
0N/A- Bump to 1.23.5. Remove upstream patch 01-uninstalled.
0N/A* Wed Jul 09 2008 - damien.carbery@sun.com
0N/A- Add patch 01-uninstalled to fix bugzilla #542217.
0N/A* Mon Jul 07 2008 - li.yuan@sun.com
0N/A- Fix 6697334. Add 64 bit libraries support.
0N/A* Tue Jun 03 2008 - damien.carbery@sun.com
0N/A- Bump to 1.23.3.
0N/A* Mon Mar 10 2008 - damien.carbery@sun.com
0N/A- Bump to 1.22.0.
0N/A* Mon Feb 25 2008 - damien.carbery@sun.com
0N/A- Bump to 1.21.92.
0N/A* Mon Jan 14 2008 - damien.carbery@sun.com
0N/A- Bump to 1.21.5.
0N/A* Thu Jan 10 2008 - li.yuan@sun.com
0N/A- change owner to liyuan.
0N/A* Tue Dec 04 2007 - damien.carbery@sun.com
0N/A- Bump to 1.21.3.
0N/A* Tue Oct 30 2007 - damien.carbery@sun.com
0N/A- Bump to 1.21.1.
0N/A* Fri Oct 19 2007 - damien.carbery@sun.com
0N/A- Bump to 1.20.1.
0N/A* Wed Oct 10 2007 - damien.carbery@sun.com
0N/A- Move files from site-packages to vendor-packages. Fixes 6615442.
0N/A* Tue Sep 18 2007 - damien.carbery@sun.com
0N/A- Bump to 1.20.0.
0N/A* Wed Aug 29 2007 - damien.carbery@sun.com
0N/A- Add intltoolize call to update intltool scripts.
0N/A* Wed Jul 11 2007 - damien.carbery@sun.com
0N/A- Bump to 1.19.5.
0N/A* Wed Jun 06 2007 - damien.carbery@sun.com
0N/A- Bump to 1.19.3.
0N/A* Thu May 10 2007 - damien.carbery@sun.com
0N/A- Bump to 1.19.1.
0N/A* Thu Apr 12 2007 - damien.carbery@sun.com
0N/A- Bump to 1.18.1.
0N/A* Mon Mar 12 2007 - damien.carbery@sun.com
0N/A- Bump to 1.18.0.
0N/A* Mon Mar 05 2007 - damien.carbery@sun.com
0N/A- Bump to 1.17.2.
0N/A* Wed Feb 28 2007 - li.yuan@sun.com
0N/A- Remove upstream patch, at-spi-01-get-attributes-crash.diff
0N/A* Tue Feb 13 2007 - damien.carbery@sun.com
0N/A- Bump to 1.17.0.
0N/A* Mon Jan 22 2007 - damien.carbery@sun.com
0N/A- Bump to 1.7.16.
0N/A* Mon Jan 08 2007 - damien.carbery@sun.com
0N/A- Bump to 1.7.15.
0N/A* Tue Dec 19 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.14. Remove upstream patch, at-spi-01-fix-leak.diff.
0N/A* Fri Dec 08 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.13.
0N/A* Fri Nov 10 2006 - padraig.obriain@sun.com
0N/A- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
0N/A 01-fix-leak.diff
0N/A* Fri Nov 3 2006 - laca@sun.com
0N/A- use %gtk_doc_option in configure so that it can be disabled using
0N/A --without-gtk-doc
0N/A* Wed Oct 11 2006 - padraig.obriain@sun.com
0N/A- Add patch 02-fix-leak to fix bug 6457388
0N/A* Mon Oct 02 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.12.
0N/A* Tue Aug 22 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.11.
0N/A* Tue Jul 25 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.10.
0N/A* Wed Jul 19 2006 - dermot.mccluskey@sun.com
0N/A- Bump to 1.7.9
0N/A* Mon Apr 01 2006 - padraig.obriain@sun.com
0N/A- Add patch 01-define-symbols so that gok builds.
0N/A* Fri Mar 31 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.7.
0N/A* Tue Feb 28 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.6.
0N/A* Thu Feb 23 2006 - damien.carbery@sun.com
0N/A- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
0N/A* Tue Feb 21 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.5.
0N/A* Thu Feb 16 2006 - brian.cameron@sun.com
0N/A- Add "make clean" hack to ensure that the bonobo
0N/A registry server file is built with the right
0N/A sysconfdir.
0N/A* Tue Jan 31 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.4.
0N/A* Tue Jan 31 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.3.
0N/A* Fri Jan 20 2006 - damien.carbery@sun.com
0N/A- Bump to 1.7.2.
0N/A* Thu Sep 08 2005 - damien.carbery@sun.com
0N/A- Bump to 1.6.6.
0N/A* Mon Sep 05 2005 - damien.carbery@sun.com
0N/A- Bump to 1.6.5.
0N/A* Tue Aug 23 2005 - damien.carbery@sun.com
0N/A- Move CFLAGS setting as it was useless in original location.
0N/A* Tue Jun 14 2005 - brian.cameron@sun.com
0N/A- Added aclocal/automake/autoconf, needed for Solaris build.
0N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
0N/A- Bump to 1.6.4
0N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
0N/A- Bump to 1.6.3
0N/A* Tue Apr 5 2005 - bill.haneman@sun.com
0N/A- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
0N/A* Thu Dec 9 2004 - bill.haneman@sun.com
0N/A- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
398N/A* Wed Sep 1 2004 - bill.haneman@sun.com
398N/A- Bumped to version 1.5.4, to include fixes for
398N/A- activation issues with DISPLAY env, and gnopernicus
0N/A- dependencies.
0N/A* Tue Aug 31 2004 - bill.haneman@sun.com
0N/A- Removed patch since #5088625 has been fixed, and
0N/A- the patch is incompatible with the fix.
0N/A* Wed Aug 18 2004 - bill.haneman@sun.com
0N/A- added patch from Padraig to work around P1/S2 bug #5088625.
0N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
0N/A- added "-j $CPUS" to make to speed up builds
0N/A* Fri Jun 11 2004 - dermot.mccluskey@sun.com
0N/A- add login-helper headers and lib to %files
0N/A* Wed Jun 02 2004 - <padraig.obriain@sun.com>
0N/A- Bump version to 1.5.2
0N/A* Fri Apr 30 2004 - <padraig.obriain@sun.com>
0N/A- Bump version to 1.5.1
0N/A* Tue Mar 23 2004 - <brian.cameron@sun.com>
0N/A- Remove "patch -p1" from the %prep section since
0N/A the patch was removed, and this is causing an
0N/A error on Solaris build.
0N/A* Tue Mar 23 2004 - <padraig.obriain@sun.com>
0N/A- Bump version to 1.4.0, remove reference to
0N/A at-spi-01-uninstalled-idldir.diff
0N/A* Mon Mar 22 2004 - <laca@sun.com>
0N/A- backport idldir fix in uninstalled.pc files from HEAD
0N/A* Tue Mar 16 2004 - <glynn.foster@sun.com>
0N/A- Remove the uninstalled-pc patch as it's
0N/A upstream now.
0N/A* Thu Mar 11 2004 - <damien.carbery@sun.com>
0N/A- Reset release to 1.
0N/A* Wed Mar 10 2004 - <damien.carbery@sun.com>
0N/A- Bump to 1.3.15
0N/A* Mon Feb 23 2004 - damien.carbery@sun.com
0N/A- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
0N/A* Wed Feb 18 2004 - matt.keenan@sun.com
0N/A- tarball upgrade to 1.3.12, add manpages, update %files
0N/A* Wed Dec 16 2003 - glynn.foster@sun.com
0N/A- tarball upgrade to 1.3.9
0N/A* Fri Oct 10 2003 - Laszlo.Kovacs@sun.com
0N/A- tarball upgrade
0N/A* Thu Aug 14 2003 - <laca@sun.com>
0N/A- move *.so to -devel, remove *.a and *.al
0N/A* Thu May 08 2003 - ghee.teo@Sun.COM
0N/A- Created new spec file for at-spi
0N/A