at-spi.spec revision 13505
342N/A#
1472N/A# spec file for package at-spi
342N/A#
342N/A# Copyright (c) 2008 Sun Microsystems, Inc.
342N/A# This file and all modifications and additions to the pristine
342N/A# package are under the same license as the package itself.
342N/A#
342N/A# Owner: liyuan
342N/A#
342N/A%define pythonver 2.4
342N/A
342N/AName: at-spi
342N/ALicense: LGPL
342N/AGroup: System/Libraries
342N/AVersion: 1.23.3
342N/ARelease: 1
342N/ADistribution: Java Desktop System
342N/AVendor: Sun Microsystems, Inc.
1472N/ASummary: Assistive Technology Service Provider Interface
1472N/ASource: http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.23/%{name}-%{version}.tar.bz2
1472N/A%if %build_l10n
342N/ASource1: l10n-configure.sh
342N/A%endif
342N/AURL: http://developer.gnome.org/projects/gap/
342N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
342N/ADocdir: %{_defaultdocdir}/%{name}
342N/AAutoreqprov: on
342N/APrereq: /sbin/ldconfig
342N/A
342N/A%define gtk2_version 2.4.0
342N/A%define libbonobo_version 2.6.0
342N/A%define atk_version 1.7.2
342N/A%define gail_version 1.6.3
342N/A
342N/ABuildRequires: gtk2-devel >= %{gtk2_version}
342N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
342N/ABuildRequires: gail-devel >= %{gail_version}
342N/ARequires: gtk2 >= %{gtk2_version}
342N/ARequires: libbonobo >= %{libbonobo_version}
342N/ARequires: gail >= %{gail_version}
342N/A
342N/A%description
342N/Aat-spi allows assistive technologies to access GTK-based
342N/Aapplications. Essentially it exposes the internals of applications for
342N/Aautomation, so tools such as screen readers, magnifiers, or even
342N/Ascripting interfaces can query and interact with GUI controls.
342N/A
342N/A%package devel
342N/ASummary: Assistive Technology Service Provider Developer Interface
342N/AGroup: Development/Libraries/GNOME
342N/ARequires: %{name} = %{version}
342N/ARequires: libbonobo-devel >= %{libbonobo_version}
342N/ARequires: atk-devel >= %{atk_version}
342N/A
342N/A%description devel
342N/Aat-spi allows assistive technologies to access GTK-based
342N/Aapplications. Essentially it exposes the internals of applications for
342N/Aautomation, so tools such as screen readers, magnifiers, or even
1311N/Ascripting interfaces can query and interact with GUI controls.
1311N/A
342N/A%prep
807N/A%setup -q
807N/A
807N/A
342N/A%build
342N/A%ifos linux
342N/Aif [ -x /usr/bin/getconf ]; then
342N/A CPUS=`getconf _NPROCESSORS_ONLN`
342N/Afi
342N/A%else
342N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
342N/A%endif
342N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
342N/A CPUS=1
342N/Afi
342N/A
342N/Aintltoolize --force --copy --automake
342N/A
342N/A%if %build_l10n
342N/Abash -x %SOURCE1 --enable-copyright
342N/A%endif
342N/A
342N/Aaclocal $ACLOCAL_FLAGS
1394N/Aautomake -a -c -f
1394N/Aautoconf
1394N/ACFLAGS="%optflags"
1394N/ALDFLAGS="%{_ldflags}"
1394N/A./configure --prefix=%{_prefix} \
342N/A --libdir=%{_libdir} \
1394N/A --bindir=%{_bindir} \
342N/A --sysconfdir=%{_sysconfdir} \
342N/A --mandir=%{_mandir} \
342N/A --libexecdir=%{_libexecdir} \
342N/A %{gtk_doc_option}
1394N/Amake -j $CPUS
342N/A
342N/A%install
342N/Amake DESTDIR=$RPM_BUILD_ROOT install
342N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
1394N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
1394N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
1394N/A
1394N/A# Move to vendor-packages
1394N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
1394N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
1394N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
342N/Afi
342N/A
342N/A%clean
342N/Arm -rf $RPM_BUILD_ROOT
342N/A
342N/A%post
342N/A/sbin/ldconfig
342N/A
342N/A%postun
342N/A/sbin/ldconfig
342N/A
342N/A%files
1394N/A%defattr(-,root,root)
1394N/A%{_libdir}/libspi*.so.*
1394N/A%{_libdir}/libcspi*.so.*
1394N/A%{_libdir}/libloginhelper*.so.*
1394N/A%{_libdir}/gtk-2.0/modules/*.so
1394N/A%{_libdir}/bonobo/servers/*.server
1394N/A%{_libdir}/orbit-2.0/*.so
1394N/A%{_libexecdir}/at-spi-registryd
342N/A%{_datadir}/locale/*
342N/A
545N/A%files devel
342N/A%defattr(-, root, root)
342N/A%{_includedir}/at-spi-1.0/cspi/*.h
342N/A%{_includedir}/at-spi-1.0/libspi/*.h
1394N/A%{_includedir}/at-spi-1.0/login-helper/*.h
342N/A%{_libdir}/pkgconfig/*.pc
342N/A%{_datadir}/gtk-doc/html
342N/A%{_datadir}/idl
342N/A%{_libdir}/libspi*.so
342N/A%{_libdir}/libcspi*.so
342N/A%{_libdir}/libloginhelper*.so
342N/A%{_mandir}/man3/*
342N/A
342N/A%changelog
342N/A* Mon Jul 07 2008 - li.yuan@sun.com
342N/A- Fix 6697334. Add 64 bit libraries support.
342N/A* Tue Jun 03 2008 - damien.carbery@sun.com
342N/A- Bump to 1.23.3.
342N/A* Mon Mar 10 2008 - damien.carbery@sun.com
342N/A- Bump to 1.22.0.
342N/A* Mon Feb 25 2008 - damien.carbery@sun.com
342N/A- Bump to 1.21.92.
342N/A* Mon Jan 14 2008 - damien.carbery@sun.com
342N/A- Bump to 1.21.5.
342N/A* Thu Jan 10 2008 - li.yuan@sun.com
342N/A- change owner to liyuan.
342N/A* Tue Dec 04 2007 - damien.carbery@sun.com
342N/A- Bump to 1.21.3.
342N/A* Tue Oct 30 2007 - damien.carbery@sun.com
342N/A- Bump to 1.21.1.
796N/A* Fri Oct 19 2007 - damien.carbery@sun.com
342N/A- Bump to 1.20.1.
342N/A* Wed Oct 10 2007 - damien.carbery@sun.com
342N/A- Move files from site-packages to vendor-packages. Fixes 6615442.
342N/A* Tue Sep 18 2007 - damien.carbery@sun.com
342N/A- Bump to 1.20.0.
342N/A* Wed Aug 29 2007 - damien.carbery@sun.com
342N/A- Add intltoolize call to update intltool scripts.
342N/A* Wed Jul 11 2007 - damien.carbery@sun.com
942N/A- Bump to 1.19.5.
942N/A* Wed Jun 06 2007 - damien.carbery@sun.com
342N/A- Bump to 1.19.3.
342N/A* Thu May 10 2007 - damien.carbery@sun.com
342N/A- Bump to 1.19.1.
342N/A* Thu Apr 12 2007 - damien.carbery@sun.com
342N/A- Bump to 1.18.1.
342N/A* Mon Mar 12 2007 - damien.carbery@sun.com
342N/A- Bump to 1.18.0.
342N/A* Mon Mar 05 2007 - damien.carbery@sun.com
342N/A- Bump to 1.17.2.
342N/A* Wed Feb 28 2007 - li.yuan@sun.com
342N/A- Remove upstream patch, at-spi-01-get-attributes-crash.diff
342N/A* Tue Feb 13 2007 - damien.carbery@sun.com
342N/A- Bump to 1.17.0.
342N/A* Mon Jan 22 2007 - damien.carbery@sun.com
342N/A- Bump to 1.7.16.
342N/A* Mon Jan 08 2007 - damien.carbery@sun.com
342N/A- Bump to 1.7.15.
342N/A* Tue Dec 19 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.14. Remove upstream patch, at-spi-01-fix-leak.diff.
342N/A* Fri Dec 08 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.13.
342N/A* Fri Nov 10 2006 - padraig.obriain@sun.com
342N/A- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
342N/A 01-fix-leak.diff
342N/A* Fri Nov 3 2006 - laca@sun.com
342N/A- use %gtk_doc_option in configure so that it can be disabled using
342N/A --without-gtk-doc
342N/A* Wed Oct 11 2006 - padraig.obriain@sun.com
342N/A- Add patch 02-fix-leak to fix bug 6457388
342N/A* Mon Oct 02 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.12.
342N/A* Tue Aug 22 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.11.
342N/A* Tue Jul 25 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.10.
342N/A* Wed Jul 19 2006 - dermot.mccluskey@sun.com
342N/A- Bump to 1.7.9
342N/A* Mon Apr 01 2006 - padraig.obriain@sun.com
342N/A- Add patch 01-define-symbols so that gok builds.
342N/A* Fri Mar 31 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.7.
636N/A* Tue Feb 28 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.6.
342N/A* Thu Feb 23 2006 - damien.carbery@sun.com
342N/A- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
342N/A* Tue Feb 21 2006 - damien.carbery@sun.com
545N/A- Bump to 1.7.5.
636N/A* Thu Feb 16 2006 - brian.cameron@sun.com
636N/A- Add "make clean" hack to ensure that the bonobo
636N/A registry server file is built with the right
636N/A sysconfdir.
636N/A* Tue Jan 31 2006 - damien.carbery@sun.com
636N/A- Bump to 1.7.4.
636N/A* Tue Jan 31 2006 - damien.carbery@sun.com
636N/A- Bump to 1.7.3.
342N/A* Fri Jan 20 2006 - damien.carbery@sun.com
342N/A- Bump to 1.7.2.
342N/A* Thu Sep 08 2005 - damien.carbery@sun.com
342N/A- Bump to 1.6.6.
342N/A* Mon Sep 05 2005 - damien.carbery@sun.com
1391N/A- Bump to 1.6.5.
1391N/A* Tue Aug 23 2005 - damien.carbery@sun.com
1391N/A- Move CFLAGS setting as it was useless in original location.
342N/A* Tue Jun 14 2005 - brian.cameron@sun.com
342N/A- Added aclocal/automake/autoconf, needed for Solaris build.
342N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
342N/A- Bump to 1.6.4
342N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
342N/A- Bump to 1.6.3
342N/A* Tue Apr 5 2005 - bill.haneman@sun.com
342N/A- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
342N/A* Thu Dec 9 2004 - bill.haneman@sun.com
342N/A- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
342N/A* Wed Sep 1 2004 - bill.haneman@sun.com
342N/A- Bumped to version 1.5.4, to include fixes for
342N/A- activation issues with DISPLAY env, and gnopernicus
342N/A- dependencies.
342N/A* Tue Aug 31 2004 - bill.haneman@sun.com
342N/A- Removed patch since #5088625 has been fixed, and
342N/A- the patch is incompatible with the fix.
342N/A* Wed Aug 18 2004 - bill.haneman@sun.com
526N/A- added patch from Padraig to work around P1/S2 bug #5088625.
526N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
526N/A- added "-j $CPUS" to make to speed up builds
526N/A* Fri Jun 11 2004 - dermot.mccluskey@sun.com
526N/A- add login-helper headers and lib to %files
526N/A* Wed Jun 02 2004 - <padraig.obriain@sun.com>
526N/A- Bump version to 1.5.2
526N/A* Fri Apr 30 2004 - <padraig.obriain@sun.com>
526N/A- Bump version to 1.5.1
526N/A* Tue Mar 23 2004 - <brian.cameron@sun.com>
526N/A- Remove "patch -p1" from the %prep section since
526N/A the patch was removed, and this is causing an
526N/A error on Solaris build.
526N/A* Tue Mar 23 2004 - <padraig.obriain@sun.com>
526N/A- Bump version to 1.4.0, remove reference to
526N/A at-spi-01-uninstalled-idldir.diff
526N/A* Mon Mar 22 2004 - <laca@sun.com>
526N/A- backport idldir fix in uninstalled.pc files from HEAD
526N/A* Tue Mar 16 2004 - <glynn.foster@sun.com>
526N/A- Remove the uninstalled-pc patch as it's
526N/A upstream now.
353N/A* Thu Mar 11 2004 - <damien.carbery@sun.com>
342N/A- Reset release to 1.
342N/A* Wed Mar 10 2004 - <damien.carbery@sun.com>
342N/A- Bump to 1.3.15
342N/A* Mon Feb 23 2004 - damien.carbery@sun.com
342N/A- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
342N/A* Wed Feb 18 2004 - matt.keenan@sun.com
342N/A- tarball upgrade to 1.3.12, add manpages, update %files
342N/A* Wed Dec 16 2003 - glynn.foster@sun.com
342N/A- tarball upgrade to 1.3.9
342N/A* Fri Oct 10 2003 - Laszlo.Kovacs@sun.com
342N/A- tarball upgrade
342N/A* Thu Aug 14 2003 - <laca@sun.com>
545N/A- move *.so to -devel, remove *.a and *.al
545N/A* Thu May 08 2003 - ghee.teo@Sun.COM
342N/A- Created new spec file for at-spi
342N/A