at-spi.spec revision 12451
10139N/A#
10139N/A# spec file for package at-spi
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: liyuan
10139N/A#
10139N/A%define pythonver 2.4
10139N/A
10139N/AName: at-spi
15291N/ALicense: LGPL
15295N/AGroup: System/Libraries
10139N/AVersion: 1.21.92
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Assistive Technology Service Provider Interface
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.21/%{name}-%{version}.tar.bz2
10139N/AURL: http://developer.gnome.org/projects/gap/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
11893N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
15372N/A
15372N/A%define gtk2_version 2.4.0
10139N/A%define libbonobo_version 2.6.0
10139N/A%define atk_version 1.7.2
10139N/A%define gail_version 1.6.3
10139N/A
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gail-devel >= %{gail_version}
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gail >= %{gail_version}
10139N/A
10139N/A%description
10139N/Aat-spi allows assistive technologies to access GTK-based
15372N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
10139N/Ascripting interfaces can query and interact with GUI controls.
10139N/A
10139N/A%package devel
10139N/ASummary: Assistive Technology Service Provider Developer Interface
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %{name} = %{version}
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/ARequires: atk-devel >= %{atk_version}
10139N/A
10139N/A%description devel
10139N/Aat-spi allows assistive technologies to access GTK-based
10139N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
15295N/Ascripting interfaces can query and interact with GUI controls.
10139N/A
10464N/A%prep
10139N/A%setup -q
10139N/A
13511N/A
13511N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10541N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aintltoolize --force --copy --automake
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
15372N/A --sysconfdir=%{_sysconfdir} \
15372N/A --mandir=%{_mandir} \
15372N/A --libexecdir=%{_libexecdir} \
15324N/A %{gtk_doc_option}
15324N/Amake -j $CPUS
15324N/A
15324N/A%install
15324N/Amake DESTDIR=$RPM_BUILD_ROOT install
15291N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
15295N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
15295N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
15295N/A
15324N/A# Move to vendor-packages
15295N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
15295N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
15291N/A
13511N/A%clean
13511N/Arm -rf $RPM_BUILD_ROOT
10541N/A
10542N/A%post
10542N/A/sbin/ldconfig
10542N/A
10542N/A%postun
10542N/A/sbin/ldconfig
10542N/A
10541N/A%files
10541N/A%defattr(-,root,root)
10541N/A%{_libdir}/libspi*.so.*
10541N/A%{_libdir}/libcspi*.so.*
10481N/A%{_libdir}/libloginhelper*.so.*
10481N/A%{_libdir}/gtk-2.0/modules/*.so
10481N/A%{_libdir}/bonobo/servers/*.server
10464N/A%{_libdir}/orbit-2.0/*.so
10471N/A%{_libexecdir}/at-spi-registryd
10471N/A%{_datadir}/locale/*
10471N/A
10464N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/at-spi-1.0/cspi/*.h
10139N/A%{_includedir}/at-spi-1.0/libspi/*.h
10471N/A%{_includedir}/at-spi-1.0/login-helper/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10471N/A%{_datadir}/gtk-doc/html
10471N/A%{_datadir}/idl
10139N/A%{_libdir}/libspi*.so
10139N/A%{_libdir}/libcspi*.so
10139N/A%{_libdir}/libloginhelper*.so
%{_mandir}/man3/*
%changelog
* Mon Feb 25 2008 - damien.carbery@sun.com
- Bump to 1.21.92.
* Mon Jan 14 2008 - damien.carbery@sun.com
- Bump to 1.21.5.
* Thu Jan 10 2008 - li.yuan@sun.com
- change owner to liyuan.
* Tue Dec 04 2007 - damien.carbery@sun.com
- Bump to 1.21.3.
* Tue Oct 30 2007 - damien.carbery@sun.com
- Bump to 1.21.1.
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 1.20.1.
* Wed Oct 10 2007 - damien.carbery@sun.com
- Move files from site-packages to vendor-packages. Fixes 6615442.
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 1.20.0.
* Wed Aug 29 2007 - damien.carbery@sun.com
- Add intltoolize call to update intltool scripts.
* Wed Jul 11 2007 - damien.carbery@sun.com
- Bump to 1.19.5.
* Wed Jun 06 2007 - damien.carbery@sun.com
- Bump to 1.19.3.
* Thu May 10 2007 - damien.carbery@sun.com
- Bump to 1.19.1.
* Thu Apr 12 2007 - damien.carbery@sun.com
- Bump to 1.18.1.
* Mon Mar 12 2007 - damien.carbery@sun.com
- Bump to 1.18.0.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 1.17.2.
* Wed Feb 28 2007 - li.yuan@sun.com
- Remove upstream patch, at-spi-01-get-attributes-crash.diff
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 1.17.0.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 1.7.16.
* Mon Jan 08 2007 - damien.carbery@sun.com
- Bump to 1.7.15.
* Tue Dec 19 2006 - damien.carbery@sun.com
- Bump to 1.7.14. Remove upstream patch, at-spi-01-fix-leak.diff.
* Fri Dec 08 2006 - damien.carbery@sun.com
- Bump to 1.7.13.
* Fri Nov 10 2006 - padraig.obriain@sun.com
- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
01-fix-leak.diff
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Wed Oct 11 2006 - padraig.obriain@sun.com
- Add patch 02-fix-leak to fix bug 6457388
* Mon Oct 02 2006 - damien.carbery@sun.com
- Bump to 1.7.12.
* Tue Aug 22 2006 - damien.carbery@sun.com
- Bump to 1.7.11.
* Tue Jul 25 2006 - damien.carbery@sun.com
- Bump to 1.7.10.
* Wed Jul 19 2006 - dermot.mccluskey@sun.com
- Bump to 1.7.9
* Mon Apr 01 2006 - padraig.obriain@sun.com
- Add patch 01-define-symbols so that gok builds.
* Fri Mar 31 2006 - damien.carbery@sun.com
- Bump to 1.7.7.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 1.7.6.
* Thu Feb 23 2006 - damien.carbery@sun.com
- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
* Tue Feb 21 2006 - damien.carbery@sun.com
- Bump to 1.7.5.
* Thu Feb 16 2006 - brian.cameron@sun.com
- Add "make clean" hack to ensure that the bonobo
registry server file is built with the right
sysconfdir.
* Tue Jan 31 2006 - damien.carbery@sun.com
- Bump to 1.7.4.
* Tue Jan 31 2006 - damien.carbery@sun.com
- Bump to 1.7.3.
* Fri Jan 20 2006 - damien.carbery@sun.com
- Bump to 1.7.2.
* Thu Sep 08 2005 - damien.carbery@sun.com
- Bump to 1.6.6.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 1.6.5.
* Tue Aug 23 2005 - damien.carbery@sun.com
- Move CFLAGS setting as it was useless in original location.
* Tue Jun 14 2005 - brian.cameron@sun.com
- Added aclocal/automake/autoconf, needed for Solaris build.
* Mon May 16 2005 - balamurali.viswanathan@wipro.com
- Bump to 1.6.4
* Mon May 16 2005 - balamurali.viswanathan@wipro.com
- Bump to 1.6.3
* Tue Apr 5 2005 - bill.haneman@sun.com
- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
* Thu Dec 9 2004 - bill.haneman@sun.com
- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
* Wed Sep 1 2004 - bill.haneman@sun.com
- Bumped to version 1.5.4, to include fixes for
- activation issues with DISPLAY env, and gnopernicus
- dependencies.
* Tue Aug 31 2004 - bill.haneman@sun.com
- Removed patch since #5088625 has been fixed, and
- the patch is incompatible with the fix.
* Wed Aug 18 2004 - bill.haneman@sun.com
- added patch from Padraig to work around P1/S2 bug #5088625.
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Fri Jun 11 2004 - dermot.mccluskey@sun.com
- add login-helper headers and lib to %files
* Wed Jun 02 2004 - <padraig.obriain@sun.com>
- Bump version to 1.5.2
* Fri Apr 30 2004 - <padraig.obriain@sun.com>
- Bump version to 1.5.1
* Tue Mar 23 2004 - <brian.cameron@sun.com>
- Remove "patch -p1" from the %prep section since
the patch was removed, and this is causing an
error on Solaris build.
* Tue Mar 23 2004 - <padraig.obriain@sun.com>
- Bump version to 1.4.0, remove reference to
at-spi-01-uninstalled-idldir.diff
* Mon Mar 22 2004 - <laca@sun.com>
- backport idldir fix in uninstalled.pc files from HEAD
* Tue Mar 16 2004 - <glynn.foster@sun.com>
- Remove the uninstalled-pc patch as it's
upstream now.
* Thu Mar 11 2004 - <damien.carbery@sun.com>
- Reset release to 1.
* Wed Mar 10 2004 - <damien.carbery@sun.com>
- Bump to 1.3.15
* Mon Feb 23 2004 - damien.carbery@sun.com
- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
* Wed Feb 18 2004 - matt.keenan@sun.com
- tarball upgrade to 1.3.12, add manpages, update %files
* Wed Dec 16 2003 - glynn.foster@sun.com
- tarball upgrade to 1.3.9
* Fri Oct 10 2003 - Laszlo.Kovacs@sun.com
- tarball upgrade
* Thu Aug 14 2003 - <laca@sun.com>
- move *.so to -devel, remove *.a and *.al
* Thu May 08 2003 - ghee.teo@Sun.COM
- Created new spec file for at-spi