at-spi.spec revision 10264
10139N/A#
10139N/A# spec file for package at-spi
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: padraig
10139N/A#
10139N/AName: at-spi
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
10264N/AVersion: 1.18.0
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Assistive Technology Service Provider Interface
10264N/ASource: http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.18/%{name}-%{version}.tar.bz2
10139N/AURL: http://developer.gnome.org/projects/gap/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define libbonobo_version 2.6.0
10139N/A%define atk_version 1.7.2
10139N/A%define gail_version 1.6.3
10139N/A
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gail-devel >= %{gail_version}
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gail >= %{gail_version}
10139N/A
10139N/A%description
10139N/Aat-spi allows assistive technologies to access GTK-based
10139N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
10139N/Ascripting interfaces can query and interact with GUI controls.
10139N/A
10139N/A%package devel
10139N/ASummary: Assistive Technology Service Provider Developer Interface
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %{name} = %{version}
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/ARequires: atk-devel >= %{atk_version}
10139N/A
10139N/A%description devel
10139N/Aat-spi allows assistive technologies to access GTK-based
10139N/Aapplications. Essentially it exposes the internals of applications for
10139N/Aautomation, so tools such as screen readers, magnifiers, or even
10139N/Ascripting interfaces can query and interact with GUI controls.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A %{gtk_doc_option}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/libspi*.so.*
10139N/A%{_libdir}/libcspi*.so.*
10139N/A%{_libdir}/libloginhelper*.so.*
10139N/A%{_libdir}/gtk-2.0/modules/*.so
10139N/A%{_libdir}/bonobo/servers/*.server
10139N/A%{_libdir}/orbit-2.0/*.so
10139N/A%{_libexecdir}/at-spi-registryd
10139N/A%{_datadir}/locale/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/at-spi-1.0/cspi/*.h
10139N/A%{_includedir}/at-spi-1.0/libspi/*.h
10139N/A%{_includedir}/at-spi-1.0/login-helper/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/gtk-doc/html
10139N/A%{_datadir}/idl
10139N/A%{_libdir}/libspi*.so
10139N/A%{_libdir}/libcspi*.so
10139N/A%{_libdir}/libloginhelper*.so
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
10264N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10264N/A- Bump to 1.18.0.
10179N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10179N/A- Bump to 1.17.2.
10139N/A* Wed Feb 28 2007 - li.yuan@sun.com
10139N/A- Remove upstream patch, at-spi-01-get-attributes-crash.diff
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.17.0.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.7.16.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.7.15.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.14. Remove upstream patch, at-spi-01-fix-leak.diff.
10139N/A* Fri Dec 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.13.
10139N/A* Fri Nov 10 2006 - padraig.obriain@sun.com
10139N/A- Remove patch 01-define-symbols.diff; move patch 02-fix-leak.diff to
10139N/A 01-fix-leak.diff
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Wed Oct 11 2006 - padraig.obriain@sun.com
10139N/A- Add patch 02-fix-leak to fix bug 6457388
10139N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.12.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.11.
10139N/A* Tue Jul 25 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.10.
10139N/A* Wed Jul 19 2006 - dermot.mccluskey@sun.com
10139N/A- Bump to 1.7.9
10139N/A* Mon Apr 01 2006 - padraig.obriain@sun.com
10139N/A- Add patch 01-define-symbols so that gok builds.
10139N/A* Fri Mar 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.7.
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.6.
10139N/A* Thu Feb 23 2006 - damien.carbery@sun.com
10139N/A- Remove 'make clean' hack as 1.7.5 tarball fixed the issue.
10139N/A* Tue Feb 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.5.
10139N/A* Thu Feb 16 2006 - brian.cameron@sun.com
10139N/A- Add "make clean" hack to ensure that the bonobo
10139N/A registry server file is built with the right
10139N/A sysconfdir.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.4.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.3.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.7.2.
10139N/A* Thu Sep 08 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.6.6.
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.6.5.
10139N/A* Tue Aug 23 2005 - damien.carbery@sun.com
10139N/A- Move CFLAGS setting as it was useless in original location.
10139N/A* Tue Jun 14 2005 - brian.cameron@sun.com
10139N/A- Added aclocal/automake/autoconf, needed for Solaris build.
10139N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
10139N/A- Bump to 1.6.4
10139N/A* Mon May 16 2005 - balamurali.viswanathan@wipro.com
10139N/A- Bump to 1.6.3
10139N/A* Tue Apr 5 2005 - bill.haneman@sun.com
10139N/A- Added patch at-spi-01-leakfix.diff to fix leak in bounds-change events.
10139N/A* Thu Dec 9 2004 - bill.haneman@sun.com
10139N/A- Revved to 1.6.2, to get fixes for 6192693, 6205004, others.
10139N/A* Wed Sep 1 2004 - bill.haneman@sun.com
10139N/A- Bumped to version 1.5.4, to include fixes for
10139N/A- activation issues with DISPLAY env, and gnopernicus
10139N/A- dependencies.
10139N/A* Tue Aug 31 2004 - bill.haneman@sun.com
10139N/A- Removed patch since #5088625 has been fixed, and
10139N/A- the patch is incompatible with the fix.
10139N/A* Wed Aug 18 2004 - bill.haneman@sun.com
10139N/A- added patch from Padraig to work around P1/S2 bug #5088625.
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri Jun 11 2004 - dermot.mccluskey@sun.com
10139N/A- add login-helper headers and lib to %files
10139N/A* Wed Jun 02 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.5.2
10139N/A* Fri Apr 30 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.5.1
10139N/A* Tue Mar 23 2004 - <brian.cameron@sun.com>
10139N/A- Remove "patch -p1" from the %prep section since
10139N/A the patch was removed, and this is causing an
10139N/A error on Solaris build.
10139N/A* Tue Mar 23 2004 - <padraig.obriain@sun.com>
10139N/A- Bump version to 1.4.0, remove reference to
10139N/A at-spi-01-uninstalled-idldir.diff
10139N/A* Mon Mar 22 2004 - <laca@sun.com>
10139N/A- backport idldir fix in uninstalled.pc files from HEAD
10139N/A* Tue Mar 16 2004 - <glynn.foster@sun.com>
10139N/A- Remove the uninstalled-pc patch as it's
10139N/A upstream now.
10139N/A* Thu Mar 11 2004 - <damien.carbery@sun.com>
10139N/A- Reset release to 1.
10139N/A* Wed Mar 10 2004 - <damien.carbery@sun.com>
10139N/A- Bump to 1.3.15
10139N/A* Mon Feb 23 2004 - damien.carbery@sun.com
10139N/A- Add '--libexecdir=%{_libexecdir}' to install files to correct dir on Solaris.
10139N/A* Wed Feb 18 2004 - matt.keenan@sun.com
10139N/A- tarball upgrade to 1.3.12, add manpages, update %files
10139N/A* Wed Dec 16 2003 - glynn.foster@sun.com
10139N/A- tarball upgrade to 1.3.9
10139N/A* Fri Oct 10 2003 - Laszlo.Kovacs@sun.com
10139N/A- tarball upgrade
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move *.so to -devel, remove *.a and *.al
10139N/A* Thu May 08 2003 - ghee.teo@Sun.COM
10139N/A- Created new spec file for at-spi