alacarte.spec revision 13992
12258N/A#
12258N/A# spec file for package gnome-menu-editor
12258N/A#
12412N/A# Copyright (c) 2005 Sun Microsystems, Inc.
12258N/A# This file and all modifications and additions to the pristine
12258N/A# package are under the same license as the package itself.
12258N/A#
13305N/A# Owner: jedy
12258N/A#
12258N/A%define python_version 2.4
15153N/A
12258N/AName: alacarte
15293N/AVersion: 0.11.5
12258N/ARelease: 1
12517N/ASummary: Simple menu editor for GNOME
15839N/AGroup: System/GUI/GNOME
12258N/ALicense: GPL
12258N/AURL: http://www.realistanew.com/projects/alacarte/
12258N/ADistribution: java-desktop-system
12258N/AVendor: Sun Microsystems, Inc.
12258N/ASource: http://ftp.gnome.org/pub/GNOME/sources/alacarte/0.11/alacarte-%{version}.tar.bz2
12258N/A%if %build_l10n
15153N/ASource1: l10n-configure.sh
15153N/A%endif
12258N/A#owner:jedy date:2008-07-14 type:branding
12258N/APatch1: alacarte-01-menu-entry.diff
12258N/A
12258N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12517N/A
12517N/ABuildRequires: pygtk2.0-devel
12258N/ABuildRequires: desktop-file-utils
12258N/ABuildRequires: gnome-menus-devel >= 2.15.4.1
12258N/ABuildRequires: perl-XML-Parser
12258N/ARequires: pygtk2.0, gnome-python-gconf, gnome-python
12474N/ARequires: python-gnome-menus
12258N/AObsoletes: smeg
12258N/AProvides: smeg %{version}-%{release}
12517N/A
13032N/A%description
12820N/AAlacarte is a menu editor for GNOME that lets you get things done,
15234N/Asimply and quickly.
13759N/A
13851N/AJust click and type to edit, add, and delete any menu entry.
13851N/A
15234N/A%prep
14061N/A%setup -q
14295N/A%patch1 -p1
14295N/A
15259N/A%build
15259N/A%ifos linux
15260N/Aif [ -x /usr/bin/getconf ]; then
15260N/A CPUS=`getconf _NPROCESSORS_ONLN`
15856N/Afi
15856N/A%else
15856N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15856N/A%endif
12258N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12258N/A CPUS=1
12258N/Afi
12258N/A
12258N/Aintltoolize -c -f --automake
12258N/A
12258N/A%if %build_l10n
12258N/Abash -x %SOURCE1 --enable-copyright
12258N/A%endif
12258N/A
12258N/Alibtoolize --copy --force
12258N/Aaclocal $ACLOCAL_FLAGS
12258N/Aautomake -a -c -f
12258N/Aautoconf
12258N/A
12258N/A./configure --prefix=%{_prefix} --mandir=%{_mandir} \
12258N/A --libdir=%{_libdir} \
12258N/A --libexecdir=%{_libexecdir} \
12258N/A --sysconfdir=%{_sysconfdir}
12258N/Amake -j $CPUS \
12258N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
12258N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
12258N/A
12258N/A%install
12258N/Arm -rf $RPM_BUILD_ROOT
12258N/Amake DESTDIR=$RPM_BUILD_ROOT install \
12258N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
12258N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
12258N/A
12258N/A%post
12258N/A%update_menus
12258N/A%update_icon_cache hicolor
12258N/A
12258N/A%postun
15523N/A%clean_menus
15523N/A%clean_icon_cache hicolor
15153N/A
15153N/A%clean
15153N/Arm -rf $RPM_BUILD_ROOT
12258N/A
13875N/A%files -f %{name}.lang
12258N/A%defattr (-, root, root)
13875N/A%doc README AUTHORS COPYING
13708N/A%{_libdir}/python?.?/vendor-packages/*
12258N/A%{_bindir}/*
12258N/A%{_datadir}/applications/*
12258N/A%{_datadir}/%name/*
12517N/A%{_datadir}/icons/*
12820N/A%{_libdir}/menu/%{name}
13759N/A
14061N/A%changelog
14295N/A* Fri Aug 22 2008 - jedy.wang@sun.com
15259N/A- rename desktop.diff to menu-entry.diff.
15260N/A* Mon Jul 14 2008 - jedy.wang@sun.com
15856N/A- Add 01-desktop.diff.
15856N/A* Tue Mar 11 2008 - damien.carbery@sun.com
12258N/A- Bump to 0.11.5.
12258N/A* Mon Feb 18 2008 - damien.carbery@sun.com
12258N/A- Bump to 0.11.4.
12258N/A* Fri Nov 09 2007 - jedy.wang@sun.com
12258N/A* Remove 01-force-reload.diff.
12258N/A* Thu Oct 12 2007 - jedy.wang@sun.com
12258N/A- Take the ownership from harrylu.
12258N/A* Wed Oct 10 2007 - damien.carbery@sun.com
12258N/A- Don't delete *.pyc files - they are needed.
12258N/A* Fri Aug 17 2007 - jedy.wang@sun.com
12258N/A- Fix 'patch1 -p0' - change to -p1 and change patch file too.
12258N/A* Tue Feb 13 2007 - damien.carbery@sun.com
12258N/A- Bump to 0.11.3.
12258N/A* Thu Jan 11 2007 - damien.carbery@sun.com
12773N/A- Bump to 0.11.1.1.
12773N/A* Tue Jan 09 2007 - damien.carbery@sun.com
12773N/A- Bump to 0.11.0.
12258N/A* Tue Dec 19 2006 - damien.carbery@sun.com
12258N/A- Bump to 0.10.2. Remove upstream patches, 02-launch-menu-item and
12258N/A 03-g11n-i18n-ui.
12258N/A* Tue Dec 12 2006 - takao.fujiwara@sun.com
12258N/A- Added intltoollize to read LINGUAS file
12258N/A- Added alacarte-03-g11n-i18n-ui.diff
12258N/A* Fri Nov 17 2006 - damien.carbery@sun.com
12258N/A- Change patch2 to use p1.
12258N/A* Wed Nov 15 2006 - calum.benson@sun.com
12258N/A Change menu item to match latest UI spec.
12258N/A* Tue Oct 03 2006 - damien.carbery@sun.com
12258N/A- Bump to 0.10.0.
12258N/A* Mon Sep 04 2006 - damien.carbery@sun.com
12258N/A- Bump to 0.10.0.
12258N/A* Thu Aug 24 2006 - laca@sun.com
12258N/A- remove autoheader call since there is AC_CONFIG_HEADER in configure.in
12258N/A* Tue Aug 22 2006 - halton.huo@sun.com
12258N/A- Divide SFEgnome-menu-editor.spec into alacarte.spec
12258N/A and SUNWgnome-menu-editor.spec
12258N/A* Wed Aug 16 2006 - harry.lu@sun.com
12258N/A- bump up to 0.9.90 and add patch alacarte-01-force-reload.diff to make
12258N/A it work on solaris.
12258N/A* Wed Jul 5 2006 - laca@sun.com
12258N/A- rename to gnome-menu-editor
12258N/A- delete share subpkg
12258N/A* Fri Apr 21 2006 - glynn.foster@sun.com
12258N/A- Initial spec file
12258N/A