alacarte.spec revision 11900
20829N/A#
20829N/A# spec file for package gnome-menu-editor
20829N/A#
20829N/A# Copyright (c) 2005 Sun Microsystems, Inc.
20829N/A# This file and all modifications and additions to the pristine
20829N/A# package are under the same license as the package itself.
20829N/A#
20829N/A# Owner: jedy
20829N/A#
20829N/A%define python_version 2.4
20829N/A
20829N/AName: alacarte
20829N/AVersion: 0.11.3
20829N/ARelease: 1
20829N/ASummary: Simple menu editor for GNOME
20829N/AGroup: System/GUI/GNOME
20829N/ALicense: GPL
20829N/AURL: http://www.realistanew.com/projects/alacarte/
20829N/ADistribution: java-desktop-system
20829N/AVendor: Sun Microsystems, Inc.
20829N/ASource: http://ftp.gnome.org/pub/GNOME/sources/alacarte/0.11/alacarte-%{version}.tar.bz2
20829N/A
20829N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20829N/A
20829N/ABuildRequires: pygtk2.0-devel
20829N/ABuildRequires: desktop-file-utils
20829N/ABuildRequires: gnome-menus-devel >= 2.15.4.1
20829N/ABuildRequires: perl-XML-Parser
20829N/ARequires: pygtk2.0, gnome-python-gconf, gnome-python
20829N/ARequires: python-gnome-menus
20829N/AObsoletes: smeg
20829N/AProvides: smeg %{version}-%{release}
20829N/A
20829N/A%description
20829N/AAlacarte is a menu editor for GNOME that lets you get things done,
20829N/Asimply and quickly.
20829N/A
20829N/AJust click and type to edit, add, and delete any menu entry.
20829N/A
20829N/A%prep
20829N/A%setup -q
20829N/A
20829N/A%build
20829N/A%ifos linux
20829N/Aif [ -x /usr/bin/getconf ]; then
20829N/A CPUS=`getconf _NPROCESSORS_ONLN`
20829N/Afi
20829N/A%else
20829N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20829N/A%endif
20829N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20829N/A CPUS=1
20829N/Afi
20829N/A
20829N/Aintltoolize -c -f --automake
20829N/Alibtoolize --copy --force
20829N/Aaclocal $ACLOCAL_FLAGS
20829N/Aautomake -a -c -f
20829N/Aautoconf
20829N/A
20829N/A./configure --prefix=%{_prefix} --mandir=%{_mandir} \
20829N/A --libdir=%{_libdir} \
20829N/A --libexecdir=%{_libexecdir} \
20829N/A --sysconfdir=%{_sysconfdir}
20829N/Amake -j $CPUS \
20829N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
20829N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
20829N/A
20829N/A%install
20829N/Arm -rf $RPM_BUILD_ROOT
20829N/Amake DESTDIR=$RPM_BUILD_ROOT install \
20829N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
20829N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
20829N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
20829N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
20829N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
20829N/A
20829N/A%post
20829N/A%update_menus
20829N/A%update_icon_cache hicolor
20829N/A
20829N/A%postun
20829N/A%clean_menus
20829N/A%clean_icon_cache hicolor
20829N/A
20829N/A%clean
20829N/Arm -rf $RPM_BUILD_ROOT
20829N/A
20829N/A%files -f %{name}.lang
20829N/A%defattr (-, root, root)
20829N/A%doc README AUTHORS COPYING
20829N/A%{_libdir}/python?.?/vendor-packages/*
20829N/A%{_bindir}/*
20829N/A%{_datadir}/applications/*
20829N/A%{_datadir}/%name/*
20829N/A%{_datadir}/icons/*
20829N/A%{_libdir}/menu/%{name}
20829N/A
20829N/A%changelog
20829N/A* Fri Nov 09 2007 - jedy.wang@sun.com
20829N/A* Remove 01-force-reload.diff.
20829N/A* Thu Oct 12 2007 - jedy.wang@sun.com
20829N/A- Take the ownership from harrylu.
20829N/A* Wed Oct 10 2007 - damien.carbery@sun.com
20829N/A- Don't delete *.pyc files - they are needed.
20829N/A* Fri Aug 17 2007 - jedy.wang@sun.com
20829N/A- Fix 'patch1 -p0' - change to -p1 and change patch file too.
20829N/A* Tue Feb 13 2007 - damien.carbery@sun.com
20829N/A- Bump to 0.11.3.
20829N/A* Thu Jan 11 2007 - damien.carbery@sun.com
20829N/A- Bump to 0.11.1.1.
20829N/A* Tue Jan 09 2007 - damien.carbery@sun.com
20829N/A- Bump to 0.11.0.
20829N/A* Tue Dec 19 2006 - damien.carbery@sun.com
20829N/A- Bump to 0.10.2. Remove upstream patches, 02-launch-menu-item and
20829N/A 03-g11n-i18n-ui.
20829N/A* Tue Dec 12 2006 - takao.fujiwara@sun.com
20829N/A- Added intltoollize to read LINGUAS file
20829N/A- Added alacarte-03-g11n-i18n-ui.diff
20829N/A* Fri Nov 17 2006 - damien.carbery@sun.com
20829N/A- Change patch2 to use p1.
20829N/A* Wed Nov 15 2006 - calum.benson@sun.com
20829N/A Change menu item to match latest UI spec.
20829N/A* Tue Oct 03 2006 - damien.carbery@sun.com
20829N/A- Bump to 0.10.0.
20829N/A* Mon Sep 04 2006 - damien.carbery@sun.com
20829N/A- Bump to 0.10.0.
20829N/A* Thu Aug 24 2006 - laca@sun.com
20829N/A- remove autoheader call since there is AC_CONFIG_HEADER in configure.in
20829N/A* Tue Aug 22 2006 - halton.huo@sun.com
20829N/A- Divide SFEgnome-menu-editor.spec into alacarte.spec
20829N/A and SUNWgnome-menu-editor.spec
20829N/A* Wed Aug 16 2006 - harry.lu@sun.com
20829N/A- bump up to 0.9.90 and add patch alacarte-01-force-reload.diff to make
20829N/A it work on solaris.
20829N/A* Wed Jul 5 2006 - laca@sun.com
20829N/A- rename to gnome-menu-editor
20829N/A- delete share subpkg
20829N/A* Fri Apr 21 2006 - glynn.foster@sun.com
20829N/A- Initial spec file
20829N/A