#
# Copyright (c) 2008 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
#
Release: 1
Source: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486solaris_enu.tar.bz2
Source1: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/%{version}/jpn/AdbeRdr%{version}-1_i486solaris_jpn.tar.bz2
Source2: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/%{version}/fra/AdbeRdr%{version}-1_i486solaris_fra.tar.bz2
Source3: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/%{version}/deu/AdbeRdr%{version}-1_i486solaris_deu.tar.bz2
Source4: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.1/misc/FontPack910_chs_i386-solaris.tar.bz2
Source5: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.1/misc/FontPack910_cht_i386-solaris.tar.bz2
Source6: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.1/misc/FontPack910_kor_i386-solaris.tar.bz2
Source7: http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.1/misc/FontPack910_jpn_i386-solaris.tar.bz2
%prep
cd jpn
cd ..
cd fra
cd ..
cd deu
cd ..
cd chs
cd ..
cd cht
cd ..
cd kor
cd ..
cd jpn
cd ..
# From the Asian font packs (chs, cht, kor, jpn), extract one of the LANGCOM.TAR
# files (they are all identical) and each of the other LANG*.TAR files.
# This gives us the localized font and cmap files.
# Files in common with the tarballs for the full Janapese and English releases
# get overwritten by later commands.
cd ../..
cd ../..
cd ../..
cd ../..
# (over-writting any common files as we go).
cd jpn/AdobeReader
cd ../..
cd fra/AdobeReader
cd ../..
cd deu/AdobeReader
cd ../..
cd AdobeReader
cd ..
# overwrite distributed script with new ver that supports all langs
cd AdobeReader
install --mode=0644 ${RPM_BUILD_ROOT}%{adobe_base_dir}/Adobe/Reader9/Reader/Legal/en_US/License.txt \
# Make a link for acroread.1 manpage file
# Make a link for .xml file
# Make a link for the .desktop file
# Make links for the hicolor theme icons
do
do
if test "x"$p != "xAdobeReader9.png" ; then
ln -s ../../../../../lib/AdobeReader/Adobe/Reader9/Resource/Icons/$f/$p ./$f/mimetypes/application-`echo $p | /bin/awk -F'.' '{print $(NF-1)}'`.png
fi
done
done
# Make a link for the Firefox plugin