accerciser.spec revision 19064
11161N/A#
11161N/A# includes module(s): accerciser
11161N/A#
11161N/A# Copyright (c) 2008 Sun Microsystems, Inc.
11161N/A# This file and all modifications and additions to the pristine
11161N/A# package are under the same license as the package itself.
11161N/A#
11161N/A%define owner liyuan
11161N/A#
11161N/A%define pythonver 2.6
11161N/A
11377N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
11161N/A
11161N/AName: accerciser
11251N/AVersion: 1.10.1
11161N/ARelease: 1%{?dist}
11161N/AVendor: Gnome Community
11161N/ASummary: An interactive Python accessibility explorer for the GNOME desktop
11161N/A
11161N/AGroup: Applications/System
11161N/ALicense: BSD
11251N/AURL: http://live.gnome.org/Accerciser
11161N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.10/%{name}-%{version}.tar.bz2
11161N/A#owner:liyuan date:2007-11-09 bugster:6610155 type:branding
11161N/APatch1: accerciser-01-remove-from-menu.diff
11161N/A#owner:liyuan date:2010-02-08 bugzilla:14420 type:branding
11161N/APatch2: accerciser-02-python-version.diff
11161N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11161N/ABuildRequires: gnome-doc-utils, desktop-file-utils, scrollkeeper, gnome-python2-libwnck, gettext
11161N/ARequires: at-spi, pygtk2, gnome-python2, gnome-python2-libwnck, pygtk2-libglade, gnome-python2-bonobo
11161N/A
11161N/A#Requires(pre): GConf2
11161N/A#Requires(post): scrollkeeper GConf2
11161N/A#Requires(postun): scrollkeeper
11161N/A#Requires(preun): GConf2
11161N/A
11161N/A%description
11161N/AAccerciser is an interactive Python accessibility explorer for the GNOME
11161N/Adesktop. It uses AT-SPI to inspect and control widgets, allowing you to
11161N/Acheck if an application is providing correct information to assistive
11161N/Atechnologies and automated test frameworks.
11161N/A
11161N/A%prep
11161N/A%setup -q
11161N/A%patch1 -p1
11161N/A%patch2 -p1
11161N/A
11161N/A
11161N/A%build
11161N/Aaclocal $ACLOCAL_FLAGS
11161N/Aautomake --add-missing
11161N/Aautoconf
11161N/A
11161N/A./configure --prefix=%{_prefix} \
11161N/A --libdir=%{_libdir} \
11161N/A --bindir=%{_bindir} \
11161N/A --datadir=%{_datadir} \
11161N/A --sysconfdir=%{_sysconfdir} \
11161N/A --disable-scrollkeeper
11161N/Amake
11161N/Ased s/"\/env python"/"\/python2.6"/g src/accerciser > src/accerciser.bak
11161N/Amv src/accerciser.bak src/accerciser
11377N/A
11377N/A%install
11377N/Arm -rf $RPM_BUILD_ROOT
11377N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
11161N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
11161N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
11161N/A
11161N/A#desktop-file-install --vendor="" --delete-original \
11161N/A# --dir $RPM_BUILD_ROOT%{_datadir}/applications \
11161N/A# $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
11161N/A
11161N/A#%find_lang %{name}
11161N/A
11161N/A# Move to vendor-packages
11161N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
11161N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
11161N/A
11161N/A# Remove .pyo files
11161N/Afind $RPM_BUILD_ROOT -name '*.pyo' -exec rm {} \;
11161N/A
11161N/A%clean
11161N/Arm -rf $RPM_BUILD_ROOT
11161N/A
11161N/A%prep
11161N/Aif [ "$1" -gt 1 ]; then
11161N/A export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/A gconftool-2 --makefile-uninstall-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas >/dev/null || :
11161N/A killall -HUP gconfd-2 || :
11161N/Afi
11161N/A
11161N/A%post
11161N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/Agconftool-2 --makefile-install-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
11161N/Akillall -HUP gconfd-2 || :
11161N/A
11161N/Ascrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
11161N/Atouch --no-create %{_datadir}/icons/hicolor || :
11161N/A%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
11161N/A
11161N/A%postun
11161N/Ascrollkeeper-update -q || :
11161N/Atouch --no-create %{_datadir}/icons/hicolor || :
11161N/A%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
11161N/A
11161N/A%preun
11161N/Aif [ "$1" -eq 0 ]; then
11161N/A export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/A gconftool-2 --makefile-uninstall-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
11377N/A killall -HUP gconfd-2 || :
11383N/Afi
11251N/A
11251N/A%files -f %{name}.lang
11186N/A%defattr(-,root,root)
11186N/A%doc README AUTHORS ChangeLog COPYING NEWS
11186N/A%{_bindir}/%{name}
11186N/A#%{python_sitearch}/%{name}
%{_datadir}/%{name}
%{_datadir}/omf/%{name}
%{_datadir}/applications/*.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%{_datadir}/gnome/help/%{name}
%{_sysconfdir}/gconf/schemas/%{name}.schemas
%changelog
* Wed Oct 27 2010 - brian.cameron@oracle.com
- Bump to 1.10.1.
* Sat Mar 3 2010 - christian.kelly@sun.com
- Bump to 1.10.0.
* Mon Feb 08 2009 - li.yuan@sun.com
- Add patch 02, specific Python version.
* Mon Nov 30 2009 - li.yuan@sun.com
- Bump to 1.9.3.
* Wed Oct 14 2009 - li.yuan@sun.com
- Use Python 2.6 and remove .pyo files.
* Wed Sep 23 2009 - dave.lin@sun.com
- Bump to 1.8.0
* Wed Aug 26 2009 - li.yuan@sun.com
- Bump to 1.7.91.
* Thu Aug 13 2009 - li.yuan@sun.com
- Update vendor information.
* Wed Aug 12 2009 - li.yuan@sun.com
- Bump to 1.7.90.
* Sun Jul 19 2009 - christian.kelly@sun.com
- Bump to 1.7.4.
* Mon Jul 06 2009 - christian.kelly@sun.com
- Bump to 1.7.2.
* Wed Apr 15 2009 - dave.lin@sun.com
- Bump to 1.6.1
* Tue Mar 17 2009 - dave.lin@sun.com
- Bump to 1.6.0
* Wed Feb 18 2009 - dave.lin@sun.com
- Bump to 1.5.91
* Thu Feb 05 2009 - christian.kelly@sun.com
- Bump to 1.5.9.
* Thu Jan 22 2009 - li.yuan@sun.com
- Bump to 1.5.5.
* Thu Jan 08 2009 - li.yuan@sun.com
- Bump to 1.5.4.
* Wed Dec 03 2008 - dave.lin@sun.com
- Bump to 1.5.2
* Wed Nov 05 2008 - li.yuan@sun.com
- Change copyright information.
* Mon Sep 29 2008 - patrick.ale@gmail.com
- Correct download URL
* Tue Sep 23 2008 - christian.kelly@sun.com
- Bump to 1.4.0.
* Tue Sep 09 2008 - christian.kelly@sun.com
- Bump to 1.3.92.
* Tue Sep 02 2008 - christian.kelly@sun.com
- Bump to 1.3.91.
* Tue Aug 05 2008 - damien.carbery@sun.com
- Bump to 1.3.6.
* Mon Jul 21 2008 - damien.carbery@sun.com
- Bump to 1.3.5.
* Tue Jun 17 2008 - damien.carbery@sun.com
- Bump to 1.3.4. Remove upstream patch, 02-pyatspi-check.
* Tue Jun 10 2008 - damien.carbery@sun.com
- Add patch 02-pyatspi-check to skip the pyatspi check as it requires a display.
* Wed May 28 2008 - damien.carbery@sun.com
- Bump to 1.3.1.
* Thu Mar 27 2008 - damien.carbery@sun.com
- Bump to 1.2.0. Call aclocal, automake and autoconf to get patched
intltool.m4.
* Tue Feb 26 2008 - damien.carbery@sun.com
- Bump to 1.1.92.
* Mon Feb 11 2008 - brian.cameron@sun.com
- Bump to 1.1.91.
* Tue Jan 29 2008 - damien.carbery@sun.com
- Bump to 1.1.90.
* Mon Jan 14 2008 - brian.cameron@sun.com
- Bump to 1.1.5.
* Mon Dec 03 2007 - brian.cameron@sun.com
- Bump to 1.1.3.
* Tue Oct 30 2007 - damien.carbery@sun.com
- Bump to 1.1.1.
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 1.0.1.
* Wed Oct 10 2007 - damien.carbery@sun.com
- Move files from site-packages to vendor-packages. Fixes 6615442.
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 1.0.0.
* Tue Sep 04 2007 - damien.carbery@sun.com
- Bump to 0.1.92.
* Sun Sep 02 2007 - li.yuan@sun.com
- Initial version.