accerciser.spec revision 15311
17476N/A#
17476N/A# includes module(s): accerciser
17476N/A#
17476N/A# Copyright (c) 2008 Sun Microsystems, Inc.
17476N/A# This file and all modifications and additions to the pristine
17476N/A# package are under the same license as the package itself.
17476N/A#
17476N/A# Owner: liyuan
17476N/A#
17476N/A%define pythonver 2.4
17476N/A
17476N/AName: accerciser
17476N/AVersion: 1.4.0
17476N/ARelease: 1%{?dist}
17476N/ASummary: An interactive Python accessibility explorer for the GNOME desktop
17476N/A
17476N/AGroup: Applications/System
17476N/ALicense: BSD
17476N/AURL: http://live.gnome.org/Accerciser
17476N/ASource0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.4/%{name}-%{version}.tar.bz2
17476N/A#owner:liyuan date:2007-11-09 bugster:6610155 type:branding
17476N/APatch1: accerciser-01-remove-from-menu.diff
17476N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17476N/ABuildRequires: gnome-doc-utils, desktop-file-utils, scrollkeeper, gnome-python2-libwnck, gettext
17476N/ARequires: at-spi, pygtk2, gnome-python2, gnome-python2-libwnck, pygtk2-libglade, gnome-python2-bonobo
17476N/A
17476N/A#Requires(pre): GConf2
17476N/A#Requires(post): scrollkeeper GConf2
17476N/A#Requires(postun): scrollkeeper
17476N/A#Requires(preun): GConf2
17476N/A
17476N/A%description
17476N/AAccerciser is an interactive Python accessibility explorer for the GNOME
17476N/Adesktop. It uses AT-SPI to inspect and control widgets, allowing you to
17476N/Acheck if an application is providing correct information to assistive
17476N/Atechnologies and automated test frameworks.
17476N/A
17476N/A%prep
17476N/A%setup -q
17476N/A%patch1 -p1
17476N/A
17476N/A
17476N/A%build
17476N/Aaclocal $ACLOCAL_FLAGS
17476N/Aautomake --add-missing
17476N/Aautoconf
17476N/A
17476N/A./configure --prefix=%{_prefix} \
17476N/A --libdir=%{_libdir} \
17476N/A --bindir=%{_bindir} \
17476N/A --datadir=%{_datadir} \
17476N/A --sysconfdir=%{_sysconfdir} \
17476N/A --disable-scrollkeeper
17476N/Amake
17476N/A
17476N/A%install
17476N/Arm -rf $RPM_BUILD_ROOT
17476N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
17476N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
17476N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
17476N/A
17476N/A#desktop-file-install --vendor="" --delete-original \
17476N/A# --dir $RPM_BUILD_ROOT%{_datadir}/applications \
17476N/A# $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
17476N/A
17476N/A#%find_lang %{name}
17476N/A
17476N/A# Move to vendor-packages
17476N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
17476N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
17476N/A
%clean
rm -rf $RPM_BUILD_ROOT
%prep
if [ "$1" -gt 1 ]; then
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-uninstall-rule \
%{_sysconfdir}/gconf/schemas/accerciser.schemas >/dev/null || :
killall -HUP gconfd-2 || :
fi
%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule \
%{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
killall -HUP gconfd-2 || :
scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
touch --no-create %{_datadir}/icons/hicolor || :
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
%postun
scrollkeeper-update -q || :
touch --no-create %{_datadir}/icons/hicolor || :
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
%preun
if [ "$1" -eq 0 ]; then
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-uninstall-rule \
%{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
killall -HUP gconfd-2 || :
fi
%files -f %{name}.lang
%defattr(-,root,root)
%doc README AUTHORS ChangeLog COPYING NEWS
%{_bindir}/%{name}
#%{python_sitearch}/%{name}
%{_datadir}/%{name}
%{_datadir}/omf/%{name}
%{_datadir}/applications/*.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%{_datadir}/gnome/help/%{name}
%{_sysconfdir}/gconf/schemas/%{name}.schemas
%changelog
* Wed Nov 05 2008 - li.yuan@sun.com
- Change copyright information.
* Mon Sep 29 2008 - patrick.ale@gmail.com
- Correct download URL
* Tue Sep 23 2008 - christian.kelly@sun.com
- Bump to 1.4.0.
* Tue Sep 09 2008 - christian.kelly@sun.com
- Bump to 1.3.92.
* Tue Sep 02 2008 - christian.kelly@sun.com
- Bump to 1.3.91.
* Tue Aug 05 2008 - damien.carbery@sun.com
- Bump to 1.3.6.
* Mon Jul 21 2008 - damien.carbery@sun.com
- Bump to 1.3.5.
* Tue Jun 17 2008 - damien.carbery@sun.com
- Bump to 1.3.4. Remove upstream patch, 02-pyatspi-check.
* Tue Jun 10 2008 - damien.carbery@sun.com
- Add patch 02-pyatspi-check to skip the pyatspi check as it requires a display.
* Wed May 28 2008 - damien.carbery@sun.com
- Bump to 1.3.1.
* Thu Mar 27 2008 - damien.carbery@sun.com
- Bump to 1.2.0. Call aclocal, automake and autoconf to get patched
intltool.m4.
* Tue Feb 26 2008 - damien.carbery@sun.com
- Bump to 1.1.92.
* Mon Feb 11 2008 - brian.cameron@sun.com
- Bump to 1.1.91.
* Tue Jan 29 2008 - damien.carbery@sun.com
- Bump to 1.1.90.
* Mon Jan 14 2008 - brian.cameron@sun.com
- Bump to 1.1.5.
* Mon Dec 03 2007 - brian.cameron@sun.com
- Bump to 1.1.3.
* Tue Oct 30 2007 - damien.carbery@sun.com
- Bump to 1.1.1.
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 1.0.1.
* Wed Oct 10 2007 - damien.carbery@sun.com
- Move files from site-packages to vendor-packages. Fixes 6615442.
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 1.0.0.
* Tue Sep 04 2007 - damien.carbery@sun.com
- Bump to 0.1.92.
* Sun Sep 02 2007 - li.yuan@sun.com
- Initial version.