accerciser.spec revision 11819
11161N/A#
11161N/A# spec file for package SUNWgnome-a11y-poke
11161N/A#
11161N/A# includes module(s): accerciser
11161N/A#
11161N/A# Copyright (c) 2004 Sun Microsystems, Inc.
11161N/A# This file and all modifications and additions to the pristine
11161N/A# package are under the same license as the package itself.
11161N/A#
11161N/A# Owner: liyuan
11161N/A#
11377N/A%define pythonver 2.4
11161N/A
11161N/AName: accerciser
11819N/AVersion: 1.1.1
11161N/ARelease: 1%{?dist}
11161N/ASummary: An interactive Python accessibility explorer for the GNOME desktop
11161N/A
11161N/AGroup: Applications/System
11161N/ALicense: GPL
11161N/AURL: http://live.gnome.org/Accerciser
11819N/ASource0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
11161N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11161N/ABuildRequires: gnome-doc-utils, desktop-file-utils, scrollkeeper, gnome-python2-libwnck, gettext
11161N/ARequires: at-spi, pygtk2, gnome-python2, gnome-python2-libwnck, pygtk2-libglade, gnome-python2-bonobo
11161N/A
11161N/A#Requires(pre): GConf2
11161N/A#Requires(post): scrollkeeper GConf2
11161N/A#Requires(postun): scrollkeeper
11161N/A#Requires(preun): GConf2
11161N/A
11161N/A%description
11161N/AAccerciser is an interactive Python accessibility explorer for the GNOME
11161N/Adesktop. It uses AT-SPI to inspect and control widgets, allowing you to
11161N/Acheck if an application is providing correct information to assistive
11161N/Atechnologies and automated test frameworks.
11161N/A
11161N/A%prep
11161N/A%setup -q
11161N/A
11161N/A
11161N/A%build
11161N/A./configure --prefix=%{_prefix} \
11161N/A --libdir=%{_libdir} \
11161N/A --bindir=%{_bindir} \
11161N/A --datadir=%{_datadir} \
11161N/A --sysconfdir=%{_sysconfdir} \
11161N/A --disable-scrollkeeper
11161N/Amake
11161N/A
11161N/A%install
11161N/Arm -rf $RPM_BUILD_ROOT
11161N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
11161N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
11161N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
11161N/A
11161N/A#desktop-file-install --vendor="" --delete-original \
11161N/A# --dir $RPM_BUILD_ROOT%{_datadir}/applications \
11161N/A# $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
11161N/A
11161N/A#%find_lang %{name}
11161N/A
11377N/A# Move to vendor-packages
11377N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
11377N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
11377N/A
11161N/A%clean
11161N/Arm -rf $RPM_BUILD_ROOT
11161N/A
11161N/A%prep
11161N/Aif [ "$1" -gt 1 ]; then
11161N/A export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/A gconftool-2 --makefile-uninstall-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas >/dev/null || :
11161N/A killall -HUP gconfd-2 || :
11161N/Afi
11161N/A
11161N/A%post
11161N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/Agconftool-2 --makefile-install-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
11161N/Akillall -HUP gconfd-2 || :
11161N/A
11161N/Ascrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
11161N/Atouch --no-create %{_datadir}/icons/hicolor || :
11161N/A%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
11161N/A
11161N/A%postun
11161N/Ascrollkeeper-update -q || :
11161N/Atouch --no-create %{_datadir}/icons/hicolor || :
11161N/A%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
11161N/A
11161N/A%preun
11161N/Aif [ "$1" -eq 0 ]; then
11161N/A export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
11161N/A gconftool-2 --makefile-uninstall-rule \
11161N/A %{_sysconfdir}/gconf/schemas/accerciser.schemas > /dev/null || :
11161N/A killall -HUP gconfd-2 || :
11161N/Afi
11161N/A
11161N/A%files -f %{name}.lang
11161N/A%defattr(-,root,root)
11161N/A%doc README AUTHORS ChangeLog COPYING NEWS
11161N/A%{_bindir}/%{name}
11161N/A#%{python_sitearch}/%{name}
11161N/A%{_datadir}/%{name}
11161N/A%{_datadir}/omf/%{name}
11161N/A%{_datadir}/applications/*.desktop
11161N/A%{_datadir}/icons/hicolor/*/apps/%{name}.*
11161N/A%{_datadir}/gnome/help/%{name}
11161N/A%{_sysconfdir}/gconf/schemas/%{name}.schemas
11161N/A
11161N/A%changelog
11819N/A* Tue Oct 30 2007 - damien.carbery@sun.com
11819N/A- Bump to 1.1.1.
11416N/A* Fri Oct 19 2007 - damien.carbery@sun.com
11416N/A- Bump to 1.0.1.
11377N/A* Wed Oct 10 2007 - damien.carbery@sun.com
11383N/A- Move files from site-packages to vendor-packages. Fixes 6615442.
11251N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11251N/A- Bump to 1.0.0.
11186N/A* Tue Sep 04 2007 - damien.carbery@sun.com
11186N/A- Bump to 0.1.92.
11186N/A* Sun Sep 02 2007 - li.yuan@sun.com
11186N/A- Initial version.