ORBit2.spec revision 12858
10139N/A
10139N/A# spec file for package ORBit2
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:gheet
10139N/A#
10139N/AName: ORBit2
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
10139N/AProvides: ORBit2
10139N/ASummary: High-performance CORBA Object Request Broker
10139N/AVersion: 2.14.12
10139N/ARelease: 3
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-%{version}.tar.bz2
10139N/ASource1: orbitrc
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AURL: http://www.gnome.org/projects/ORBit2
10139N/ADocDir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A# date:2008-04-15 bugzilla:527128 owner:jefftsai type:bug
10139N/APatch1: ORBit-01-linc-localhost.diff
10139N/A
10139N/A%define libIDL_version 0.8.2
10139N/A%define popt_version 1.6.4
10139N/A%define gtk_doc_version 1.1
10139N/A%define linc_version 1.1.1
10139N/A
10139N/ARequires: libIDL >= %{libIDL_version}
10139N/ARequires: popt >= %{popt_version}
10139N/ABuildRequires: libIDL-devel >= %{libIDL_version}
10139N/ABuildRequires: popt-devel >= %{popt_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/A
10139N/AObsoletes: linc < %{linc_version}
10139N/AProvides: linc = %{linc_version}
10139N/AObsoletes: linc-devel < %{linc_version}
10139N/AProvides: linc-devel = %{linc_version}
10139N/A
10139N/A%description
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%package devel
10139N/ASummary: High-performance CORBA Object Request Broker
10139N/AGroup: Development/Libraries
10139N/AProvides: ORBit2-devel
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ARequires: libIDL-devel >= %{libIDL_version}
10139N/A
10139N/A%description devel
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/Aln -s `pwd`/src/services/name `pwd`/include/ORBitservices
10139N/A
10139N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --copy --force
10139N/Agtkdocize
10139N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Ainstall -d $RPM_BUILD_ROOT%{_sysconfdir}
10139N/Ainstall --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/orbitrc
10139N/AAFILES=" libORBit-2 libORBit-imodule-2 libORBitCosNaming-2 orbit-2.0/Everything_module"
10139N/Apushd $RPM_BUILD_ROOT%{_libdir}
10139N/Afor i in $AFILES; do
10139N/A rm $i.a
10139N/A rm $i.la
10139N/Adone
10139N/Apopd
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/libORBit*.so.*
10139N/A%{_libdir}/orbit-2.0/Every*so*
10139N/A%{_bindir}/ior-decode-2
10139N/A%{_bindir}/typelib-dump
10139N/A%{_bindir}/linc-cleanup-sockets
10139N/A%{_sysconfdir}/orbitrc
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/orbit-2.0
10139N/A%{_bindir}/orbit-idl-2
10139N/A%{_bindir}/orbit2-config
10139N/A%{_libdir}/libname-server-2.a
10139N/A%{_libdir}/libORBit*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/idl/orbit-2.0/*.idl
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/html/ORBit2
10139N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
10139N/A* Tue Apr 15 2008 - jeff.cai@sun.com
10139N/A- Add patch -01-linc-localhost.diff
10139N/A Fix bug #527128
10139N/A* Tue Jan 29 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.14.12.
10139N/A* Fri Jan 25 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.14.11.
10139N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.10.
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.9.
10139N/A* Fri Jul 27 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.8. Remove upstream patch, 01-secureports.
10139N/A* Wed Apr 04 2007 - brian.cameron@sun.com
10139N/A- Add patch ORBit2-01-secureports.diff so that ports are opened more
10139N/A securely. This makes sure to bind the socket when using IPv4 and
10139N/A IPv6 since this is needed for Secure-By-Default requirements to be
10139N/A met. Without this when you run "netstat -a" you see that all the
10139N/A GNOME sockets are listening wide open on the internet even when
10139N/A ORBLocalOnly=1 in /etc/orbitrc. After this change, you see that
10139N/A the ports are listed properly with "localhost.####" in the "Local
10139N/A Address" column. This indicates Secure By Default is working.
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed adding ccdir to PATH
10139N/A* Tue Mar 06 2005 - damien.carbery@sun.com
- Bump to 2.14.7.
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 2.14.6. Remove upstream patch, 01-uninstalled_pc.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.14.5.
* Mon Dec 18 2006 - damien.carbery@sun.com
- Bump to 2.14.4. Remove upstream patch, ORBit-02-fixhypen.diff.
* Fri Dec 08 2006 - damien.carbery@sun.com
- Bump to 2.14.3. Remove upstream patches, 03-gcc-Werror and 04-localonly.
Renumber remainder.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Wed Sep 20 2006 - brian.cameron@sun.omc
- Add patch ORBit-06-fixhyphen.diff to resolve escalation #1-19359745
and bug 6466464. GNOME Bugzilla bug #152659.
* Fri Sep 15 2006 - brian.cameron@sun.com
- Remove patch ORBit-03-dhcp-hostname.diff after reviewing with the
maintainer, Michael Meeks, andt he patch writer Arvind
Samptur we all agreed that this is the wrong approach to fix any
issues with ORBit haveing problems with the hostname changing due to
DHCP reallocation.
* Tue Aug 1 2006 - brian.cameron@sun.com
- Add patch 5 so LocalOnly mode works on Solaris. This patch causes
the linc library to not use getaddrinfo() and getaddrname(), which
do not seem to work on Solaris. The fallback code that uses
gethostbyname() and gethostbyaddr() seem to work better. Might be
good to fix the getaddrinfo(), getaddrname() code to work on
Solaris, though not sure if this is really necessary.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.14.2.
* Tue Jun 2 2006 - simon.zheng@sun.com
- Add patch, ORBIT-05-signal-broadcast.diff.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Thu Feb 9 2006 - damien.carbery@sun.com
- Remove upstream patch, ORBit-05-illegal_cast.diff.
* Wed Feb 8 2006 - damien.carbery@sun.com
- Bump to 2.13.3.
* Wed Dec 21 2005 - damien.carbery@sun.com
- Add patch, 05-illegal_cast.diff, to remove unnecessary cast that breaks the
build. Bugzilla #324686.
* Tue Dec 20 2005 - damien.carbery@sun.com
- Bump to 2.13.2. Remove upstream patch, 04-ipv4-port-hosed.
- Add ORBit-04-gcc-Werror.diff so gcc option is only set when using gcc.
* Thu Oct 06 2005 - damien.carbery@sun.com
- Add gtkdocize call to 64 bit section.
* Wed Sep 29 2005 - damien.carbery@sun.com
- Add gtkdocize call for automake.
* Tue Sep 27 2005 - damien.carbery@sun.com
- Bump to 2.12.4.
* Sun Sep 18 2005 - glynn.foster@sun.com
- Remove some patches.
* Wed Aug 17 2005 - damien.carbery@sun.com
- Bump to 2.12.3.
* Wed Jun 15 2005 - laca@sun.com
- Add patch new-pkgconfig.diff taken from GNOME CVS to make ORBit2 build
with pkg-config > 0.15.0
* Fri May 06 2005 - glynn.foster@wipro.com
- Bump to 2.12.2
* Tue Apr 19 2005 - arvind.samptru@wipro.com
- fix login failure when ipv4 port in the IOR
is taken to be valid on login after reboot
Fixes #6238754
* Fri Mar 11 2005 - arvind.samptur@wipro.com
- fix a bogus linc_protocol_destroy assertion
coming up at install time
* Wed Mar 02 2005 - arvind.samptur@wipro.com
- another attempt to fix dhcp bug safely.
* Tue Feb 15 2005 - arvind.samptur@wipro.com
- Add patch to fix dhcp hostname change blocking
the login
* Tue Dec 21 2004 - ghee.teo@sun.com
- Obsoletes linc for upgrade purposes. Fix bug 6211773.
* Fri Oct 29 2004 - laca@sun.com
- use $CC64 for the 64-bit build if defined
* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
- Create 64bit libraries for Solaris
* Wed Aug 18 2004 - brian.cameron@sun.com
- added --enable-gtk-doc.
* Thu Jul 08 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Fri Jun 11 2004 - <ghee.teo@sun.com>
- Put back /etc/orbitrc which is required by A11y login. Bug 5059822.
* Tue Jun 08 2004 - <ghee.teo@sun.com>
- removed /etc/orbitrc at the moment as this is a feature for Cinnabar not
metro.
* Mon Feb 23 2004 - <stephen.browne@sun.com>
- Bump to 2.9.8
* Wed Feb 11 2004 - <matt.keenan@sun.com>
- Bump to 2.9.7, gtk-doc.make hack patch 03
* Mon Dec 15 2003 - <glynn.foster@sun.com>
- Bump to 2.9.2
* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-2
- Require gtk-doc.
* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-1
- Update to 2.8.1.
* Thu Aug 14 2003 - <laca@sun.com>
- add patch to disable static linking of test programs
- remove lib*.a and .la, except libname-server-2.a which is
apparently needed by bonobo-activation
- move *.so to -devel
* Fri Aug 01 2003 - <markmc@sun.com> 2.6.3-1
- Upgrade to 2.6.3.
* Wed Apr 30 2003 - <niall.power@sun.com>
- Create new spec file for ORBit2