ORBit2.spec revision 10969
10139N/A
10139N/A# spec file for package ORBit2
10139N/A#
12147N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner:gheet
10139N/A#
17177N/AName: ORBit2
18603N/ALicense: LGPL
17177N/AGroup: System/Libraries
10139N/AProvides: ORBit2
10139N/ASummary: High-performance CORBA Object Request Broker
10139N/AVersion: 2.14.8
19088N/ARelease: 3
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
18615N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-%{version}.tar.bz2
10139N/ASource1: orbitrc
19088N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AURL: http://www.gnome.org/projects/ORBit2
16360N/ADocDir: %{_defaultdocdir}/doc
16428N/AAutoreqprov: on
16428N/APrereq: /sbin/ldconfig
16428N/A
16428N/A%define libIDL_version 0.8.2
16428N/A%define popt_version 1.6.4
10491N/A%define gtk_doc_version 1.1
12088N/A%define linc_version 1.1.1
10139N/A
12088N/ARequires: libIDL >= %{libIDL_version}
10139N/ARequires: popt >= %{popt_version}
12088N/ABuildRequires: libIDL-devel >= %{libIDL_version}
12176N/ABuildRequires: popt-devel >= %{popt_version}
12196N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
12306N/A
12368N/AObsoletes: linc < %{linc_version}
13088N/AProvides: linc = %{linc_version}
13278N/AObsoletes: linc-devel < %{linc_version}
16768N/AProvides: linc-devel = %{linc_version}
14363N/A
16768N/A%description
16642N/AORBit is a high-performance CORBA (Common Object Request Broker
19088N/AArchitecture) ORB (object request broker). It allows programs to
19088N/Asend requests and receive replies from other programs, regardless
19088N/Aof the locations of the two programs. CORBA is an architecture that
19088N/Aenables communication between program objects, regardless of the
19088N/Aprogramming language they're written in or the operating system they
19088N/Arun on.
19088N/A
19088N/A%package devel
19088N/ASummary: High-performance CORBA Object Request Broker
10139N/AGroup: Development/Libraries
10139N/AProvides: ORBit2-devel
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ARequires: libIDL-devel >= %{libIDL_version}
10139N/A
10139N/A%description devel
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ..
10139N/Acp -rp ORBit2-%{version} ORBit2-%{version}-64
10139N/Acd ORBit2-%{version}
10139N/A%endif
10139N/A%endif
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
12819N/A
12288N/ACONFLAGS="--prefix=%{_prefix}"
15377N/A
14363N/A%ifos solaris
15959N/A%ifarch amd64 sparcv9
18549N/ACPUS=$(($CPUS*4))
18786N/A
19088N/Acd ../ORBit2-%version-64
19088N/A
10139N/Aexport CFLAGS="$CFLAGS64"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
10139N/A
10139N/Alibtoolize --copy --force
10139N/Agtkdocize
10139N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/A./configure $CONFLAGS \
10139N/A --bindir=%{_bindir}/%{_arch64} \
10139N/A --libdir=%{_libdir}/%{_arch64} \
10139N/A --libexecdir=%{_libexecdir}/%{_arch64} \
10139N/A --sysconfdir=%{_sysconfdir}/%{_arch64} \
10139N/A --disable-gtk-doc
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/Acd ../ORBit2-%version
18138N/A
18195N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10318N/Aexport CFLAGS="$CFLAGS32"
10318N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10318N/A
10318N/A%endif
10318N/A%endif
10139N/A
12140N/A
19088N/Alibtoolize --copy --force
16309N/Agtkdocize
10139N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure $CONFLAGS \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
17379N/A%install
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ../ORBit2-%version-64
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm -f $RPM_BUILD_ROOT%{_bindir}/%{_arch64}/orbit2-config
10139N/Acd ../ORBit2-%version
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Ainstall -d $RPM_BUILD_ROOT%{_sysconfdir}
10139N/Ainstall --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/orbitrc
10139N/AAFILES=" libORBit-2 libORBit-imodule-2 libORBitCosNaming-2 orbit-2.0/Everything_module"
10139N/Apushd $RPM_BUILD_ROOT%{_libdir}
10139N/Afor i in $AFILES; do
10139N/A rm $i.a
10139N/A rm $i.la
10139N/Adone
10139N/Apopd
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
19088N/A%postun
19088N/A/sbin/ldconfig
19088N/A
19088N/A%files
19088N/A%defattr(-, root, root)
19088N/A%{_libdir}/libORBit*.so.*
19088N/A%{_libdir}/orbit-2.0/Every*so*
19088N/A%{_bindir}/ior-decode-2
19088N/A%{_bindir}/typelib-dump
19088N/A%{_bindir}/linc-cleanup-sockets
19088N/A%{_sysconfdir}/orbitrc
19088N/A
19088N/A%files devel
18786N/A%defattr(-, root, root)
18786N/A%{_includedir}/orbit-2.0
18623N/A%{_bindir}/orbit-idl-2
18623N/A%{_bindir}/orbit2-config
18549N/A%{_libdir}/libname-server-2.a
18549N/A%{_libdir}/libORBit*.so
18521N/A%{_libdir}/pkgconfig/*.pc
18521N/A%{_datadir}/idl/orbit-2.0/*.idl
18511N/A%{_datadir}/aclocal/*.m4
18511N/A%{_datadir}/gtk-doc/html/ORBit2
18436N/A%{_mandir}/man1/*
18436N/A%{_mandir}/man3/*
18303N/A
18303N/A%changelog
18195N/A* Fri Jul 27 2007 - damien.carbery@sun.com
18195N/A- Bump to 2.14.8. Remove upstream patch, 01-secureports.
17605N/A* Wed Apr 04 2007 - brian.cameron@sun.com
17605N/A- Add patch ORBit2-01-secureports.diff so that ports are opened more
17496N/A securely. This makes sure to bind the socket when using IPv4 and
17496N/A IPv6 since this is needed for Secure-By-Default requirements to be
17379N/A met. Without this when you run "netstat -a" you see that all the
17379N/A GNOME sockets are listening wide open on the internet even when
17320N/A ORBLocalOnly=1 in /etc/orbitrc. After this change, you see that
17320N/A the ports are listed properly with "localhost.####" in the "Local
17234N/A Address" column. This indicates Secure By Default is working.
17234N/A* Wed Mar 15 2007 - dougs@truemail.co.th
17091N/A- Removed adding ccdir to PATH
17091N/A* Tue Mar 06 2005 - damien.carbery@sun.com
17091N/A- Bump to 2.14.7.
16821N/A* Tue Feb 13 2007 - damien.carbery@sun.com
16821N/A- Bump to 2.14.6. Remove upstream patch, 01-uninstalled_pc.
16802N/A* Mon Jan 22 2007 - damien.carbery@sun.com
16802N/A- Bump to 2.14.5.
16802N/A* Mon Dec 18 2006 - damien.carbery@sun.com
16768N/A- Bump to 2.14.4. Remove upstream patch, ORBit-02-fixhypen.diff.
16667N/A* Fri Dec 08 2006 - damien.carbery@sun.com
16667N/A- Bump to 2.14.3. Remove upstream patches, 03-gcc-Werror and 04-localonly.
16667N/A Renumber remainder.
16667N/A* Fri Nov 3 2006 - laca@sun.com
16653N/A- use %gtk_doc_option in configure so that it can be disabled using
16653N/A --without-gtk-doc
16367N/A* Wed Sep 20 2006 - brian.cameron@sun.omc
16367N/A- Add patch ORBit-06-fixhyphen.diff to resolve escalation #1-19359745
16309N/A and bug 6466464. GNOME Bugzilla bug #152659.
16309N/A* Fri Sep 15 2006 - brian.cameron@sun.com
16134N/A- Remove patch ORBit-03-dhcp-hostname.diff after reviewing with the
16134N/A maintainer, Michael Meeks, andt he patch writer Arvind
16030N/A Samptur we all agreed that this is the wrong approach to fix any
16030N/A issues with ORBit haveing problems with the hostname changing due to
15959N/A DHCP reallocation.
15959N/A* Tue Aug 1 2006 - brian.cameron@sun.com
15880N/A- Add patch 5 so LocalOnly mode works on Solaris. This patch causes
15880N/A the linc library to not use getaddrinfo() and getaddrname(), which
15860N/A do not seem to work on Solaris. The fallback code that uses
15860N/A gethostbyname() and gethostbyaddr() seem to work better. Might be
15838N/A good to fix the getaddrinfo(), getaddrname() code to work on
15838N/A Solaris, though not sure if this is really necessary.
15613N/A* Mon Jul 24 2006 - damien.carbery@sun.com
15613N/A- Bump to 2.14.2.
15613N/A* Tue Jun 2 2006 - simon.zheng@sun.com
15521N/A- Add patch, ORBIT-05-signal-broadcast.diff.
15521N/A* Tue Mar 14 2006 - damien.carbery@sun.com
15521N/A- Bump to 2.14.0.
15448N/A* Thu Feb 9 2006 - damien.carbery@sun.com
15448N/A- Remove upstream patch, ORBit-05-illegal_cast.diff.
15448N/A* Wed Feb 8 2006 - damien.carbery@sun.com
15448N/A- Bump to 2.13.3.
14363N/A* Wed Dec 21 2005 - damien.carbery@sun.com
14363N/A- Add patch, 05-illegal_cast.diff, to remove unnecessary cast that breaks the
14196N/A build. Bugzilla #324686.
14196N/A* Tue Dec 20 2005 - damien.carbery@sun.com
14136N/A- Bump to 2.13.2. Remove upstream patch, 04-ipv4-port-hosed.
14136N/A- Add ORBit-04-gcc-Werror.diff so gcc option is only set when using gcc.
13910N/A* Thu Oct 06 2005 - damien.carbery@sun.com
13910N/A- Add gtkdocize call to 64 bit section.
13910N/A* Wed Sep 29 2005 - damien.carbery@sun.com
13876N/A- Add gtkdocize call for automake.
13876N/A* Tue Sep 27 2005 - damien.carbery@sun.com
13791N/A- Bump to 2.12.4.
13791N/A* Sun Sep 18 2005 - glynn.foster@sun.com
13620N/A- Remove some patches.
13620N/A* Wed Aug 17 2005 - damien.carbery@sun.com
13519N/A- Bump to 2.12.3.
13519N/A* Wed Jun 15 2005 - laca@sun.com
13497N/A- Add patch new-pkgconfig.diff taken from GNOME CVS to make ORBit2 build
13497N/A with pkg-config > 0.15.0
13400N/A* Fri May 06 2005 - glynn.foster@wipro.com
13400N/A- Bump to 2.12.2
13278N/A* Tue Apr 19 2005 - arvind.samptru@wipro.com
13278N/A- fix login failure when ipv4 port in the IOR
13278N/A is taken to be valid on login after reboot
13109N/A Fixes #6238754
13109N/A* Fri Mar 11 2005 - arvind.samptur@wipro.com
13088N/A- fix a bogus linc_protocol_destroy assertion
13088N/A coming up at install time
13088N/A* Wed Mar 02 2005 - arvind.samptur@wipro.com
13088N/A- another attempt to fix dhcp bug safely.
13055N/A* Tue Feb 15 2005 - arvind.samptur@wipro.com
13055N/A- Add patch to fix dhcp hostname change blocking
12819N/A the login
12819N/A* Tue Dec 21 2004 - ghee.teo@sun.com
12812N/A- Obsoletes linc for upgrade purposes. Fix bug 6211773.
12812N/A* Fri Oct 29 2004 - laca@sun.com
12811N/A- use $CC64 for the 64-bit build if defined
12811N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
12765N/A- Create 64bit libraries for Solaris
12765N/A* Wed Aug 18 2004 - brian.cameron@sun.com
12746N/A- added --enable-gtk-doc.
12746N/A* Thu Jul 08 2004 - niall.power@sun.com
12619N/A- ported to rpm4
12619N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
12619N/A- added "-j $CPUS" to make to speed up builds
12584N/A* Fri Jun 11 2004 - <ghee.teo@sun.com>
12584N/A- Put back /etc/orbitrc which is required by A11y login. Bug 5059822.
12468N/A* Tue Jun 08 2004 - <ghee.teo@sun.com>
12468N/A- removed /etc/orbitrc at the moment as this is a feature for Cinnabar not
12368N/A metro.
12368N/A* Mon Feb 23 2004 - <stephen.browne@sun.com>
12368N/A- Bump to 2.9.8
12287N/A* Wed Feb 11 2004 - <matt.keenan@sun.com>
12287N/A- Bump to 2.9.7, gtk-doc.make hack patch 03
12246N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
12246N/A- Bump to 2.9.2
12196N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-2
12196N/A- Require gtk-doc.
12765N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-1
12176N/A- Update to 2.8.1.
12176N/A* Thu Aug 14 2003 - <laca@sun.com>
12147N/A- add patch to disable static linking of test programs
12152N/A- remove lib*.a and .la, except libname-server-2.a which is
12140N/A apparently needed by bonobo-activation
12140N/A- move *.so to -devel
12095N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.6.3-1
12096N/A- Upgrade to 2.6.3.
12096N/A* Wed Apr 30 2003 - <niall.power@sun.com>
12093N/A- Create new spec file for ORBit2
12093N/A