ORBit2.spec revision 10199
10139N/A
10139N/A# spec file for package ORBit2
10139N/A#
12151N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:gheet
10139N/A#
10139N/AName: ORBit2
10139N/ALicense: LGPL
15322N/AGroup: System/Libraries
10139N/AProvides: ORBit2
14030N/ASummary: High-performance CORBA Object Request Broker
14030N/AVersion: 2.14.7
16193N/ARelease: 3
12578N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-%{version}.tar.bz2
10139N/ASource1: orbitrc
11256N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10142N/AURL: http://www.gnome.org/projects/ORBit2
12773N/ADocDir: %{_defaultdocdir}/doc
12773N/AAutoreqprov: on
12773N/APrereq: /sbin/ldconfig
11358N/A
10139N/A%define libIDL_version 0.8.2
11358N/A%define popt_version 1.6.4
11358N/A%define gtk_doc_version 1.1
11358N/A%define linc_version 1.1.1
11358N/A
11358N/ARequires: libIDL >= %{libIDL_version}
11358N/ARequires: popt >= %{popt_version}
14126N/ABuildRequires: libIDL-devel >= %{libIDL_version}
11002N/ABuildRequires: popt-devel >= %{popt_version}
15503N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
13025N/A
13907N/AObsoletes: linc < %{linc_version}
13907N/AProvides: linc = %{linc_version}
15460N/AObsoletes: linc-devel < %{linc_version}
15460N/AProvides: linc-devel = %{linc_version}
15503N/A
16427N/A%description
15543N/AORBit is a high-performance CORBA (Common Object Request Broker
15968N/AArchitecture) ORB (object request broker). It allows programs to
16353N/Asend requests and receive replies from other programs, regardless
16193N/Aof the locations of the two programs. CORBA is an architecture that
16054N/Aenables communication between program objects, regardless of the
16193N/Aprogramming language they're written in or the operating system they
16511N/Arun on.
16511N/A
16623N/A%package devel
16623N/ASummary: High-performance CORBA Object Request Broker
10139N/AGroup: Development/Libraries
10139N/AProvides: ORBit2-devel
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ARequires: libIDL-devel >= %{libIDL_version}
10139N/A
10139N/A%description devel
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ..
10139N/Acp -rp ORBit2-%{version} ORBit2-%{version}-64
10139N/Acd ORBit2-%{version}
10139N/A%endif
10139N/A%endif
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/ACONFLAGS="--prefix=%{_prefix}"
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/ACPUS=$(($CPUS*4))
10139N/A
10139N/Acd ../ORBit2-%version-64
10139N/A
10139N/Aexport CFLAGS="$CFLAGS64"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
10139N/Aexport CC=${CC64:-$CC}
10139N/Asave_PATH="$PATH"
10139N/Accdir=`dirname $CC`
10139N/Aexport PATH=$ccdir:$PATH
10139N/A
10139N/Alibtoolize --copy --force
10139N/Agtkdocize
12274N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
12274N/Aautomake -a -c -f
12274N/Aautoconf
12274N/A
10139N/A./configure $CONFLAGS \
10139N/A --bindir=%{_bindir}/%{_arch64} \
10139N/A --libdir=%{_libdir}/%{_arch64} \
10139N/A --libexecdir=%{_libexecdir}/%{_arch64} \
10142N/A --sysconfdir=%{_sysconfdir}/%{_arch64} \
10139N/A --disable-gtk-doc
16395N/A
16395N/Amake -j $CPUS
10139N/A
11358N/Acd ../ORBit2-%version
10139N/A
11358N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
11358N/Aexport CFLAGS="$CFLAGS32"
11358N/Aexport RPM_OPT_FLAGS="$CFLAGS"
11358N/Aexport CC=${CC32:-$CC}
11002N/Aexport PATH="$save_PATH"
13025N/A
12830N/A%endif
13664N/A%endif
16425N/A
15591N/A
16193N/Alibtoolize --copy --force
16511N/Agtkdocize
16623N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure $CONFLAGS \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ../ORBit2-%version-64
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm -f $RPM_BUILD_ROOT%{_bindir}/%{_arch64}/orbit2-config
10139N/Acd ../ORBit2-%version
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Ainstall -d $RPM_BUILD_ROOT%{_sysconfdir}
10139N/Ainstall --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/orbitrc
10617N/AAFILES=" libORBit-2 libORBit-imodule-2 libORBitCosNaming-2 orbit-2.0/Everything_module"
10139N/Apushd $RPM_BUILD_ROOT%{_libdir}
10139N/Afor i in $AFILES; do
10617N/A rm $i.a
10139N/A rm $i.la
10139N/Adone
10139N/Apopd
10139N/A
10139N/A
12773N/A%clean
12773N/Arm -rf $RPM_BUILD_ROOT
12773N/A
12773N/A%post
12773N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/libORBit*.so.*
10139N/A%{_libdir}/orbit-2.0/Every*so*
10139N/A%{_bindir}/ior-decode-2
10139N/A%{_bindir}/typelib-dump
10139N/A%{_bindir}/linc-cleanup-sockets
10139N/A%{_sysconfdir}/orbitrc
11189N/A
11155N/A%files devel
12830N/A%defattr(-, root, root)
10617N/A%{_includedir}/orbit-2.0
10139N/A%{_bindir}/orbit-idl-2
10139N/A%{_bindir}/orbit2-config
10139N/A%{_libdir}/libname-server-2.a
10139N/A%{_libdir}/libORBit*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/idl/orbit-2.0/*.idl
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/html/ORBit2
10139N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
12893N/A
10139N/A%changelog
10139N/A* Tue Mar 06 2005 - damien.carbery@sun.com
11358N/A- Bump to 2.14.7.
15389N/A* Tue Feb 13 2007 - damien.carbery@sun.com
15389N/A- Bump to 2.14.6. Remove upstream patch, 01-uninstalled_pc.
15389N/A* Mon Jan 22 2007 - damien.carbery@sun.com
15389N/A- Bump to 2.14.5.
11358N/A* Mon Dec 18 2006 - damien.carbery@sun.com
11358N/A- Bump to 2.14.4. Remove upstream patch, ORBit-02-fixhypen.diff.
10248N/A* Fri Dec 08 2006 - damien.carbery@sun.com
10248N/A- Bump to 2.14.3. Remove upstream patches, 03-gcc-Werror and 04-localonly.
10139N/A Renumber remainder.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Wed Sep 20 2006 - brian.cameron@sun.omc
10139N/A- Add patch ORBit-06-fixhyphen.diff to resolve escalation #1-19359745
10139N/A and bug 6466464. GNOME Bugzilla bug #152659.
10139N/A* Fri Sep 15 2006 - brian.cameron@sun.com
10139N/A- Remove patch ORBit-03-dhcp-hostname.diff after reviewing with the
10139N/A maintainer, Michael Meeks, andt he patch writer Arvind
10139N/A Samptur we all agreed that this is the wrong approach to fix any
10139N/A issues with ORBit haveing problems with the hostname changing due to
10139N/A DHCP reallocation.
10139N/A* Tue Aug 1 2006 - brian.cameron@sun.com
10139N/A- Add patch 5 so LocalOnly mode works on Solaris. This patch causes
10139N/A the linc library to not use getaddrinfo() and getaddrname(), which
10139N/A do not seem to work on Solaris. The fallback code that uses
10139N/A gethostbyname() and gethostbyaddr() seem to work better. Might be
10139N/A good to fix the getaddrinfo(), getaddrname() code to work on
10139N/A Solaris, though not sure if this is really necessary.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.2.
10139N/A* Tue Jun 2 2006 - simon.zheng@sun.com
10139N/A- Add patch, ORBIT-05-signal-broadcast.diff.
10139N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0.
10139N/A* Thu Feb 9 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, ORBit-05-illegal_cast.diff.
10139N/A* Wed Feb 8 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.3.
10139N/A* Wed Dec 21 2005 - damien.carbery@sun.com
10139N/A- Add patch, 05-illegal_cast.diff, to remove unnecessary cast that breaks the
10139N/A build. Bugzilla #324686.
10139N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.13.2. Remove upstream patch, 04-ipv4-port-hosed.
10139N/A- Add ORBit-04-gcc-Werror.diff so gcc option is only set when using gcc.
10139N/A* Thu Oct 06 2005 - damien.carbery@sun.com
10139N/A- Add gtkdocize call to 64 bit section.
10139N/A* Wed Sep 29 2005 - damien.carbery@sun.com
10139N/A- Add gtkdocize call for automake.
10139N/A* Tue Sep 27 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.4.
10139N/A* Sun Sep 18 2005 - glynn.foster@sun.com
10139N/A- Remove some patches.
10139N/A* Wed Aug 17 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.3.
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- Add patch new-pkgconfig.diff taken from GNOME CVS to make ORBit2 build
10139N/A with pkg-config > 0.15.0
10139N/A* Fri May 06 2005 - glynn.foster@wipro.com
10139N/A- Bump to 2.12.2
10139N/A* Tue Apr 19 2005 - arvind.samptru@wipro.com
10139N/A- fix login failure when ipv4 port in the IOR
10139N/A is taken to be valid on login after reboot
16623N/A Fixes #6238754
16623N/A* Fri Mar 11 2005 - arvind.samptur@wipro.com
16511N/A- fix a bogus linc_protocol_destroy assertion
16511N/A coming up at install time
16395N/A* Wed Mar 02 2005 - arvind.samptur@wipro.com
16395N/A- another attempt to fix dhcp bug safely.
16193N/A* Tue Feb 15 2005 - arvind.samptur@wipro.com
16193N/A- Add patch to fix dhcp hostname change blocking
16190N/A the login
16190N/A* Tue Dec 21 2004 - ghee.teo@sun.com
16054N/A- Obsoletes linc for upgrade purposes. Fix bug 6211773.
16054N/A* Fri Oct 29 2004 - laca@sun.com
16013N/A- use $CC64 for the 64-bit build if defined
16013N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
16013N/A- Create 64bit libraries for Solaris
16038N/A* Wed Aug 18 2004 - brian.cameron@sun.com
15968N/A- added --enable-gtk-doc.
15968N/A* Thu Jul 08 2004 - niall.power@sun.com
15968N/A- ported to rpm4
15792N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
15792N/A- added "-j $CPUS" to make to speed up builds
15591N/A* Fri Jun 11 2004 - <ghee.teo@sun.com>
15591N/A- Put back /etc/orbitrc which is required by A11y login. Bug 5059822.
15591N/A* Tue Jun 08 2004 - <ghee.teo@sun.com>
15543N/A- removed /etc/orbitrc at the moment as this is a feature for Cinnabar not
15543N/A metro.
15543N/A* Mon Feb 23 2004 - <stephen.browne@sun.com>
15543N/A- Bump to 2.9.8
15503N/A* Wed Feb 11 2004 - <matt.keenan@sun.com>
15503N/A- Bump to 2.9.7, gtk-doc.make hack patch 03
15460N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
15460N/A- Bump to 2.9.2
15389N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-2
15389N/A- Require gtk-doc.
15389N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-1
15347N/A- Update to 2.8.1.
15347N/A* Thu Aug 14 2003 - <laca@sun.com>
15347N/A- add patch to disable static linking of test programs
15347N/A- remove lib*.a and .la, except libname-server-2.a which is
15247N/A apparently needed by bonobo-activation
15247N/A- move *.so to -devel
15230N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.6.3-1
15230N/A- Upgrade to 2.6.3.
14468N/A* Wed Apr 30 2003 - <niall.power@sun.com>
14468N/A- Create new spec file for ORBit2
14362N/A