10139N/A
10139N/A# spec file for package ORBit2
10139N/A#
12273N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner gheet
10139N/A#
17177N/A
18602N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17177N/A
10139N/AName: ORBit2
19947N/ALicense: LGPLv2,GPLv2
10139N/AGroup: System/Libraries
10139N/AProvides: ORBit2
10139N/ASummary: High-performance CORBA Object Request Broker
19064N/AVersion: 2.14.19
14559N/ARelease: 1
10139N/ADistribution: Java Desktop System
18602N/AVendor: Gnome Community
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-%{version}.tar.bz2
16839N/A# date:2009-07-22 owner:gheet type:branding doo:10086
16839N/APatch1: ORBit2-01-alignments.diff
18820N/A# date:2010-05-28 owner:wangke type:bug doo:15964
18797N/APatch2: ORBit2-02-custom-g-main-context.diff
10142N/ASource1: orbitrc
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AURL: http://www.gnome.org/projects/ORBit2
10139N/ADocDir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define libIDL_version 0.8.2
10139N/A%define popt_version 1.6.4
10139N/A%define gtk_doc_version 1.1
10139N/A%define linc_version 1.1.1
10139N/A
10139N/ARequires: libIDL >= %{libIDL_version}
10139N/ARequires: popt >= %{popt_version}
10139N/ABuildRequires: libIDL-devel >= %{libIDL_version}
10139N/ABuildRequires: popt-devel >= %{popt_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/A
10139N/AObsoletes: linc < %{linc_version}
10139N/AProvides: linc = %{linc_version}
10139N/AObsoletes: linc-devel < %{linc_version}
10139N/AProvides: linc-devel = %{linc_version}
10139N/A
10139N/A%description
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%package devel
10139N/ASummary: High-performance CORBA Object Request Broker
10139N/AGroup: Development/Libraries
10139N/AProvides: ORBit2-devel
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ARequires: libIDL-devel >= %{libIDL_version}
10139N/A
10139N/A%description devel
10139N/AORBit is a high-performance CORBA (Common Object Request Broker
10139N/AArchitecture) ORB (object request broker). It allows programs to
10139N/Asend requests and receive replies from other programs, regardless
10139N/Aof the locations of the two programs. CORBA is an architecture that
10139N/Aenables communication between program objects, regardless of the
10139N/Aprogramming language they're written in or the operating system they
10139N/Arun on.
10139N/A
10139N/A%prep
10139N/A%setup -q
11314N/Aln -s `pwd`/src/services/name `pwd`/include/ORBitservices
10139N/A
16839N/A%patch1 -p1
18797N/A%patch2 -p1
16839N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --copy --force
10139N/Agtkdocize
10139N/Aaclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal
10139N/Aautomake -a -c -f
10139N/Aautoconf
11314N/Aexport CFLAGS="%optflags"
11314N/Aexport LDFLAGS="%_ldflags"
11314N/A./configure --prefix=%{_prefix} \
11314N/A --mandir=%{_mandir} \
11314N/A --datadir=%{_datadir} \
11314N/A --libdir=%{_libdir} \
11314N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Ainstall -d $RPM_BUILD_ROOT%{_sysconfdir}
10142N/Ainstall --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/orbitrc
10139N/AAFILES=" libORBit-2 libORBit-imodule-2 libORBitCosNaming-2 orbit-2.0/Everything_module"
10139N/Apushd $RPM_BUILD_ROOT%{_libdir}
10139N/Afor i in $AFILES; do
10139N/A rm $i.a
10139N/A rm $i.la
10139N/Adone
10139N/Apopd
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/libORBit*.so.*
10139N/A%{_libdir}/orbit-2.0/Every*so*
10139N/A%{_bindir}/ior-decode-2
10139N/A%{_bindir}/typelib-dump
10139N/A%{_bindir}/linc-cleanup-sockets
10139N/A%{_sysconfdir}/orbitrc
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/orbit-2.0
10139N/A%{_bindir}/orbit-idl-2
10139N/A%{_bindir}/orbit2-config
10139N/A%{_libdir}/libname-server-2.a
10139N/A%{_libdir}/libORBit*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/idl/orbit-2.0/*.idl
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/html/ORBit2
10139N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
19064N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19064N/A- Bump to 2.14.19.
18797N/A* Fri May 28 2010 - ke.wang@sun.com
18797N/A- Add ORBit2-02-custom-g-main-context.diff to fix doo 15964.
18544N/A* Sat Apr 3 2010 - christian.kelly@sun.com
18544N/A- Bump to 2.14.18.
16143N/A* Fri Mar 13 2009 - dave.lin@sun.com
16143N/A- Bump to 2.14.17
14559N/A* Mon Sep 29 2008 - brian.cameron@sun.com
14559N/A- Bump to 2.14.16.
14452N/A* Sun Sep 21 2008 - christian.kelly@sun.com
14452N/A- Bump to 2.14.15.
13951N/A* Thu Aug 21 2008 - dave.lin@sun.com
13951N/A- Bump to 2.14.14
13313N/A* Tue Jun 03 2008 - damien.carbery@sun.com
13313N/A- Bump to 2.14.13. Remove upstream patch, 01-linc-localhost.
12858N/A* Tue Apr 15 2008 - jeff.cai@sun.com
12858N/A- Add patch -01-linc-localhost.diff
12858N/A Fix bug #527128
12295N/A* Tue Jan 29 2008 - damien.carbery@sun.com
12295N/A- Bump to 2.14.12.
12273N/A* Fri Jan 25 2008 - damien.carbery@sun.com
12273N/A- Bump to 2.14.11.
11416N/A* Fri Oct 19 2007 - damien.carbery@sun.com
11416N/A- Bump to 2.14.10.
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- convert to new style multi-ISA build
11249N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11249N/A- Bump to 2.14.9.
10969N/A* Fri Jul 27 2007 - damien.carbery@sun.com
10969N/A- Bump to 2.14.8. Remove upstream patch, 01-secureports.
10408N/A* Wed Apr 04 2007 - brian.cameron@sun.com
10408N/A- Add patch ORBit2-01-secureports.diff so that ports are opened more
10408N/A securely. This makes sure to bind the socket when using IPv4 and
10408N/A IPv6 since this is needed for Secure-By-Default requirements to be
10408N/A met. Without this when you run "netstat -a" you see that all the
10408N/A GNOME sockets are listening wide open on the internet even when
10408N/A ORBLocalOnly=1 in /etc/orbitrc. After this change, you see that
10408N/A the ports are listed properly with "localhost.####" in the "Local
10408N/A Address" column. This indicates Secure By Default is working.
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed adding ccdir to PATH
10199N/A* Tue Mar 06 2005 - damien.carbery@sun.com
10199N/A- Bump to 2.14.7.
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.6. Remove upstream patch, 01-uninstalled_pc.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.5.
10139N/A* Mon Dec 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.4. Remove upstream patch, ORBit-02-fixhypen.diff.
10139N/A* Fri Dec 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.3. Remove upstream patches, 03-gcc-Werror and 04-localonly.
10139N/A Renumber remainder.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Wed Sep 20 2006 - brian.cameron@sun.omc
10139N/A- Add patch ORBit-06-fixhyphen.diff to resolve escalation #1-19359745
10139N/A and bug 6466464. GNOME Bugzilla bug #152659.
10139N/A* Fri Sep 15 2006 - brian.cameron@sun.com
10139N/A- Remove patch ORBit-03-dhcp-hostname.diff after reviewing with the
10139N/A maintainer, Michael Meeks, andt he patch writer Arvind
10139N/A Samptur we all agreed that this is the wrong approach to fix any
10139N/A issues with ORBit haveing problems with the hostname changing due to
10139N/A DHCP reallocation.
10139N/A* Tue Aug 1 2006 - brian.cameron@sun.com
10139N/A- Add patch 5 so LocalOnly mode works on Solaris. This patch causes
10139N/A the linc library to not use getaddrinfo() and getaddrname(), which
10139N/A do not seem to work on Solaris. The fallback code that uses
10139N/A gethostbyname() and gethostbyaddr() seem to work better. Might be
10139N/A good to fix the getaddrinfo(), getaddrname() code to work on
10139N/A Solaris, though not sure if this is really necessary.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.2.
10139N/A* Tue Jun 2 2006 - simon.zheng@sun.com
10139N/A- Add patch, ORBIT-05-signal-broadcast.diff.
10139N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0.
10139N/A* Thu Feb 9 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, ORBit-05-illegal_cast.diff.
10139N/A* Wed Feb 8 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.3.
10139N/A* Wed Dec 21 2005 - damien.carbery@sun.com
10139N/A- Add patch, 05-illegal_cast.diff, to remove unnecessary cast that breaks the
10139N/A build. Bugzilla #324686.
10139N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.13.2. Remove upstream patch, 04-ipv4-port-hosed.
10139N/A- Add ORBit-04-gcc-Werror.diff so gcc option is only set when using gcc.
10139N/A* Thu Oct 06 2005 - damien.carbery@sun.com
10139N/A- Add gtkdocize call to 64 bit section.
10139N/A* Wed Sep 29 2005 - damien.carbery@sun.com
10139N/A- Add gtkdocize call for automake.
10139N/A* Tue Sep 27 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.4.
10139N/A* Sun Sep 18 2005 - glynn.foster@sun.com
10139N/A- Remove some patches.
10139N/A* Wed Aug 17 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.3.
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- Add patch new-pkgconfig.diff taken from GNOME CVS to make ORBit2 build
10139N/A with pkg-config > 0.15.0
10139N/A* Fri May 06 2005 - glynn.foster@wipro.com
10139N/A- Bump to 2.12.2
10139N/A* Tue Apr 19 2005 - arvind.samptru@wipro.com
10139N/A- fix login failure when ipv4 port in the IOR
10139N/A is taken to be valid on login after reboot
10139N/A Fixes #6238754
10139N/A* Fri Mar 11 2005 - arvind.samptur@wipro.com
10139N/A- fix a bogus linc_protocol_destroy assertion
10139N/A coming up at install time
10139N/A* Wed Mar 02 2005 - arvind.samptur@wipro.com
10139N/A- another attempt to fix dhcp bug safely.
10139N/A* Tue Feb 15 2005 - arvind.samptur@wipro.com
10139N/A- Add patch to fix dhcp hostname change blocking
10139N/A the login
10139N/A* Tue Dec 21 2004 - ghee.teo@sun.com
10139N/A- Obsoletes linc for upgrade purposes. Fix bug 6211773.
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc.
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri Jun 11 2004 - <ghee.teo@sun.com>
10139N/A- Put back /etc/orbitrc which is required by A11y login. Bug 5059822.
10139N/A* Tue Jun 08 2004 - <ghee.teo@sun.com>
10139N/A- removed /etc/orbitrc at the moment as this is a feature for Cinnabar not
10139N/A metro.
10139N/A* Mon Feb 23 2004 - <stephen.browne@sun.com>
10139N/A- Bump to 2.9.8
10139N/A* Wed Feb 11 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.9.7, gtk-doc.make hack patch 03
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Bump to 2.9.2
10139N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-2
10139N/A- Require gtk-doc.
10139N/A* Mon Oct 02 2003 - <markmc@sun.com> 2.8.1-1
10139N/A- Update to 2.8.1.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- add patch to disable static linking of test programs
10139N/A- remove lib*.a and .la, except libname-server-2.a which is
10139N/A apparently needed by bonobo-activation
10139N/A- move *.so to -devel
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.6.3-1
10139N/A- Upgrade to 2.6.3.
10139N/A* Wed Apr 30 2003 - <niall.power@sun.com>
10139N/A- Create new spec file for ORBit2