GConf.spec revision 15894
0N/A#
1827N/A# spec file for package GConf
0N/A#
0N/A# Copyright 2008 Sun Microsystems, Inc.
0N/A# This file and all modifications and additions to the pristine
0N/A# package are under the same license as the package itself.
0N/A#
0N/A# Owner: stephen
0N/A#
0N/AName: GConf
0N/ALicense: LGPL
0N/AGroup: System/Libraries/GNOME
0N/AProvides: GConf
0N/AVersion: 2.25.2
0N/ARelease: 1
0N/ADistribution: Java Desktop System
0N/AVendor: Sun Microsystems, Inc.
0N/ASummary: GNOME Configuration Framework
1472N/ASource: http://ftp.gnome.org/pub/GNOME/sources/GConf/2.25/GConf-%{version}.tar.bz2
1472N/A%if %build_l10n
1472N/ASource1: l10n-configure.sh
0N/A%endif
0N/A#owner:stephen date:2004-08-02 type:bug bugster:5042863 bugzilla:100378
0N/APatch1: GConf-01-g11n-locale-alias.diff
1879N/A#owner:laca date:2006-06-29 type:feature
1879N/APatch2: GConf-02-GCONF_BACKEND_DIR.diff
1879N/A#owner:yippi date:2008-10-09 type:bug bugzilla:555745
1879N/APatch3: GConf-03-user-specific-dbus.diff
1879N/AURL: http://www.gnome.org
1879N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
0N/ADocdir: %{_defaultdocdir}/doc
0N/AAutoreqprov: on
0N/APrereq: /sbin/ldconfig
0N/A
0N/A%define gtk2_version 2.4.0
0N/A%define libxml2_version 2.6.7
0N/A%define ORBit2_version 2.10.1
0N/A%define gtk_doc_version 1.1
0N/A%define popt_version 1.7
0N/A
0N/ARequires: gtk2 >= %{gtk2_version}
0N/ARequires: libxml2 >= %{libxml2_version}
0N/ARequires: ORBit2 >= %{ORBit2_version}
0N/ARequires: popt >= %{popt_version}
0N/ABuildRequires: gtk2-devel >= %{gtk2_version}
0N/ABuildRequires: libxml2-devel >= %{libxml2_version}
0N/ABuildRequires: ORBit2-devel >= %{ORBit2_version}
0N/ABuildRequires: popt-devel >= %{popt_version}
0N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
0N/A
0N/A%description
0N/AGConf is the Configuration Framework for the GNOME Desktop.
0N/A
0N/A%package devel
0N/ASummary: GNOME Configuration Framework Development Libraries
0N/AGroup: Development/Libraries/GNOME
0N/ARequires: %{name} = %{version}
0N/ARequires: libxml2-devel >= %{libxml2_version}
0N/ARequires: ORBit2-devel >= %{ORBit2_version}
0N/ARequires: gtk2-devel >= %{gtk2_version}
0N/A
0N/A%description devel
0N/AGConf is the Configuration Framework for the GNOME Desktop.
0N/A
0N/A%prep
0N/A%setup -q
0N/A%if %build_l10n
0N/A# Disable GNU extensions for ar CR 6730851
0N/Ash %SOURCE1 --disable-gnu-extensions
0N/A%endif
0N/A
0N/A%patch1 -p1
0N/A%patch2 -p1
0N/A%patch3 -p1
0N/A
0N/A%build
0N/A%ifos linux
0N/Aif [ -x /usr/bin/getconf ]; then
0N/A CPUS=`getconf _NPROCESSORS_ONLN`
0N/Afi
0N/A%else
0N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
0N/A%endif
0N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
0N/A CPUS=1
0N/Afi
0N/A
0N/Aexport PKG_CONFIG_PATH=%{_libdir}/pkgconfig
0N/A
0N/A%if %build_l10n
0N/Ash %SOURCE1 --enable-copyright
0N/A%endif
0N/A
0N/Alibtoolize --force
0N/Aaclocal
0N/Aautoheader
0N/Aautoconf
0N/Aexport CFLAGS="%optflags"
0N/Aexport LDFLAGS="%_ldflags"
0N/A./configure \
0N/A --prefix=%{_prefix} \
0N/A --bindir=%{_bindir} \
0N/A --libdir=%{_libdir} \
0N/A --libexecdir=%{_libexecdir} \
0N/A --sysconfdir=%{_sysconfdir} \
0N/A --libexecdir=%{_libexecdir} \
0N/A %{gtk_doc_option}
0N/A
0N/A# For some reason using -j $CPUS breaks the build on my machine with
0N/A# 2 processors, so just using make
0N/A#
0N/Amake
0N/A
0N/A%install
0N/Amake install DESTDIR=$RPM_BUILD_ROOT MKDIR_P="mkdir -p"
0N/A
0N/A#Copy zh_HK from zh_TW
0N/A#Fixes bug 4930405
0N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
0N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
0N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.la
0N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.a
0N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
0N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
0N/A
0N/A%clean
0N/Arm -rf $RPM_BUILD_ROOT
0N/A
0N/A%post
0N/A/sbin/ldconfig
0N/A
0N/A%postun
0N/A/sbin/ldconfig
0N/A
0N/A%files
0N/A%defattr(-, root, root)
0N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
0N/A%{_datadir}/GConf
0N/A%{_bindir}/*
0N/A%{_libexecdir}/*
0N/A%{_libdir}/GConf/2/*.so*
0N/A%{_libdir}/libgconf-2*so.*
0N/A%{_sysconfdir}/gconf
0N/A%{_mandir}/man1/*
0N/A%dir %{_sysconfdir}/gconf/gconf.xml.defaults
0N/A%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
0N/A
0N/A%files devel
1827N/A%defattr(-, root, root)
0N/A%{_includedir}/gconf/2/gconf/*.h
0N/A%{_libdir}/libgconf-2*.so
0N/A%{_libdir}/pkgconfig/*.pc
0N/A%{_datadir}/aclocal/*.m4
0N/A%{_datadir}/gtk-doc/*
0N/A%{_datadir}/sgml/*
0N/A%{_mandir}/man3/*
0N/A
0N/A%changelog
0N/A* Tue Jan 20 2009 - brian.cameron@sun.com
0N/A- Bump to 2.25.0.
0N/A* Fri Oct 10 2008 - darren.kenny@sun.com
0N/A- Add patch GConf-04-user-specific-dbus so D-Bus is restarted without
0N/A DBUS_SESSION_BUS_ADDRESS set if the effective user id looking to connect is
0N/A not the same as the owner of the bus. Fix for bug#2980
0N/A* Fri Sep 26 2008 - brian.cameron@sun.com
0N/A- Bump to 2.24.0. Remove upstream patch GConf-04-nopolkit.diff.
0N/A* Tue Aug 05 2008 - takao.fujiwara@sun.com
0N/A- Add l10n-configure.sh to fix 6730851 ar SEGV
1879N/A* Tue Jun 03 2008 - damien.carbery@sun.com
1879N/A- Bump to 2.23.1.
* Mon Mar 10 2008 - damien.carbery@sun.com
- Bump to 2.22.0.
* Mon Jan 28 2008 - damien.carbery@sun.com
- Bump to 2.21.90.
* Tue Jan 22 2008 - damien.carbery@sun.com
- Bump to 2.21.2. Remove upstream patch 04-glib-pc.
* Thu Jan 10 2008 - damien.carbery@sun.com
- Add patch 04-glib-pc to fix gconf-2.0.pc file type: s/glib/glib-2.0/.
* Wed Jan 09 2008 - damien.carbery@sun.com
- Bump to 2.21.1. Remove upstream patch, 02-daemon-hanged-solaris, rename
remainder.
* Fri Oct 19 2007 - damien.carbery@sun.com
- Bump to 2.20.1.
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Wed Sep 19 2007 - damien.carbery@sun.com
- Bump to 2.20.0.
* Mon Jul 02 2007 - damien.carbery@sun.com
- Bump to 2.19.1.
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed adding ccdir to PATH
* Tue Mar 06 2007 - damien.carbery@sun.com
- Add aclocal call and set MKDIR_P in %install to resolve autoconf version
mismatch.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 2.18.0.1.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 2.18.0. Remove upstream patches, 05-gconftool-makefile-install and
06-use-fdwalk.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Tue Oct 17 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Mon Sep 25 2006 - padraig.obriain@sun.com
- add patch use-fdwalk to speed up clsoing of fds. (bug 6366879)
* Tue Jul 4 2006 - laca@sun.com
- add patch gconftool-makefile-install.diff which makes --makefile-install-rule
continue if a schemas file fails.
* Thu Jun 29 2006 - laca@sun.com
- add patch GCONF_BACKEND_DIR.diff that makes the backend dir relocatable
via env variable
* Sat Mar 18 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Fri Jan 20 2006 - damien.carbery@sun.com
- Bump to 2.13.5.
* Fri Jan 6 2006 - laca@sun.com
- set 64-bit sysconfdir to /etc, since those files are not arch specific
* Wed Nov 30 2005 - damien.carbery@sun.com
- Remove upstream patch, 04-markup-tree-incremental-reads.diff.
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.12.1.
* Thu Oct 20 2005 - laca@sun.com
- add Lorenzo's incremental read patch; already in HEAD
* Wed Sep 14 2005 - brian.cameron@sunc.om
- Bump to 2.12.0.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.92.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.90.
* Wed Jun 15 2005 - laca@sun.com
- add patch pkgconfig.diff that add gconf-2.0 to the pkgconfig deps
- run autoconf
* Wed May 11 2005 - brian.cameron@sun.com
- Remove building with multiple processors, since that is breaking
the build on Solaris.
* Fri May 06 2005 - glynn.foster@wipro.com
- Bump to 2.10.0
* Tue Feb 15 2005 - arvind.samptur@wipro.com
- Add patch to fix such that defaults don't get
installed for all locales since we always
fallback to C locale values
* Fri Oct 29 2004 - laca@sun.com
- use $CC64 for the 64-bit build if defined
* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
- Create 64bit libraries for Solaris
* Fri Sep 24 2004 - yuriy.kuznetsov@sun.com
- Added GConf-06-g11n-potfiles.diff
* Mon Aug 30 2004 - takao.fujiwara@sun.com
- updated GConf-02-g11n-potfiles.diff
* Wed Aug 18 2004 - brian.cameron@sun.com
- added --enable-gtk-doc.
* Wed Aug 11 2004 - ghee.teo@sun.com
- Removed GConf-05-use-global-lock.diff as it is backwards incomptaible in a
heterogeneous environment. While the goal of the project is to allow
concurrent login which has in effect achieved by not having any lock at all.
* Thu Aug 02 2004 - hidetoshi.tajima@sun.com
- create GConf-06-g11n-locale-alias.diff to fix bug #5042863,
the orignal patch is from the bugzilla.gnome.org #100378
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to GConf-l10n-po-1.2.tar.bz2
* Thu Jul 08 2004 - stephen.browne@sun.com
- ported to rpm4/suse91
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Fri Jun 11 2004 - Ghee.Teo@Sun.Com
- Create a patch GConf-05-use-global-lock.diff as we want to use orbit ip
to resolve to a single gconf daemon per user.
* Thu Jun 03 2004 - Ghee.Teo@Sun.Com
- Added GConf-04-daemon-hanged-solaris.diff as the signal handler
is calling non-reentrant code as gconf_log(). SO removed the calls
to these signals, though much of these messages are not that important.
* Wed May 19 2004 - Cyrille.Moureaux@Sun.COM
- added GConf-03-apoc-path-update.diff.
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to GConf-l10n-po-1.1.tar.bz2
* Thu Apr 06 2004 - matt.keenan@sun.com
- Updtaed to 2.6.1 tarball.
* Fri Apr 02 2004 - ghee.teo@sun.com
- Updtaed to 2.6.0 tarball.
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to GConf-l10n-po-1.0.tar.bz2
* Fri Mar 19 2004 - glynn.foster@sun.com
- Bump to 2.5.90 and merge the potfile patches.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added GConf-03-g11n-potfiles.diff
* Wed Feb 11 2004 - <matt.keenan@sun.com>
- Bump to 2.5.1, l10n to 0.7, port 02-fix-potfiles patch
* Mon Dec 15 2003 - <glynn.foster@sun.com>
- Add back the man page stuff, and the backend
notification patch
* Mon Oct 06 2003 - <markmc@sun.com> 2.4.0.1-1
- Update to 2.4.0.1-1.
- Remove dump/load and local locks patches.
* Tue Aug 19 2003 - <niall.power@sun.com>
- add GConf-02-sanity-check.diff patch, fixes 4908212
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Fri Aug 01 2003 - <markmc@sun.com> 2.2.1-1
- Upgrade to 2.2.1
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Fri May 30 2003 - <markmc@sun.com>
- Make sure gconf.xml.mandatory gets created
* Fri May 30 2003 - <markmc@sun.com>
- Add patches required by gnome-panel-2.3.1
- Install .la files
* Thu May 07 2003 - <Niall.Power@Sun.COM>
- Create new spec file for GConf