GConf.spec revision 15871
10139N/A#
10139N/A# spec file for package GConf
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
16307N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:stephen
10139N/A#
17185N/AName: GConf
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries/GNOME
17240N/AProvides: GConf
10139N/AVersion: 2.25.2
10139N/ARelease: 1
13598N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
19135N/ASummary: GNOME Configuration Framework
18688N/ASource: http://ftp.gnome.org/pub/GNOME/sources/GConf/2.25/GConf-%{version}.tar.bz2
18688N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/A#owner:stephen date:2004-08-02 type:bug bugster:5042863 bugzilla:100378
12856N/APatch1: GConf-01-g11n-locale-alias.diff
10139N/A#owner:laca date:2006-06-29 type:feature
10139N/APatch2: GConf-02-GCONF_BACKEND_DIR.diff
10139N/A#owner:yippi date:2008-10-09 type:bug bugzilla:555745
19142N/APatch3: GConf-03-user-specific-dbus.diff
16401N/AURL: http://www.gnome.org
16401N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
18993N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define libxml2_version 2.6.7
10139N/A%define ORBit2_version 2.10.1
10139N/A%define gtk_doc_version 1.1
10139N/A%define popt_version 1.7
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: ORBit2 >= %{ORBit2_version}
16307N/ARequires: popt >= %{popt_version}
13075N/ABuildRequires: gtk2-devel >= %{gtk2_version}
17240N/ABuildRequires: libxml2-devel >= %{libxml2_version}
16575N/ABuildRequires: ORBit2-devel >= %{ORBit2_version}
16575N/ABuildRequires: popt-devel >= %{popt_version}
17529N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
16401N/A
10139N/A%description
10139N/AGConf is the Configuration Framework for the GNOME Desktop.
10139N/A
10139N/A%package devel
10139N/ASummary: GNOME Configuration Framework Development Libraries
10139N/AGroup: Development/Libraries/GNOME
18993N/ARequires: %{name} = %{version}
18993N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/ARequires: ORBit2-devel >= %{ORBit2_version}
10139N/ARequires: gtk2-devel >= %{gtk2_version}
18993N/A
13075N/A%description devel
16575N/AGConf is the Configuration Framework for the GNOME Desktop.
16575N/A
17529N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
19126N/A# Disable GNU extensions for ar CR 6730851
10139N/Ash %SOURCE1 --disable-gnu-extensions
19126N/A%endif
10139N/A
19142N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
19142N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
19142N/Afi
10139N/A
10139N/Aexport PKG_CONFIG_PATH=%{_libdir}/pkgconfig
10139N/A
10139N/A%if %build_l10n
10139N/Ash %SOURCE1 --enable-copyright
13598N/A%endif
10139N/A
10139N/Alibtoolize --force
10139N/Aaclocal
10139N/Aautoheader
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
16745N/Aexport LDFLAGS="%_ldflags"
15964N/A./configure \
13598N/A --prefix=%{_prefix} \
13598N/A --bindir=%{_bindir} \
15964N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
13598N/A --libexecdir=%{_libexecdir} \
10139N/A %{gtk_doc_option}
10139N/A
16745N/A# For some reason using -j $CPUS breaks the build on my machine with
16745N/A# 2 processors, so just using make
10139N/A#
13598N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT MKDIR_P="mkdir -p"
10139N/A
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/A
16307N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
16307N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/GConf
10139N/A%{_bindir}/*
10139N/A%{_libexecdir}/*
10139N/A%{_libdir}/GConf/2/*.so*
10139N/A%{_libdir}/libgconf-2*so.*
10139N/A%{_sysconfdir}/gconf
10139N/A%{_mandir}/man1/*
10139N/A%dir %{_sysconfdir}/gconf/gconf.xml.defaults
10139N/A%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/gconf/2/gconf/*.h
10139N/A%{_libdir}/libgconf-2*.so
14348N/A%{_libdir}/pkgconfig/*.pc
14348N/A%{_datadir}/aclocal/*.m4
14348N/A%{_datadir}/gtk-doc/*
14348N/A%{_datadir}/sgml/*
14348N/A%{_mandir}/man3/*
14348N/A
14348N/A%changelog
14348N/A* Tue Jan 20 2009 - brian.cameron@sun.com
14348N/A- Bump to 2.25.0.
14348N/A* Fri Oct 10 2008 - darren.kenny@sun.com
16575N/A- Add patch GConf-04-user-specific-dbus so D-Bus is restarted without
16575N/A DBUS_SESSION_BUS_ADDRESS set if the effective user id looking to connect is
16575N/A not the same as the owner of the bus. Fix for bug#2980
16575N/A* Fri Sep 26 2008 - brian.cameron@sun.com
14348N/A- Bump to 2.24.0. Remove upstream patch GConf-04-nopolkit.diff.
16575N/A* Tue Aug 05 2008 - takao.fujiwara@sun.com
16575N/A- Add l10n-configure.sh to fix 6730851 ar SEGV
14348N/A* Tue Jun 03 2008 - damien.carbery@sun.com
14348N/A- Bump to 2.23.1.
14348N/A* Mon Mar 10 2008 - damien.carbery@sun.com
14348N/A- Bump to 2.22.0.
14348N/A* Mon Jan 28 2008 - damien.carbery@sun.com
14348N/A- Bump to 2.21.90.
14348N/A* Tue Jan 22 2008 - damien.carbery@sun.com
14348N/A- Bump to 2.21.2. Remove upstream patch 04-glib-pc.
14348N/A* Thu Jan 10 2008 - damien.carbery@sun.com
14348N/A- Add patch 04-glib-pc to fix gconf-2.0.pc file type: s/glib/glib-2.0/.
14348N/A* Wed Jan 09 2008 - damien.carbery@sun.com
14348N/A- Bump to 2.21.1. Remove upstream patch, 02-daemon-hanged-solaris, rename
14348N/A remainder.
14348N/A* Fri Oct 19 2007 - damien.carbery@sun.com
14348N/A- Bump to 2.20.1.
14348N/A* Fri Sep 28 2007 - laca@sun.com
14348N/A- convert to new style multi-ISA build
14348N/A* Wed Sep 19 2007 - damien.carbery@sun.com
14348N/A- Bump to 2.20.0.
14348N/A* Mon Jul 02 2007 - damien.carbery@sun.com
14348N/A- Bump to 2.19.1.
14348N/A* Wed Mar 15 2007 - dougs@truemail.co.th
14348N/A- Removed adding ccdir to PATH
14348N/A* Tue Mar 06 2007 - damien.carbery@sun.com
14348N/A- Add aclocal call and set MKDIR_P in %install to resolve autoconf version
14348N/A mismatch.
14348N/A* Mon Mar 05 2007 - damien.carbery@sun.com
14348N/A- Bump to 2.18.0.1.
14348N/A* Mon Mar 05 2007 - damien.carbery@sun.com
14348N/A- Bump to 2.18.0. Remove upstream patches, 05-gconftool-makefile-install and
14348N/A 06-use-fdwalk.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Tue Oct 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
10139N/A- add patch use-fdwalk to speed up clsoing of fds. (bug 6366879)
10139N/A* Tue Jul 4 2006 - laca@sun.com
10139N/A- add patch gconftool-makefile-install.diff which makes --makefile-install-rule
10139N/A continue if a schemas file fails.
10139N/A* Thu Jun 29 2006 - laca@sun.com
10139N/A- add patch GCONF_BACKEND_DIR.diff that makes the backend dir relocatable
10139N/A via env variable
10139N/A* Sat Mar 18 2006 - damien.carbery@sun.com
10522N/A- Bump to 2.14.0.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.5.
10139N/A* Fri Jan 6 2006 - laca@sun.com
10139N/A- set 64-bit sysconfdir to /etc, since those files are not arch specific
10139N/A* Wed Nov 30 2005 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 04-markup-tree-incremental-reads.diff.
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.1.
10139N/A* Thu Oct 20 2005 - laca@sun.com
10139N/A- add Lorenzo's incremental read patch; already in HEAD
10139N/A* Wed Sep 14 2005 - brian.cameron@sunc.om
10139N/A- Bump to 2.12.0.
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.92.
17967N/A* Mon Aug 15 2005 - damien.carbery@sun.com
17967N/A- Bump to 2.11.90.
17529N/A* Wed Jun 15 2005 - laca@sun.com
17529N/A- add patch pkgconfig.diff that add gconf-2.0 to the pkgconfig deps
17529N/A- run autoconf
17240N/A* Wed May 11 2005 - brian.cameron@sun.com
17240N/A- Remove building with multiple processors, since that is breaking
16745N/A the build on Solaris.
16745N/A* Fri May 06 2005 - glynn.foster@wipro.com
16745N/A- Bump to 2.10.0
16714N/A* Tue Feb 15 2005 - arvind.samptur@wipro.com
16714N/A- Add patch to fix such that defaults don't get
16714N/A installed for all locales since we always
16575N/A fallback to C locale values
16307N/A* Fri Oct 29 2004 - laca@sun.com
16307N/A- use $CC64 for the 64-bit build if defined
16224N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
16224N/A- Create 64bit libraries for Solaris
16224N/A* Fri Sep 24 2004 - yuriy.kuznetsov@sun.com
16224N/A- Added GConf-06-g11n-potfiles.diff
15964N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
15964N/A- updated GConf-02-g11n-potfiles.diff
15964N/A* Wed Aug 18 2004 - brian.cameron@sun.com
14348N/A- added --enable-gtk-doc.
14348N/A* Wed Aug 11 2004 - ghee.teo@sun.com
13075N/A- Removed GConf-05-use-global-lock.diff as it is backwards incomptaible in a
13075N/A heterogeneous environment. While the goal of the project is to allow
12203N/A concurrent login which has in effect achieved by not having any lock at all.
12203N/A* Thu Aug 02 2004 - hidetoshi.tajima@sun.com
11314N/A- create GConf-06-g11n-locale-alias.diff to fix bug #5042863,
11314N/A the orignal patch is from the bugzilla.gnome.org #100378
10522N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10522N/A- Updated l10n content to GConf-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - stephen.browne@sun.com
10139N/A- ported to rpm4/suse91
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri Jun 11 2004 - Ghee.Teo@Sun.Com
10139N/A- Create a patch GConf-05-use-global-lock.diff as we want to use orbit ip
10139N/A to resolve to a single gconf daemon per user.
10139N/A* Thu Jun 03 2004 - Ghee.Teo@Sun.Com
10139N/A- Added GConf-04-daemon-hanged-solaris.diff as the signal handler
10139N/A is calling non-reentrant code as gconf_log(). SO removed the calls
10139N/A to these signals, though much of these messages are not that important.
10139N/A* Wed May 19 2004 - Cyrille.Moureaux@Sun.COM
10139N/A- added GConf-03-apoc-path-update.diff.
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to GConf-l10n-po-1.1.tar.bz2
10139N/A* Thu Apr 06 2004 - matt.keenan@sun.com
10139N/A- Updtaed to 2.6.1 tarball.
10139N/A* Fri Apr 02 2004 - ghee.teo@sun.com
10139N/A- Updtaed to 2.6.0 tarball.
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to GConf-l10n-po-1.0.tar.bz2
10139N/A* Fri Mar 19 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.5.90 and merge the potfile patches.
10139N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
10139N/A- added GConf-03-g11n-potfiles.diff
10139N/A* Wed Feb 11 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.5.1, l10n to 0.7, port 02-fix-potfiles patch
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- Add back the man page stuff, and the backend
10139N/A notification patch
10139N/A* Mon Oct 06 2003 - <markmc@sun.com> 2.4.0.1-1
10139N/A- Update to 2.4.0.1-1.
10139N/A- Remove dump/load and local locks patches.
10139N/A* Tue Aug 19 2003 - <niall.power@sun.com>
10139N/A- add GConf-02-sanity-check.diff patch, fixes 4908212
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.2.1-1
10139N/A- Upgrade to 2.2.1
10139N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Fri May 30 2003 - <markmc@sun.com>
10139N/A- Make sure gconf.xml.mandatory gets created
10139N/A* Fri May 30 2003 - <markmc@sun.com>
10139N/A- Add patches required by gnome-panel-2.3.1
10139N/A- Install .la files
10139N/A* Thu May 07 2003 - <Niall.Power@Sun.COM>
10139N/A- Create new spec file for GConf
10139N/A