GConf.spec revision 12576
10139N/A#
10139N/A# spec file for package GConf
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
18953N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:stephen
10139N/A#
17185N/AName: GConf
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries/GNOME
10139N/AProvides: GConf
17176N/AVersion: 2.22.0
17176N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
18953N/ASummary: GNOME Configuration Framework
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/GConf/2.22/GConf-%{version}.tar.bz2
10139N/A#owner:stephen date:2004-05-19 type:branding
18688N/APatch1: GConf-01-apoc-path-update.diff
18688N/A#owner:stephen date:2004-08-02 type:bug bugster:5042863 bugzilla:100378
10139N/APatch2: GConf-02-g11n-locale-alias.diff
19013N/A#owner:laca date:2006-06-29 type:feature
19016N/APatch3: GConf-03-GCONF_BACKEND_DIR.diff
18593N/AURL: http://www.gnome.org
18953N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
18417N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
12636N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define libxml2_version 2.6.7
10139N/A%define ORBit2_version 2.10.1
19142N/A%define gtk_doc_version 1.1
10139N/A%define popt_version 1.7
10139N/A
16584N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: ORBit2 >= %{ORBit2_version}
10139N/ARequires: popt >= %{popt_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
19142N/ABuildRequires: ORBit2-devel >= %{ORBit2_version}
10139N/ABuildRequires: popt-devel >= %{popt_version}
10532N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/A
10139N/A%description
10139N/AGConf is the Configuration Framework for the GNOME Desktop.
10139N/A
10139N/A%package devel
10139N/ASummary: GNOME Configuration Framework Development Libraries
10139N/AGroup: Development/Libraries/GNOME
10139N/ARequires: %{name} = %{version}
17049N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/ARequires: ORBit2-devel >= %{ORBit2_version}
10139N/ARequires: gtk2-devel >= %{gtk2_version}
10139N/A
10139N/A%description devel
10139N/AGConf is the Configuration Framework for the GNOME Desktop.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport PKG_CONFIG_PATH=%{_libdir}/pkgconfig
10139N/Aaclocal
10139N/Aautoheader
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/A# For some reason using -j $CPUS breaks the build on my machine with
10139N/A# 2 processors, so just using make
10139N/A#
10139N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT MKDIR_P="mkdir -p"
10139N/A
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/GConf/2/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/GConf
10139N/A%{_bindir}/*
10139N/A%{_libexecdir}/*
10139N/A%{_libdir}/GConf/2/*.so*
10139N/A%{_libdir}/libgconf-2*so.*
10139N/A%{_sysconfdir}/gconf
10139N/A%{_mandir}/man1/*
10139N/A%dir %{_sysconfdir}/gconf/gconf.xml.defaults
10139N/A%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/gconf/2/gconf/*.h
10139N/A%{_libdir}/libgconf-2*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/gtk-doc/*
10139N/A%{_datadir}/sgml/*
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
10139N/A* Mon Mar 10 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.22.0.
10139N/A* Mon Jan 28 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.90.
10139N/A* Tue Jan 22 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.2. Remove upstream patch 04-glib-pc.
10139N/A* Thu Jan 10 2008 - damien.carbery@sun.com
10139N/A- Add patch 04-glib-pc to fix gconf-2.0.pc file type: s/glib/glib-2.0/.
10139N/A* Wed Jan 09 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.21.1. Remove upstream patch, 02-daemon-hanged-solaris, rename
10139N/A remainder.
10139N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.1.
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Wed Sep 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.0.
10139N/A* Mon Jul 02 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.1.
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed adding ccdir to PATH
18953N/A* Tue Mar 06 2007 - damien.carbery@sun.com
18953N/A- Add aclocal call and set MKDIR_P in %install to resolve autoconf version
18850N/A mismatch.
18850N/A* Mon Mar 05 2007 - damien.carbery@sun.com
17134N/A- Bump to 2.18.0.1.
17134N/A* Mon Mar 05 2007 - damien.carbery@sun.com
17049N/A- Bump to 2.18.0. Remove upstream patches, 05-gconftool-makefile-install and
17049N/A 06-use-fdwalk.
16770N/A* Fri Nov 3 2006 - laca@sun.com
16770N/A- use %gtk_doc_option in configure so that it can be disabled using
16584N/A --without-gtk-doc
16584N/A* Tue Oct 17 2006 - damien.carbery@sun.com
14143N/A- Bump to 2.16.0.
14143N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
12636N/A- add patch use-fdwalk to speed up clsoing of fds. (bug 6366879)
12636N/A* Tue Jul 4 2006 - laca@sun.com
10532N/A- add patch gconftool-makefile-install.diff which makes --makefile-install-rule
10532N/A continue if a schemas file fails.
10307N/A* Thu Jun 29 2006 - laca@sun.com
10307N/A- add patch GCONF_BACKEND_DIR.diff that makes the backend dir relocatable
10139N/A via env variable
10139N/A* Sat Mar 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.5.
10139N/A* Fri Jan 6 2006 - laca@sun.com
10139N/A- set 64-bit sysconfdir to /etc, since those files are not arch specific
10139N/A* Wed Nov 30 2005 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 04-markup-tree-incremental-reads.diff.
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.1.
10139N/A* Thu Oct 20 2005 - laca@sun.com
10139N/A- add Lorenzo's incremental read patch; already in HEAD
10139N/A* Wed Sep 14 2005 - brian.cameron@sunc.om
10139N/A- Bump to 2.12.0.
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.92.
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.90.
10139N/A* Wed Jun 15 2005 - laca@sun.com
10139N/A- add patch pkgconfig.diff that add gconf-2.0 to the pkgconfig deps
10139N/A- run autoconf
10139N/A* Wed May 11 2005 - brian.cameron@sun.com
10139N/A- Remove building with multiple processors, since that is breaking
10139N/A the build on Solaris.
10139N/A* Fri May 06 2005 - glynn.foster@wipro.com
10139N/A- Bump to 2.10.0
10139N/A* Tue Feb 15 2005 - arvind.samptur@wipro.com
10139N/A- Add patch to fix such that defaults don't get
10139N/A installed for all locales since we always
10139N/A fallback to C locale values
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Fri Sep 24 2004 - yuriy.kuznetsov@sun.com
10139N/A- Added GConf-06-g11n-potfiles.diff
10139N/A* Mon Aug 30 2004 - takao.fujiwara@sun.com
10139N/A- updated GConf-02-g11n-potfiles.diff
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc.
10139N/A* Wed Aug 11 2004 - ghee.teo@sun.com
10139N/A- Removed GConf-05-use-global-lock.diff as it is backwards incomptaible in a
10139N/A heterogeneous environment. While the goal of the project is to allow
10139N/A concurrent login which has in effect achieved by not having any lock at all.
10139N/A* Thu Aug 02 2004 - hidetoshi.tajima@sun.com
10139N/A- create GConf-06-g11n-locale-alias.diff to fix bug #5042863,
10139N/A the orignal patch is from the bugzilla.gnome.org #100378
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to GConf-l10n-po-1.2.tar.bz2
19450N/A* Thu Jul 08 2004 - stephen.browne@sun.com
- ported to rpm4/suse91
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Fri Jun 11 2004 - Ghee.Teo@Sun.Com
- Create a patch GConf-05-use-global-lock.diff as we want to use orbit ip
to resolve to a single gconf daemon per user.
* Thu Jun 03 2004 - Ghee.Teo@Sun.Com
- Added GConf-04-daemon-hanged-solaris.diff as the signal handler
is calling non-reentrant code as gconf_log(). SO removed the calls
to these signals, though much of these messages are not that important.
* Wed May 19 2004 - Cyrille.Moureaux@Sun.COM
- added GConf-03-apoc-path-update.diff.
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to GConf-l10n-po-1.1.tar.bz2
* Thu Apr 06 2004 - matt.keenan@sun.com
- Updtaed to 2.6.1 tarball.
* Fri Apr 02 2004 - ghee.teo@sun.com
- Updtaed to 2.6.0 tarball.
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to GConf-l10n-po-1.0.tar.bz2
* Fri Mar 19 2004 - glynn.foster@sun.com
- Bump to 2.5.90 and merge the potfile patches.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added GConf-03-g11n-potfiles.diff
* Wed Feb 11 2004 - <matt.keenan@sun.com>
- Bump to 2.5.1, l10n to 0.7, port 02-fix-potfiles patch
* Mon Dec 15 2003 - <glynn.foster@sun.com>
- Add back the man page stuff, and the backend
notification patch
* Mon Oct 06 2003 - <markmc@sun.com> 2.4.0.1-1
- Update to 2.4.0.1-1.
- Remove dump/load and local locks patches.
* Tue Aug 19 2003 - <niall.power@sun.com>
- add GConf-02-sanity-check.diff patch, fixes 4908212
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Fri Aug 01 2003 - <markmc@sun.com> 2.2.1-1
- Upgrade to 2.2.1
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Fri May 30 2003 - <markmc@sun.com>
- Make sure gconf.xml.mandatory gets created
* Fri May 30 2003 - <markmc@sun.com>
- Add patches required by gnome-panel-2.3.1
- Install .la files
* Thu May 07 2003 - <Niall.Power@Sun.COM>
- Create new spec file for GConf