t_pkg_image_update.py revision 3339
7cb14f34a92e0a8eae07db027344126bf5c901c9KATOH Yasufumi# CDDL HEADER START
7cb14f34a92e0a8eae07db027344126bf5c901c9KATOH Yasufumi# The contents of this file are subject to the terms of the
7cb14f34a92e0a8eae07db027344126bf5c901c9KATOH Yasufumi# Common Development and Distribution License (the "License").
892bd61e0fcc788390abfadd32b1897943290879dlezcano# You may not use this file except in compliance with the License.
953e611ceabed9ccf986e0b234379c2af4bb331aJames Hunt# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
953e611ceabed9ccf986e0b234379c2af4bb331aJames Hunt# See the License for the specific language governing permissions
5c320b769229d713e84b02ed6b7ae1309ac31dbbGuido Trotter# and limitations under the License.
55fc19a1042bca36ae431cb4a51c2abc0ca4d801Stéphane Graber# When distributing Covered Code, include this CDDL HEADER in each
c13c0e08da7dbfecb52e85233ac6cd17afa5d818Stéphane Graber# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
892bd61e0fcc788390abfadd32b1897943290879dlezcano# If applicable, add the following below this CDDL HEADER, with the
d1de19abd0067f38bc08a4a3357de701a4e5571ddlezcano# fields enclosed by brackets "[]" replaced with your own identifying
d1de19abd0067f38bc08a4a3357de701a4e5571ddlezcano# information: Portions Copyright [yyyy] [name of copyright owner]
a6adab20ff4b58887ff1d4314c5736f54e139386Stéphane Graber# CDDL HEADER END
735f2c6e504a541cbb2592a3f94858bf337a24ffTycho Andersen# Copyright (c) 2008, 2016, Oracle and/or its affiliates. All rights reserved.
adade80c7e74c5185f63ff009116bf9d30c79876Serge Hallynclass NoTestImageUpdate(pkg5unittest.ManyDepotTestCase):
d1de19abd0067f38bc08a4a3357de701a4e5571ddlezcano # Only start/stop the depot once (instead of for every test)
df3415e02282317348bbd5f9ce66d03e1c81eeecSerge Hallyn open foo@1.0,5.11-0
8b8b04f80adf21480c25deb1aae263049ddd6754dlezcano add dir mode=0755 owner=root group=bin path=/lib
4019712d198a7d50b08b326ade17f5ff1666efbbStéphane Graber open foo@1.1,5.11-0
6a85cf91247b7dd9c3faeddceca8dacb96d02cd6Stéphane Graber add dir mode=0755 owner=root group=bin path=/lib
6a85cf91247b7dd9c3faeddceca8dacb96d02cd6Stéphane Graber open bar@1.0,5.11-0
d1de19abd0067f38bc08a4a3357de701a4e5571ddlezcano add dir mode=0755 owner=root group=bin path=/bin
f080ffd7d656fbd9505a8e8eb52a05d61355c677Dwight Engen open bar@1.1,5.11-0
aa8d013ec5b09cd1cd904173d6234ef126eb2126Peter Simons add dir mode=0755 owner=root group=bin path=/bin
aa8d013ec5b09cd1cd904173d6234ef126eb2126Peter Simons open baz@1.0,5.11-0
7822022c4c72cee06905b540b89b653491d6f6b2Stéphane Graber add dir mode=0755 owner=root group=bin path=/lib
7822022c4c72cee06905b540b89b653491d6f6b2Stéphane Graber open baz@1.1,5.11-0
6a85cf91247b7dd9c3faeddceca8dacb96d02cd6Stéphane Graber add dir mode=0755 owner=root group=bin path=/lib
9a42db48e0bcf4f34b05a3de1cda23e06f51d131Stéphane Graber open qux@1.0,5.11-0
3b9246c4aae3f7602c0ad64f5b1204eb559e5b07Daniel Lezcano add depend type=require fmri=pkg:/quux@1.0
892bd61e0fcc788390abfadd32b1897943290879dlezcano add dir mode=0755 owner=root group=bin path=/lib
add depend fmri=consolidation/java-7/java-7-incorporation type=require
add depend facet.version-lock.consolidation/java-7/java-7-incorporation=true fmri=consolidation/java-7/java-7-incorporation@1.7.0.51.34-0 type=incorporate
add depend fmri=consolidation/java-7/java-7-incorporation@1.7.0 type=incorporate
add depend fmri=consolidation/osnet/osnet-incorporation type=require
add depend facet.version-lock.consolidation/osnet/osnet-incorporation=true fmri=consolidation/osnet/osnet-incorporation@5.12-5.12.0.0.0.45.2 type=incorporate
add depend fmri=consolidation/osnet/osnet-incorporation@5.12-5.12.0 type=incorporate
open consolidation/java-7/java-7-incorporation@1.7.0.51.34-0
open consolidation/osnet/osnet-incorporation@5.12-5.12.0.0.0.45.25345
add depend fmri=pkg:/system/resource-mgmt/dynamic-resource-pools@5.12,5.12-5.12.0.0.0.45.25345 type=incorporate
add depend fmri=consolidation/java-7/java-7-incorporation type=require
open system/resource-mgmt/dynamic-resource-pools@5.12-5.12.0.0.0.45.25345
add depend fmri=consolidation/osnet/osnet-incorporation type=require
open consolidation/osnet/osnet-incorporation@5.12-5.12.0.0.0.46.25205
add depend fmri=pkg:/system/resource-mgmt/dynamic-resource-pools@5.12,5.12-5.12.0.0.0.46.25205 type=incorporate
add depend fmri=consolidation/java-7/java-7-incorporation type=require
open system/resource-mgmt/dynamic-resource-pools@5.12,5.12-5.12.0.0.0.46.25205
add depend fmri=consolidation/osnet/osnet-incorporation type=require
if fname is None:
return fsum
"system/resource-mgmt/dynamic-resource-pools@5.12-5.12.0.0.0.45.25345")
open pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1:20160225T115559Z
open pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1.1697.1:20160225T115610Z
open pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1:20160225T115616Z
open pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.3.2.906,5.11-0.1:20160225T115622Z
open pkg://test/management/em-sysmgmt-ecpc/opscenter-ecpc-incorporation@12.2.2.1103,5.11-0.1:20141203T103418Z
add set name=pkg.description value="This incorporation constrains packages for the opscenter enterprise and proxy controller."
add depend fmri=management/em-sysmgmt-ecpc/em-oc-ec@12.2.2.1103-0.1 type=incorporate
add depend fmri=management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103-0.1 type=incorporate
add depend fmri=management/em-sysmgmt-ecpc/em-oc-pc@12.2.2.1103-0.1 type=incorporate
add depend type=incorporate fmri=management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103-0.1.1697.1
self.pkg("install pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1:20160225T115559Z")
self.pkg("install pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1:20160225T115616Z")
"pkg://test/management/em-sysmgmt-ecpc/em-oc-common@12.2.2.1103,5.11-0.1:20160225T115616Z")