md5.spec revision 7c478bd95313f5f23a4c958a745db2134aa03244
#
# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
#pragma ident "%Z%%M% %I% %E% SMI"
#
# lib/libmd5/spec/md5.spec
#
function MD5Init
include <md5.h>
declaration void MD5Init(MD5_CTX *context)
version SUNW_1.1
end
function MD5Update
include <md5.h>
declaration void MD5Update(MD5_CTX *context, \
const void *input, \
unsigned int inputLen)
version SUNW_1.1
end
function MD5Final
include <md5.h>
declaration void MD5Final(unsigned char digest[16], MD5_CTX *context)
version SUNW_1.1
end
function md5_calc
declaration void md5_calc(unsigned char *output, \
unsigned char *input, \
unsigned int inlen)
version SUNW_1.1
end