interface64.spec revision 7c4dcc5546f9f002dfc2b95de47c90f00d07c066
#
# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License (the "License").
# You may not use this file except in compliance with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
#pragma ident "%Z%%M% %I% %E% SMI"
#
function alphasort64
declaration int alphasort64(const struct dirent64 **d1, \
end
function _alphasort64
end
function creat64
end
function _creat64
end
function fgetpos64
declaration int fgetpos64(FILE *_RESTRICT_KYWD stream, \
end
function fopen64
const char *_RESTRICT_KYWD mode)
end
function freopen64
const char *_RESTRICT_KYWD mode, \
end
function fseeko64
end
function fsetpos64
end
function fstat64
end
function _fstat64
end
function fstatvfs64
declaration int fstatvfs64(int fildes, struct statvfs64 *buf)
end
function _fstatvfs64
end
function ftello64
end
function ftruncate64
declaration int ftruncate64(int fildes, off64_t length)
end
function _ftruncate64
end
function ftw64
int depth)
end
function _ftw64
end
function getdents64
end
function _getdents64
end
function getrlimit64
declaration int getrlimit64(int resource, struct rlimit64 *rlp)
end
function _getrlimit64
end
function lockf64
end
function _lockf64
end
function lseek64
end
function _lseek64
end
function lstat64
end
function _lstat64
end
function mkstemp64
end
function _mkstemp64
end
function mkstemps64
declaration int mkstemps64(char *template, int suffixlen)
end
function _mkstemps64
end
function mmap64
end
function _mmap64
end
function nftw64
int, struct FTW *), \
end
function _nftw64
end
function open64
end
function _open64
end
function openat64
end
function _openat64
end
function pread64
end
function _pread64
end
function pwrite64
end
function _pwrite64
end
function readdir64
end
function _readdir64
end
function readdir64_r
end
function _readdir64_r
end
function scandir64
const struct dirent64 **));
end
function _scandir64
end
function setrlimit64
declaration int setrlimit64(int resource, const struct rlimit64 *rlp)
end
function _setrlimit64
end
function stat64
end
function _stat64
end
function fstatat64
end
function _fstatat64
end
function statvfs64
end
function _statvfs64
end
function tmpfile64
end
function truncate64
declaration int truncate64(const char *path, off64_t length)
end
function _truncate64
end
function tell64
end
function _tell64
end
function attropen64
declaration int attropen64(const char *name, const char *attr, \
int oflag, ...)
end
function _attropen64
end