aio.spec revision 3470957343f37ed9baa957980891dbbe4c2d7092
1N/A#
1N/A# CDDL HEADER START
1N/A#
1N/A# The contents of this file are subject to the terms of the
1N/A# Common Development and Distribution License (the "License").
1N/A# You may not use this file except in compliance with the License.
1N/A#
1N/A# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
1N/A# or http://www.opensolaris.org/os/licensing.
1N/A# See the License for the specific language governing permissions
1N/A# and limitations under the License.
1N/A#
1N/A# When distributing Covered Code, include this CDDL HEADER in each
1N/A# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
1N/A# If applicable, add the following below this CDDL HEADER, with the
1N/A# fields enclosed by brackets "[]" replaced with your own identifying
1N/A# information: Portions Copyright [yyyy] [name of copyright owner]
1N/A#
1N/A# CDDL HEADER END
1N/A#
1N/A#
1N/A# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
1N/A# Use is subject to license terms.
1N/A#
1N/A# ident "%Z%%M% %I% %E% SMI"
1N/A#
1N/A
1N/Afunction aiocancel
1N/Ainclude <sys/asynch.h>, <aio.h>
1N/Adeclaration int aiocancel(aio_result_t *resultp)
1N/Aversion sparc=SISCD_2.3 sparcv9=SUNW_0.7 i386=SUNW_0.7 amd64=SUNW_0.7
1N/Aerrno EACCES EFAULT EINVAL
1N/Aexception $return == -1
1N/Aend
1N/A
1N/Afunction aioread
1N/Ainclude <sys/types.h>, <sys/asynch.h>, <aio.h>
1N/Adeclaration int aioread(int fildes, char *bufp, int bufs, \
1N/A off_t offset, int whence, aio_result_t *resultp)
1N/Aversion sparc=SISCD_2.3 sparcv9=SUNW_0.7 i386=SUNW_0.7 amd64=SUNW_0.7
1N/Aerrno EAGAIN EBADF EFAULT EINVAL ENOMEM
1N/Aexception $return == -1
1N/Aend
1N/A
1N/Afunction aioread64
1N/Adeclaration int aioread64(int fd, caddr_t buf, int bufsz, off64_t offset, \
1N/A int whence, aio_result_t *resultp)
1N/Aarch i386 sparc
1N/Aversion i386=SUNW_1.0 sparc=SUNW_1.0
1N/Aend
1N/A
1N/Afunction aiowait
1N/Ainclude <sys/asynch.h>, <aio.h>, <sys/time.h>
1N/Adeclaration aio_result_t *aiowait(struct timeval *timeout)
1N/Aversion sparc=SISCD_2.3 sparcv9=SUNW_0.7 i386=SUNW_0.7 amd64=SUNW_0.7
1N/Aerrno EFAULT EINTR EINVAL
1N/Aexception $return == (aio_result_t *)-1
1N/Aend
1N/A
1N/Afunction aiowrite
1N/Ainclude <sys/types.h>, <sys/asynch.h>, <aio.h>
1N/Adeclaration int aiowrite(int fildes, char *bufp, int bufs, \
1N/A off_t offset, int whence, aio_result_t *resultp)
1N/Aversion sparc=SISCD_2.3 sparcv9=SUNW_0.7 i386=SUNW_0.7 amd64=SUNW_0.7
1N/Aerrno EAGAIN EBADF EFAULT EINVAL ENOMEM
1N/Aexception $return == -1
1N/Aend
1N/A
1N/Afunction aiowrite64
1N/Ainclude <sys/types.h>, <sys/asynch.h>, <aio.h>
1N/Adeclaration int aiowrite64(int fildes, char *bufp, int bufs, \
1N/A off64_t offset, int whence, aio_result_t *resultp)
1N/Aarch sparc i386
1N/Aversion sparc=SUNW_1.0 i386=SUNW_1.0
1N/Aerrno EAGAIN EBADF EFAULT EINVAL ENOMEM
1N/Aexception $return == -1
1N/Aend
1N/A
1N/Afunction assfail
1N/Adeclaration int assfail(char *a, char *f, int l)
1N/Aversion SUNW_1.1
1N/Aend
1N/A
1N/Afunction close
1N/Ainclude <unistd.h>
1N/Adeclaration int close(int fildes)
1N/Aversion SUNW_0.7
1N/Aerrno EBADF EINTR ENOLINK EIO
1N/Aexception $return == -1
1N/Abinding nodirect
1N/Aend
1N/A
1N/Afunction fork
1N/Aversion SUNW_0.7
1N/Afilter libc.so.1
1N/Aend
1N/A
1N/Afunction sigaction extends libc/spec/sys.spec sigaction
1N/Aversion SUNW_0.7
1N/Abinding nodirect
1N/Aend
1N/A
1N/Afunction _sigaction
1N/Aweak sigaction
1N/Aversion SUNWprivate_1.1
1N/Abinding nodirect
1N/Aend
1N/A
1N/Afunction __lio_listio
1N/Adeclaration int __lio_listio(int mode, aiocb_t * const list[], int nent, \
1N/A struct sigevent *sig)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_suspend
1N/Adeclaration int __aio_suspend(void **list, int nent, \
1N/A const timespec_t *timo, int largefile)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_error
1N/Adeclaration int __aio_error(aiocb_t *cb)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_return
1N/Adeclaration ssize_t __aio_return(aiocb_t *cb)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_read
1N/Adeclaration int __aio_read(aiocb_t *cb)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_write
1N/Adeclaration int __aio_write(aiocb_t *cb)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_fsync
1N/Adeclaration int __aio_fsync(int op, aiocb_t *aiocbp)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_cancel
1N/Adeclaration int __aio_cancel(int fd, aiocb_t *aiocbp)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_waitn
1N/Adeclaration int __aio_waitn(void **list, uint_t nent, uint_t *nwait, \
1N/A const struct timespec *timeout, int mode)
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __lio_listio64
1N/Adeclaration int __lio_listio64(int mode, aiocb64_t * const list[], \
1N/A int nent, struct sigevent *sig)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_error64
1N/Adeclaration int __aio_error64(aiocb64_t *cb)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_return64
1N/Adeclaration ssize_t __aio_return64(aiocb64_t *cb)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_read64
1N/Adeclaration int __aio_read64(aiocb64_t *cb)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_write64
1N/Adeclaration int __aio_write64(aiocb64_t *cb)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_fsync64
1N/Adeclaration int __aio_fsync64(int op, aiocb64_t *aiocbp)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction __aio_cancel64
1N/Adeclaration int __aio_cancel64(int fd, aiocb64_t *aiocbp)
1N/Aarch sparc i386
1N/Aversion sparc=SUNWprivate_1.1 i386=SUNWprivate_1.1
1N/Aend
1N/A
1N/Afunction _libaio_close
1N/Aversion SUNWprivate_1.1
1N/Aend
1N/A