libzfs_jni.spec revision f808c858fa61e7769218966759510a8b1190dfcf
#
# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
#
# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
#ident "%Z%%M% %I% %E% SMI"
function Java_com_sun_zfs_common_model_SystemDataModel_getImportablePools
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getPools
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getPool
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getFileSystems
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getFileSystem
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getVolumes
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getVolume
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getSnapshots
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getSnapshot
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getDatasets
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getDataset
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getVirtualDevice
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getVirtualDevices__Ljava_lang_String_2
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getVirtualDevices__Ljava_lang_String_2J
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getAvailableDisks
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getDependents
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getPropertyDefault
version SUNWprivate_1.1
end
function Java_com_sun_zfs_common_model_SystemDataModel_getValidPropertyNames
version SUNWprivate_1.1
end
function dmgt_avail_disk_iter
version SUNWprivate_1.1
end
function dmgt_free_disk
version SUNWprivate_1.1
end
function dmgt_free_slice
version SUNWprivate_1.1
end
function dmgt_set_error_handler
version SUNWprivate_1.1
end
function zjni_ipool_iter
version SUNWprivate_1.1
end
function zjni_vdev_state_to_str
version SUNWprivate_1.1
end
function zjni_vdev_aux_to_str
version SUNWprivate_1.1
end
function zjni_pool_state_to_str
version SUNWprivate_1.1
end
function zjni_pool_status_to_str
version SUNWprivate_1.1
end