libdscp.spec revision f808c858fa61e7769218966759510a8b1190dfcf
#
# Copyright 2006 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License (the "License").
# You may not use this file except in compliance with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
# lib/libdscp/spec/libdscp.spec
#
#ident "%Z%%M% %I% %E% SMI"
function dscpBind
include <libdscp.h>
declaration int dscpBind(int, int, int)
version SUNWprivate_1.1
end
function dscpSecure
include <libdscp.h>
declaration int dscpSecure(int, int)
version SUNWprivate_1.1
end
function dscpAuth
include <libdscp.h>
declaration int dscpAuth(int, struct sockaddr *, int)
version SUNWprivate_1.1
end
function dscpAddr
include <libdscp.h>
declaration int dscpAddr(int, int, struct sockaddr *, int *)
version SUNWprivate_1.1
end
function dscpIdent
include <libdscp.h>
declaration int dscpIdent(struct sockaddr *, int, int *)
version SUNWprivate_1.1
end