ctf.spec revision f808c858fa61e7769218966759510a8b1190dfcf
#
# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
#ident "%Z%%M% %I% %E% SMI"
data _libctf_debug
version SUNWprivate_1.1
end
function ctf_add_array
version SUNWprivate_1.2
end
function ctf_add_const
version SUNWprivate_1.2
end
function ctf_add_enum
version SUNWprivate_1.2
end
function ctf_add_enumerator
version SUNWprivate_1.2
end
function ctf_add_float
version SUNWprivate_1.2
end
function ctf_add_forward
version SUNWprivate_1.2
end
function ctf_add_function
version SUNWprivate_1.2
end
function ctf_add_integer
version SUNWprivate_1.2
end
function ctf_add_member
version SUNWprivate_1.2
end
function ctf_add_pointer
version SUNWprivate_1.2
end
function ctf_add_restrict
version SUNWprivate_1.2
end
function ctf_add_struct
version SUNWprivate_1.2
end
function ctf_add_type
version SUNWprivate_1.2
end
function ctf_add_typedef
version SUNWprivate_1.2
end
function ctf_add_union
version SUNWprivate_1.2
end
function ctf_add_volatile
version SUNWprivate_1.2
end
function ctf_array_info
version SUNWprivate_1.1
end
function ctf_bufopen
version SUNWprivate_1.1
end
function ctf_close
version SUNWprivate_1.1
end
function ctf_create
version SUNWprivate_1.2
end
function ctf_discard
version SUNWprivate_1.2
end
function ctf_enum_iter
version SUNWprivate_1.1
end
function ctf_enum_name
version SUNWprivate_1.1
end
function ctf_enum_value
version SUNWprivate_1.2
end
function ctf_errmsg
version SUNWprivate_1.1
end
function ctf_errno
version SUNWprivate_1.1
end
function ctf_fdopen
version SUNWprivate_1.1
end
function ctf_func_args
version SUNWprivate_1.1
end
function ctf_func_info
version SUNWprivate_1.1
end
function ctf_getmodel
version SUNWprivate_1.1
end
function ctf_getspecific
version SUNWprivate_1.1
end
function ctf_import
version SUNWprivate_1.1
end
function ctf_label_info
version SUNWprivate_1.2
end
function ctf_label_iter
version SUNWprivate_1.2
end
function ctf_label_topmost
version SUNWprivate_1.2
end
function ctf_lookup_by_name
version SUNWprivate_1.1
end
function ctf_lookup_by_symbol
version SUNWprivate_1.1
end
function ctf_member_info
version SUNWprivate_1.2
end
function ctf_member_iter
version SUNWprivate_1.1
end
function ctf_open
version SUNWprivate_1.1
end
function ctf_parent_file
version SUNWprivate_1.2
end
function ctf_parent_name
version SUNWprivate_1.2
end
function ctf_setmodel
version SUNWprivate_1.1
end
function ctf_setspecific
version SUNWprivate_1.1
end
function ctf_set_array
version SUNWprivate_1.2
end
function ctf_type_align
version SUNWprivate_1.2
end
function ctf_type_cmp
version SUNWprivate_1.2
end
function ctf_type_compat
version SUNWprivate_1.2
end
function ctf_type_encoding
version SUNWprivate_1.1
end
function ctf_type_iter
version SUNWprivate_1.1
end
function ctf_type_kind
version SUNWprivate_1.1
end
function ctf_type_lname
version SUNWprivate_1.1
end
function ctf_type_name
version SUNWprivate_1.1
end
function ctf_type_pointer
version SUNWprivate_1.2
end
function ctf_type_reference
version SUNWprivate_1.1
end
function ctf_type_resolve
version SUNWprivate_1.1
end
function ctf_type_size
version SUNWprivate_1.1
end
function ctf_type_visit
version SUNWprivate_1.1
end
function ctf_write
version SUNWprivate_1.2
end
function ctf_update
version SUNWprivate_1.2
end
function ctf_version
version SUNWprivate_1.1
end