getauusernam.spec revision f808c858fa61e7769218966759510a8b1190dfcf
#
# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
# Use is subject to license terms.
#
# CDDL HEADER START
#
# The contents of this file are subject to the terms of the
# Common Development and Distribution License, Version 1.0 only
# (the "License"). You may not use this file except in compliance
# with the License.
#
# You can obtain a copy of the license at usr/src/OPENSOLARIS.LICENSE
# or http://www.opensolaris.org/os/licensing.
# See the License for the specific language governing permissions
# and limitations under the License.
#
# When distributing Covered Code, include this CDDL HEADER in each
# file and include the License file at usr/src/OPENSOLARIS.LICENSE.
# If applicable, add the following below this CDDL HEADER, with the
# fields enclosed by brackets "[]" replaced with your own identifying
# information: Portions Copyright [yyyy] [name of copyright owner]
#
# CDDL HEADER END
#
#pragma ident "%Z%%M% %I% %E% SMI"
#
# lib/libbsm/spec/getauusernam.spec
function getauusernam
include <sys/param.h>
include <bsm/libbsm.h>
declaration struct au_user_ent *getauusernam(char *name)
version SUNW_0.7
exception ($return == 0)
end
function getauuserent
include <sys/param.h>
include <bsm/libbsm.h>
declaration struct au_user_ent *getauuserent(void)
version SUNW_0.7
exception ($return == 0)
end
function setauuser
include <sys/param.h>
include <bsm/libbsm.h>
declaration void setauuser(void)
version SUNW_0.7
end
function endauuser
include <sys/param.h>
include <bsm/libbsm.h>
declaration void endauuser(void)
version SUNW_0.7
end
function getauusernam_r
include <sys/param.h>
include <bsm/libbsm.h>
declaration struct au_user_ent *getauusernam_r(au_user_ent_t *u, char *name)
version SUNW_0.8
exception ($return == 0)
end
function getauuserent_r
include <sys/param.h>
include <bsm/libbsm.h>
declaration struct au_user_ent *getauuserent_r(au_user_ent_t *u)
version SUNW_0.8
exception ($return == 0)
end