Cross Reference: preinst
xref
: /
forgerock
/
opendj2
/
resource
/
debian
/
control
/
preinst
Home
History
Annotate
Line#
Navigate
Download
Search
only in
./
preinst revision 1cd2872b696c4bdfb7694da53883d02de3360e12
310
N/A
#!/
bin
/
bash
310
N/A
set
-e
310
N/A
# Pre installation script
310
N/A
# If the server is running before upgrade, creates a flag.
310
N/A
if
[
"$1"
=
"upgrade"
]
310
N/A
then
310
N/A
if
[ -f @
prefix
@/
logs
/
server.pid
]
310
N/A
then
310
N/A
touch
@
prefix
@/
logs
/
status
310
N/A
fi
310
N/A
echo
*
Stopping
OpenDJ
server
...
310
N/A
@
prefix
@/
bin
/./
stop
-
ds
310
N/A
fi
310
N/A
echo
310
N/A
# End of the pre installation script