6253N/A#!/bin/bash
6238N/Aset -e
6253N/A# Pre rm script
6642N/A# Stops the service.
6642N/A/etc/init.d/opendj stop >/dev/null 2>&1
6642N/A# Deletes the service.
6642N/Aupdate-rc.d -f opendj remove
6642N/A# Unlink the symlink to the process ID if it exists.
6642N/Atest -h "/var/run/opendj.pid" && unlink /var/run/opendj.pid
6253N/A# Stops the server
6279N/A# Only if the instance has been configured
6279N/Aif [ "$1" = "remove" ] && ( [ -f @prefix@/config/buildinfo ] && [ "$(ls -A @prefix@/config/archived-configs)" ] )
6253N/Athen
6238N/A echo *Stopping OpenDJ server...
6253N/A @prefix@/bin/./stop-ds
6238N/Afi
6253N/A# End prem script