Cross Reference: prerm
xref
: /
forgerock
/
opendj2-hg
/
resource
/
debian
/
control
/
prerm
Home
History
Annotate
Line#
Navigate
Download
Search
only in
./
6253
N/A
#!/
bin
/
bash
6238
N/A
set
-e
6253
N/A
# Pre rm script
6642
N/A
# Stops the service.
6642
N/A
/
etc
/
init.d
/
opendj
stop
>/
dev
/
null
2
>&
1
6642
N/A
# Deletes the service.
6642
N/A
update-rc.d
-f
opendj
remove
6642
N/A
# Unlink the symlink to the process ID if it exists.
6642
N/A
test
-h
"/
var
/
run
/
opendj.pid
"
&&
unlink
/
var
/
run
/
opendj.pid
6253
N/A
# Stops the server
6279
N/A
# Only if the instance has been configured
6279
N/A
if
[
"$1"
=
"remove"
] &&
( [ -f @
prefix
@/
config
/
buildinfo
] && [
"
$(
ls
-A @
prefix
@/
config
/
archived-configs
)
"
] )
6253
N/A
then
6238
N/A
echo
*
Stopping
OpenDJ
server
...
6253
N/A
@
prefix
@/
bin
/./
stop
-
ds
6238
N/A
fi
6253
N/A
# End prem script