Cross Reference: preinst
xref
: /
forgerock
/
opendj-b2.6
/
resource
/
debian
/
control
/
preinst
Home
History
Annotate
Line#
Navigate
Download
Search
only in
./
6253
N/A
#!/
bin
/
bash
6238
N/A
set
-e
6253
N/A
# Pre installation script
6253
N/A
if
[
"$1"
=
"upgrade"
]
6253
N/A
then
6279
N/A
# Only if the instance has been configured
6279
N/A
if
[ -f @
prefix
@/
config
/
buildinfo
] && [
"
$(
ls
-A @
prefix
@/
config
/
archived-configs
)
"
]
6253
N/A
then
6279
N/A
# If the server is running before upgrade, creates a flag.
6279
N/A
if
[ -f @
prefix
@/
logs
/
server.pid
]
6279
N/A
then
6279
N/A
touch
@
prefix
@/
logs
/
status
6279
N/A
fi
6279
N/A
echo
*
Stopping
OpenDJ
server
...
6279
N/A
@
prefix
@/
bin
/./
stop
-
ds
6279
N/A
else
6279
N/A
echo
"Instance is not configured. Upgrade aborded."
6279
N/A
exit
-
1
6253
N/A
fi
6253
N/A
fi
6238
N/A
echo
6253
N/A
# End of the pre installation script