Lines Matching refs:to

8  * particular file as subject to the "Classpath" exception as provided
18 * 2 along with this work; if not, write to the Free Software Foundation,
49 "The search is confined to loaded classes only; no attempt is made "
50 "to load a class of the given signature. "
52 (string signature "JNI signature of the class to find "
96 "java.lang.Thread, all native threads attached to "
129 "The communication channel to the target VM is closed, and "
130 "the target VM prepares to accept another subsequent connection "
139 "are resumed as many times as necessary for them to run. "
209 "example, to the low order 8 bits. "
226 (string utf "UTF-8 characters to use in the created string. ")
276 (string baseDir "Base directory used to resolve relative "
293 "or equal to zero, the ID is freed. "
304 "It is most useful to use this command to reduce the load on the "
333 "Tells the target VM to stop sending events. Events are not discarded; "
335 "This command is useful to control the number of events sent "
336 "to the debugger VM in situations where very large numbers of events "
339 "execution may be frozen by the debugger back-end to prevent "
341 "Responses to commands are never held and are not affected by this
352 "Tells the target VM to continue sending events. This command is "
353 "used to restore normal activity after a HoldEvents command. If "
453 "target VM then those active frames continue to run the bytecodes of the "
457 "The original method ID refers to the redefined method. "
461 "to pop frames with obsolete methods."
465 "In addition to the canRedefineClasses capability, the target VM must "
466 "have the canAddMethod capability to add methods when redefining classes, "
467 "or the canUnrestrictedlyRedefineClasses to redefine classes in arbitrary "
506 (string stratumID "default stratum, or empty string to use "
712 (Repeat fields "The number of values to get"
714 (field fieldID "A field to get")
719 (Repeat values "The number of values returned, always equal to fields, "
720 "the number of values to get."
774 "indicates the extent to which the reference type has been "
817 "Returns the class object corresponding to this type. "
966 (int maxInstances "Maximum number of instances to return. Must be non-negative. "
1014 "corresponds to the constant_pool_count item of the "
1057 "widening reference conversion from the value's type to the
1061 (Repeat values "The number of fields to set."
1063 (field fieldID "Field to set.")
1064 (untagged-value value "Value to put in the field.")
1104 "widening reference conversion from the argument value's type to the "
1110 "This is done to prevent the deadlocks "
1136 (threadObject thread "The thread in which to invoke.")
1137 (method methodID "The method to invoke.")
1179 "widening reference conversion from the argument value's type to the "
1185 "This is done to prevent the deadlocks "
1211 (threadObject thread "The thread in which to invoke the constructor.")
1212 (method methodID "The constructor to invoke.")
1257 "The line table maps source line numbers to the initial code index "
1259 "is ordered by code index (from lowest to highest). The line number "
1447 (Repeat fields "The number of values to get"
1449 (field fieldID "Field to get.")
1454 (Repeat values "The number of values returned, always equal to 'fields', "
1455 "the number of values to get. Field values are ordered "
1475 "widening reference conversion from the value's type to the
1479 (Repeat values "The number of fields to set."
1481 (field fieldID "Field to set.")
1482 (untagged-value value "Value to put in the field.")
1541 "widening reference conversion from the argument value's type to the "
1547 "This is done to prevent the deadlocks "
1573 (threadObject thread "The thread in which to invoke.")
1575 (method methodID "The method to invoke.")
1598 "collected at any time the target VM is running. A call to "
1602 "command can be used to "
1628 "and hence may be garbage collected. A call to this command is "
1666 (int maxReferrers "Maximum number of referring objects to return. "
1729 "The suspended thread is guaranteed to remain suspended until "
1737 "Running, it will still appear running to other threads. "
1754 "decremented. If it is decremented to 0, the thread will "
1755 "continue to execute. "
1809 (int startFrame "The index of the first frame to retrieve.")
1811 "The count of frames to retrieve "
1868 "thread may be waiting to enter a monitor, or it may be waiting, via "
1869 "the java.lang.Object.wait method, for another thread to invoke the "
1965 "Force a method to return before it reaches a return "
1968 "The method which will return early is referred to as the "
1988 "released. Note: this does not apply to JNI locks or "
1996 "frame on the stack causes the thread to exit when resumed. "
2001 "widening reference conversion from the value's type to the "
2008 (value value "The value to return. ")
2017 (Error OPAQUE_FRAME "Attempted to return early from "
2018 "a frame corresponding to a native "
2020 "unable to provide this functionality "
2107 (int firstIndex "The first index to retrieve.")
2108 (int length "The number of components to retrieve.")
2127 "widening reference conversion from the value's type to the
2131 (int firstIndex "The first index to set.")
2132 (Repeat values "The number of values to set. "
2133 (untagged-value value "A value to set. ")
2149 "been requested to load. This class loader is considered to be "
2153 "loading was delegated by this class loader to another class loader. "
2155 "The visible class list has useful properties with respect to "
2159 "this class loader must be resolved to that single type. "
2171 "A class visible to this class loader.")
2187 "from the target VM. The two exceptions to this are the VM Start Event and "
2191 (byte eventKind "Event kind to request. "
2194 "some events may require a capability in order to be requested. "
2203 "VM, the reply to the resume command will be written to "
2205 (Repeat modifiers "Constraints used to control the number "
2210 "applying each modifier to an event in the "
2220 "target VM to the debugger VM. "
2224 "Limit the requested event to be reported at most once after a "
2230 "are applied. If none of those filters cause the event to be "
2242 "Restricts reported events to "
2251 "generated by this request to be the "
2254 "generated by this request to those whose monitor object "
2257 "by this request to those "
2260 "be safely cast to the given reference type. "
2267 "Restricts reported events to those for classes whose name "
2279 "Matches are limited to exact matches of the "
2287 "Restricts reported events to those for classes whose name "
2299 "Matches are limited to exact matches of the "
2306 "Restricts reported events to those that occur at "
2321 "Exception to report. Null (0) means report "
2324 "events to exceptions of the given type or "
2330 "is not always possible to determine whether an "
2339 "Restricts reported events to those that occur for "
2349 "to those which satisfy "
2354 (threadObject thread "Thread in which to step")
2361 "Restricts reported events to those whose "
2371 "Restricts reported class prepare events to those "
2384 "Matches are limited to exact matches of the "
2419 (byte eventKind "Event kind to clear")
2420 (int requestID "ID of request to clear")
2445 "be retrieved if the front-end is able to "
2448 "signature without access to the local variable table information.) "
2452 (Repeat slots "The number of values to get. "
2461 (Repeat values "The number of values retrieved, always equal to slots, "
2462 "the number of values to get."
2479 "widening reference conversion from the value's type to the
2483 "be set, if the front-end is able to "
2486 "signature without access to the local variable table information.) "
2490 (Repeat slotValues "The number of values to set. "
2493 (value slotValue "The value to set. ")
2525 "Pop the top-most stack frames of the thread stack, up to, and including 'frame'. "
2526 "The thread must be suspended to perform this command. "
2527 "The top-most stack frames are discarded and the stack frame previous to 'frame' "
2531 "program counter is restored to the opcode of the invoke instruction."
2575 "or you might single step to the same location as a "
2579 "to deliver events, even if there is only one event to report. "
2641 "This means they do not need to be requested using the "
2650 "in the Event Data set to 0. The value of the suspendPolicy field in the "
2654 "suspendPolicy is specified as an option to the JDWP agent at launch-time."
2655 "The automatically generated VM Death Event will have the suspendPolicy set to "
2684 (location location "Location stepped to")
2735 "to enter a monitor that is already acquired by another thread. "
2742 (threadObject thread "Thread which is trying to enter the monitor")
2748 "after waiting for it to be released by another thread. "
2760 "Notification of a thread about to wait on a monitor object. "
2767 (threadObject thread "Thread which is about to wait")
2802 "is considered to be caught if, at the point of the throw, the "
2809 "exception, there are important restrictions to note about the "
2811 "it is not possible to predict whether an exception will be handled "
2828 "will be considered caught even though it appears to be uncaught from "
2834 "The new thread can be the result of a call to "
2836 "attaching a new thread to the VM though JNI. The "
2839 "Because of this timing, it is possible to receive other events "
2845 "command to return "
2859 "for {@link VirtualMachine#allThreads} to return this thread "
2879 "to prevent these events, but they cannot be avoided under some "
2889 "Note that the discussion above does not apply to system threads "
2939 (value valueToBe "Value to be assigned")
2980 (Constant INVALID_CLASS_FORMAT =60 "The virtual machine attempted to read a class "
3022 (Constant OUT_OF_MEMORY =110 "The function needed to allocate memory and "
3028 (Constant UNATTACHED_THREAD =115 "The thread being used to call this function "
3029 "is not attached to the virtual machine. "
3038 (Constant TRANSPORT_LOAD =509 "Unable to load the transport.")
3039 (Constant TRANSPORT_INIT =510 "Unable to initialize the transport.")
3128 "Step to the next source line unless there is no line number information in which case a MIN step is done instead.")