Lines Matching refs:by

7  * published by the Free Software Foundation.  Oracle designates this
9 * by Oracle in the LICENSE file that accompanied this code.
29 "Returns the JDWP version implemented by the target VM. "
45 "Returns reference types for all the classes loaded by the target VM "
72 "Returns reference types for all classes currently loaded by the "
98 "by the target VM. Threads that have not yet been started "
135 "<li>All threads suspended by the thread-level "
160 "The returned values indicate the number of bytes used by the "
256 "method or the field was invented by the compiler?) ")
290 "The count of references held by the back-end (the reference "
291 "count) will be decremented by refCnt. "
302 "resources associated with each ID will be freed by the back-end "
309 "IDs may be re-used by the back-end after they "
323 "handled by the front-end.")
338 "While events are held by the debugger back-end, application "
339 "execution may be frozen by the debugger back-end to prevent "
341 "Responses to commands are never held and are not affected by this
384 "method or the field was invented by the compiler?) ")
403 "Can the VM filter events by specific object?")
418 "Can the VM filter class prepare events by source name?")
517 "Returns reference types for all classes currently loaded by the "
583 "represented by java.lang.Integer.TYPE."
600 "a given reference type. If the reference type was loaded by the "
639 "by the compiler. "
674 "if present, and any synthetic methods created by the compiler. "
798 "Returns the interfaces declared as implemented by this class. "
799 "Interfaces indirectly implemented (extended by the implemented "
800 "interface or implemented by a superclass) are not included."
880 "by the compiler. "
922 "if present, and any synthetic methods created by the compiler. "
1088 "has been suspended by an event. "
1090 "when the target VM has been suspended by the front-end. "
1109 "suspended by an event or by command. "
1112 "that will be needed by the invoked method. It is possible that "
1122 "by specifying the INVOKE_SINGLE_THREADED "
1163 "has been suspended by an event. "
1165 "when the target VM has been suspended by the front-end. "
1184 "suspended by an event or by command. "
1187 "that will be needed by the invoked method. It is possible that "
1197 "by specifying the INVOKE_SINGLE_THREADED "
1259 "is ordered by code index (from lowest to highest). The line number "
1295 (int argCnt "The number of words in the frame used by arguments. "
1349 "by a non-equivalent method using the "
1360 "by a non-equivalent method using"
1388 (int argCnt "The number of words in the frame used by arguments. "
1525 "has been suspended by an event. "
1527 "when the target VM has been suspended by the front-end. "
1546 "suspended by an event or by command. "
1549 "that will be needed by the invoked method. It is possible that "
1559 "by specifying the INVOKE_SINGLE_THREADED "
1627 "objects returned by JDWP may become unreachable in the target VM, "
1661 "reference. Such non-object referrers are not returned by this command. "
1725 "thread holds a monitor needed by another running thread, "
1751 "not previously suspended by the front-end, "
1804 "the currently executing frame, followed by its caller, "
1846 "Returns the objects whose monitors have been entered by this thread. "
1890 "Stops the thread with an asynchronous exception, as if done by "
1907 "Interrupt the thread, as if done by java.lang.Thread.interrupt "
1936 "Returns monitor objects owned by the thread, along with stack depth at which "
1939 "(e.g., for monitors acquired by JNI MonitorEnter)."
1970 "defined by the Frames section in "
1985 "A lock acquired by calling the called method (if it is a "
1986 "synchronized method) and locks acquired by entering "
2152 "reference type defined by this loader and any types for which "
2153 "loading was delegated by this class loader to another class loader. "
2158 "type name in a class defined by "
2184 "Set an event request. When the event described by this request "
2209 "in the event queue. Events are filtered by "
2217 "debugger performance dramatically by
2251 "generated by this request to be the "
2254 "generated by this request to those whose monitor object "
2257 "by this request to those "
2315 "Restricts reported exceptions by their class and "
2374 "The source names are determined by the reference type's "
2555 "Returns the reference type reflected by this class object."
2660 "Which threads where suspended by this composite event?")
2670 "This event is always generated by the target VM, even "
2731 (value value "Value that will be returned by the method")
2735 "to enter a monitor that is already acquired by another thread. "
2748 "after waiting for it to be released by another thread. "
2812 "by some native method on the call stack. "
2814 "here will, in fact, be handled by a native method and not cause "
2816 "catch location returned here will ever be reached by the throwing "
2837 "notification is generated by the new thread some time before "
2857 "notification is generated by the dying thread before it terminates. "
2882 "If the event was generated by a debugger system thread, the "
2883 "value returned by this method is null, and if the requested "
2890 "created by the target VM during its normal (non-debug) operation. "
2956 "suspended by an event.")
3005 "by this VM.")
3126 "Step by the minimum possible amount (often a bytecode instruction). ")