Lines Matching refs:and

2  * Copyright (c) 1998, 2006, Oracle and/or its affiliates. All rights reserved.
5 * This code is free software; you can redistribute it and/or modify it
97 "the target VM through JNI, and system threads created "
99 "and threads that have completed their execution are not "
129 "The communication channel to the target VM is closed, and "
161 "identifiers in command and reply packets."
180 "suspends of both the virtual machine and individual threads are "
196 "Suspensions of the Virtual Machine and individual threads are "
212 "A thread death exception is not thrown and "
223 "Creates a new string object in the target VM and returns "
246 "Can the VM watch field modification, and therefore "
249 "Can the VM watch field access, and therefore "
270 "Retrieve the classpath and bootclasspath of the target VM. "
295 "be freed, and if garbage collection was "
341 "Responses to commands are never held and are not affected by this
374 "Can the VM watch field modification, and therefore "
377 "Can the VM watch field access, and therefore "
412 "and referring objects?")
519 "Both the JNI signature and the generic signature are "
674 "if present, and any synthetic methods created by the compiler. "
751 "Returns the classes and interfaces directly nested within this type."
757 (Repeat classes "The number of nested classes and interfaces"
777 "If the class is linked the PREPARED and VERIFIED bits in the returned status bits "
781 "The returned status bits are undefined for array types and for "
922 "if present, and any synthetic methods created by the compiler. "
984 "Returns the class file major and minor version numbers, as defined in the class "
999 "absent for primitive and array types.")
1028 "absent for primitive and array types.")
1058 "field's type and the field's type must be loaded. "
1105 "argument's type and the argument's type must be loaded. "
1180 "argument's type and the argument's type must be loaded. "
1287 "includes arguments and locals declared within the method. For "
1351 "The original and redefined methods are considered equivalent if their bytecodes are "
1352 "the same except for indices into the constant pool and the referenced constants are "
1376 "includes arguments and locals declared within the method. For "
1476 "field's type and the field's type must be loaded. "
1542 "argument's type and the argument's type must be loaded. "
1607 "The typical examination of variables, fields, and arrays "
1612 "pattern of garbage collection in the target VM and, "
1628 "and hence may be garbage collected. A call to this command is "
1719 "the virtual machine and individual threads are counted. Before "
1805 "and so on. The thread must be suspended, and the returned "
1830 "The thread must be suspended, and the returned "
1847 "The thread must be suspended, and the returned information is "
1871 "The thread must be suspended, and the returned information is "
1940 "The thread must be suspended, and the returned information is "
1978 "command and resumption of thread execution, the "
1986 "synchronized method) and locks acquired by entering "
2002 "return type type and the return type must be loaded. "
2063 "Returns the live threads and active thread groups directly contained "
2064 "in this thread group. Threads and thread groups in child "
2066 "A thread is alive if it has been started and has not yet been stopped. "
2128 "array component type and the array component type must be loaded. "
2152 "reference type defined by this loader and any types for which "
2187 "from the target VM. The two exceptions to this are the VM Start Event and "
2198 "Note that the order of events and command replies "
2200 "suspended and resumed. For example, if a "
2252 "preparation of the given reference type and any subtypes. "
2253 "For monitor wait and waited events, restricts the events "
2262 "class unload, thread start, and thread end. "
2272 "and waited events, the name of the class of the "
2276 "thread start and thread end. "
2280 "given class pattern and matches of patterns that "
2291 "unloaded class name is matched. For monitor wait and "
2296 "thread start and thread end. "
2300 "given class pattern and matches of patterns that "
2310 "step, and exception event kinds. "
2315 "Restricts reported exceptions by their class and "
2342 "field access and field modification event kinds only. "
2350 "depth and size constraints. "
2366 "and thread end. Introduced in JDWP version 1.4."
2385 "given pattern and matches of patterns that "
2414 "the specified event kind and requestID is cleared. If there isn't a matching event "
2415 "request the command is a no-op and does not result in an error. Automatically "
2416 "generated events do not have a corresponding event request and may not be cleared "
2480 "variable's type and the variable's type must be loaded. "
2525 "Pop the top-most stack frames of the thread stack, up to, and including 'frame'. "
2527 "The top-most stack frames are discarded and the stack frame previous to 'frame' "
2529 "are added back and if the invoke was not <code>invokestatic</code>, "
2631 "and in the same thread: "
2640 "The VM Start Event and VM Death Event are automatically generated events. "
2647 "also be requested using the EventRequest.Set command and thus multiple events "
2652 "Event the value of suspendPolicy is not defined and is therefore implementation "
2666 "received before the main thread is started and before any "
2668 "a significant amount of system code has executed and a number "
2697 "Method entry events are generated for both native and non-native "
2712 "Method exit events are generated for both native and non-native "
2724 "Method exit events are generated for both native and non-native "
2814 "here will, in fact, be handled by a native method and not cause "
2818 "a native frame between the current location and the catch location, "
2819 "the exception might be handled and cleared in that native method "
2824 "the code generated for <code>synchronized</code> and "
2841 "Method Entry Events and Method Exit Events might occur "
2883 "value returned by this method is null, and if the requested "
2886 "all threads will be suspended instead, and the "
2961 "and garbage collected.")
2981 "file and determined that the file is malformed "
2994 "and is now inconsistent.")
2999 "and canUnrestrictedlyRedefineClasses is false.")
3003 "and canUnrestrictedlyRedefineClasses is false.")
3009 =70 "The new class version has different modifiers and "
3010 "and canUnrestrictedlyRedefineClasses is false.")
3014 "than its counterpart in the old class version and "
3015 "and canUnrestrictedlyRedefineClasses is false.")
3022 (Constant OUT_OF_MEMORY =110 "The function needed to allocate memory and "